summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2011-03-05 11:34:43 +0000
committerJustin Lecher <jlec@gentoo.org>2011-03-05 11:34:43 +0000
commit807b025401beabb24a3bbb878f089f8996568c5c (patch)
tree904b459550bb668791575c878679e7ef6fbd0b86 /x11-libs/qwt
parentUse "nosmart" URI for initial branching. Merge changes from Emacs overlay. (diff)
downloadgentoo-2-807b025401beabb24a3bbb878f089f8996568c5c.tar.gz
gentoo-2-807b025401beabb24a3bbb878f089f8996568c5c.tar.bz2
gentoo-2-807b025401beabb24a3bbb878f089f8996568c5c.zip
Version Bump
(Portage version: 2.2.0_alpha26/cvs/Linux x86_64)
Diffstat (limited to 'x11-libs/qwt')
-rw-r--r--x11-libs/qwt/ChangeLog10
-rw-r--r--x11-libs/qwt/qwt-5.2.1.ebuild17
-rw-r--r--x11-libs/qwt/qwt-6.0.0_rc5.ebuild79
3 files changed, 96 insertions, 10 deletions
diff --git a/x11-libs/qwt/ChangeLog b/x11-libs/qwt/ChangeLog
index 0f01a8a9ea5b..8ee127ca096b 100644
--- a/x11-libs/qwt/ChangeLog
+++ b/x11-libs/qwt/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-libs/qwt
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/qwt/ChangeLog,v 1.80 2010/10/21 19:19:35 darkside Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qwt/ChangeLog,v 1.81 2011/03/05 11:34:43 jlec Exp $
+
+*qwt-6.0.0_rc5 (05 Mar 2011)
+
+ 05 Mar 2011; Justin Lecher <jlec@gentoo.org> qwt-5.2.1.ebuild,
+ +qwt-6.0.0_rc5.ebuild:
+ Version Bump
21 Oct 2010; Jeremy Olexa <darkside@gentoo.org> qwt-5.2.1.ebuild:
Add ~x86-macos, tested in bug 339524
diff --git a/x11-libs/qwt/qwt-5.2.1.ebuild b/x11-libs/qwt/qwt-5.2.1.ebuild
index f313fbadf1ae..c00e1017bf5a 100644
--- a/x11-libs/qwt/qwt-5.2.1.ebuild
+++ b/x11-libs/qwt/qwt-5.2.1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/qwt/qwt-5.2.1.ebuild,v 1.4 2010/10/21 19:19:35 darkside Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qwt/qwt-5.2.1.ebuild,v 1.5 2011/03/05 11:34:43 jlec Exp $
EAPI="3"
inherit eutils qt4
@@ -14,16 +14,17 @@ KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-macos"
SLOT="5"
IUSE="doc examples svg"
-DEPEND="x11-libs/qt-gui:4
+DEPEND="
+ x11-libs/qt-gui:4
doc? ( !<media-libs/coin-3.1.3[doc] )
svg? ( x11-libs/qt-svg:4 )"
RDEPEND="${DEPEND}"
src_prepare() {
cat > qwtconfig.pri <<-EOF
- target.path = "${EPREFIX}"/usr/$(get_libdir)
- headers.path = "${EPREFIX}"/usr/include/qwt5
- doc.path = "${EPREFIX}"/usr/share/doc/${PF}
+ target.path = "${EPREFIX}/usr/$(get_libdir)"
+ headers.path = "${EPREFIX}/usr/include/qwt5"
+ doc.path = "${EPREFIX}/usr/share/doc/${PF}"
CONFIG += qt warn_on thread release
CONFIG += QwtDll QwtPlot QwtWidgets QwtDesigner
VERSION = ${PV}
@@ -33,8 +34,8 @@ src_prepare() {
include( qwtconfig.pri )
TEMPLATE = app
MOC_DIR = moc
- INCLUDEPATH += "${EPREFIX}"/usr/include/qwt5
- DEPENDPATH += "${EPREFIX}"/usr/include/qwt5
+ INCLUDEPATH += "${EPREFIX}/usr/include/qwt5"
+ DEPENDPATH += "${EPREFIX}/usr/include/qwt5"
LIBS += -lqwt
EOF
sed -i -e 's:../qwtconfig:qwtconfig:' examples/examples.pro || die
diff --git a/x11-libs/qwt/qwt-6.0.0_rc5.ebuild b/x11-libs/qwt/qwt-6.0.0_rc5.ebuild
new file mode 100644
index 000000000000..93bb9d818113
--- /dev/null
+++ b/x11-libs/qwt/qwt-6.0.0_rc5.ebuild
@@ -0,0 +1,79 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qwt/qwt-6.0.0_rc5.ebuild,v 1.1 2011/03/05 11:34:43 jlec Exp $
+
+EAPI="3"
+inherit eutils qt4
+
+MY_P="${PN}-${PV/_/-}"
+
+DESCRIPTION="2D plotting library for Qt4"
+HOMEPAGE="http://qwt.sourceforge.net/"
+SRC_URI="mirror://sourceforge/project/${PN}/${PN}-beta/${PV/_/-}/${MY_P}.tar.bz2"
+
+LICENSE="qwt"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-macos"
+SLOT="5"
+IUSE="doc examples svg"
+
+DEPEND="
+ x11-libs/qt-gui:4
+ doc? ( !<media-libs/coin-3.1.3[doc] )
+ svg? ( x11-libs/qt-svg:4 )"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}"/${MY_P}
+
+src_prepare() {
+ cat > qwtconfig.pri <<-EOF
+ QWT_INSTALL_LIBS = "${EPREFIX}/usr/$(get_libdir)"
+ QWT_INSTALL_HEADERS = "${EPREFIX}/usr/include/qwt5"
+ QWT_INSTALL_DOCS = "${EPREFIX}/usr/share/doc/${PF}"
+ QWT_CONFIG += QwtDll QwtPlot QwtWidgets QwtDesigner
+ VERSION = ${PV}
+ QWT_INSTALL_PLUGINS = "${EPREFIX}/usr/$(get_libdir)/qt4/plugins/designer"
+ QWT_INSTALL_FEATURES = "${EPREFIX}/usr/$(get_libdir)/qt4/features"
+ EOF
+
+ cat > qwtbuild.pri <<-EOF
+ QWT_CONFIG += qt warn_on thread release no_keywords
+ EOF
+
+
+ # don't build examples - fix the qt files to build once installed
+ cat > examples/examples.pri <<-EOF
+ include( qwtconfig.pri )
+ TEMPLATE = app
+ MOC_DIR = moc
+ INCLUDEPATH += "${EPREFIX}/usr/include/qwt5"
+ DEPENDPATH += "${EPREFIX}/usr/include/qwt5"
+ LIBS += -lqwt
+ EOF
+ sed -i -e 's:../qwtconfig:qwtconfig:' examples/examples.pro || die
+ sed -i -e 's/target doc/target/' src/src.pro || die
+ qt4_src_prepare
+}
+
+src_configure() {
+ use svg && echo >> qwtconfig.pri "CONFIG += QwtSvg"
+ cp *.pri examples/ || die
+ eqmake4
+}
+src_compile() {
+ # split compilation to allow parallel building
+ emake sub-src || die "emake library failed"
+ emake || die "emake failed"
+}
+
+src_install () {
+ emake INSTALL_ROOT="${D}" install || die "emake install failed"
+ dodoc CHANGES README
+ insinto /usr/share/doc/${PF}
+ if use doc; then
+ doman doc/man/*/* || die
+ doins -r doc/html || die
+ fi
+ if use examples; then
+ doins -r examples || die
+ fi
+}