summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCaleb Tennis <caleb@gentoo.org>2004-12-28 18:33:46 +0000
committerCaleb Tennis <caleb@gentoo.org>2004-12-28 18:33:46 +0000
commitfe638393e24285716183952ceb14d9fac96d0ce8 (patch)
tree66f34d2adaa68fd56078499ae7914a1ab7186b09 /x11-libs/qt
parentMoved from app-sci/netcdf to sci-libs/netcdf (diff)
downloadgentoo-2-fe638393e24285716183952ceb14d9fac96d0ce8.tar.gz
gentoo-2-fe638393e24285716183952ceb14d9fac96d0ce8.tar.bz2
gentoo-2-fe638393e24285716183952ceb14d9fac96d0ce8.zip
Add a patch to remove rpaths
Diffstat (limited to 'x11-libs/qt')
-rw-r--r--x11-libs/qt/files/qt4-rpath.patch11
-rw-r--r--x11-libs/qt/qt-4.0.0_beta1-r1.ebuild3
2 files changed, 13 insertions, 1 deletions
diff --git a/x11-libs/qt/files/qt4-rpath.patch b/x11-libs/qt/files/qt4-rpath.patch
new file mode 100644
index 000000000000..9e0bb33c52a7
--- /dev/null
+++ b/x11-libs/qt/files/qt4-rpath.patch
@@ -0,0 +1,11 @@
+--- mkspecs/linux-g++/qmake.conf.orig 2004-12-28 12:33:06.729910672 -0500
++++ mkspecs/linux-g++/qmake.conf 2004-12-28 12:33:18.794076640 -0500
+@@ -57,7 +57,7 @@
+ QMAKE_LFLAGS_PLUGIN = $$QMAKE_LFLAGS_SHLIB
+ QMAKE_LFLAGS_SONAME = -Wl,-soname,
+ QMAKE_LFLAGS_THREAD =
+-QMAKE_RPATH = -Wl,-rpath,
++QMAKE_RPATH =
+
+ QMAKE_LIBS =
+ QMAKE_LIBS_DYNLOAD = -ldl
diff --git a/x11-libs/qt/qt-4.0.0_beta1-r1.ebuild b/x11-libs/qt/qt-4.0.0_beta1-r1.ebuild
index 12cbe5802cab..73e811788c52 100644
--- a/x11-libs/qt/qt-4.0.0_beta1-r1.ebuild
+++ b/x11-libs/qt/qt-4.0.0_beta1-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt/qt-4.0.0_beta1-r1.ebuild,v 1.1 2004/12/28 17:21:02 caleb Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt/qt-4.0.0_beta1-r1.ebuild,v 1.2 2004/12/28 18:33:46 caleb Exp $
inherit eutils flag-o-matic
@@ -79,6 +79,7 @@ src_unpack() {
cd ${S}
epatch ${FILESDIR}/qt4b1.patch
epatch ${FILESDIR}/qt4b1_20041228.patch
+ epatch ${FILESDIR}/qt4-rpath.patch
}
src_compile() {