summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDan Armak <danarmak@gentoo.org>2002-12-18 19:07:35 +0000
committerDan Armak <danarmak@gentoo.org>2002-12-18 19:07:35 +0000
commitfac9d4677d3e7b78a16479ffc708a898af40da61 (patch)
treec51c4ee426efe3ae2ba36e52b477379bc95cdd43 /x11-libs/qt
parentVersion bump, fixes segfault with mkfs.jfs (diff)
downloadgentoo-2-fac9d4677d3e7b78a16479ffc708a898af40da61.tar.gz
gentoo-2-fac9d4677d3e7b78a16479ffc708a898af40da61.tar.bz2
gentoo-2-fac9d4677d3e7b78a16479ffc708a898af40da61.zip
add pkg_postinst notice about remerging kedlibs
Diffstat (limited to 'x11-libs/qt')
-rw-r--r--x11-libs/qt/ChangeLog7
-rw-r--r--x11-libs/qt/qt-3.1.0-r1.ebuild10
-rw-r--r--x11-libs/qt/qt-3.1.0.ebuild10
-rw-r--r--x11-libs/qt/qt-3.1.1.ebuild12
4 files changed, 34 insertions, 5 deletions
diff --git a/x11-libs/qt/ChangeLog b/x11-libs/qt/ChangeLog
index bb94d2998c89..f6443c9b21a3 100644
--- a/x11-libs/qt/ChangeLog
+++ b/x11-libs/qt/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-libs/qt
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt/ChangeLog,v 1.42 2002/12/17 17:49:30 hannes Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt/ChangeLog,v 1.43 2002/12/18 19:07:34 danarmak Exp $
+
+ 18 Dec 2002; Dan Armak <danarmak@gentoo.org> ChangeLog :
+
+ Add pkg_postinst warning about remerging kdelibs after upgrading qt. Also
+ add -verbose parameter to configure in 3.1.1.
*qt-3.1.1 (17 Dec 2002)
diff --git a/x11-libs/qt/qt-3.1.0-r1.ebuild b/x11-libs/qt/qt-3.1.0-r1.ebuild
index 867f0f0e1818..df36b1600c12 100644
--- a/x11-libs/qt/qt-3.1.0-r1.ebuild
+++ b/x11-libs/qt/qt-3.1.0-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt/qt-3.1.0-r1.ebuild,v 1.9 2002/12/09 13:20:56 jmorgan Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt/qt-3.1.0-r1.ebuild,v 1.10 2002/12/18 19:07:35 danarmak Exp $
IUSE="cups nas postgres opengl mysql odbc gif"
@@ -156,3 +156,11 @@ src_install() {
done
}
+pkg_postinst() {
+
+ ewarn "If you upgraded from QT 3.0.x to 3.1.x, you should remerge any copies of kdelibs"
+ ewarn "you have installed. Otherwise, other kde packages may not compile properly."
+ ewarn "If you upgraded QT from 3.0.x to 3.1.x in the past but have not remerged kdelibs"
+ ewarn "since then, please do so now."
+
+} \ No newline at end of file
diff --git a/x11-libs/qt/qt-3.1.0.ebuild b/x11-libs/qt/qt-3.1.0.ebuild
index c421bbda78a1..3f381db9e888 100644
--- a/x11-libs/qt/qt-3.1.0.ebuild
+++ b/x11-libs/qt/qt-3.1.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt/qt-3.1.0.ebuild,v 1.5 2002/12/09 04:41:49 manson Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt/qt-3.1.0.ebuild,v 1.6 2002/12/18 19:07:35 danarmak Exp $
IUSE="cups nas postgres opengl mysql odbc gif"
@@ -158,3 +158,11 @@ will not work!"
}
+pkg_postinst() {
+
+ ewarn "If you upgraded from QT 3.0.x to 3.1.x, you should remerge any copies of kdelibs"
+ ewarn "you have installed. Otherwise, other kde packages may not compile properly."
+ ewarn "If you upgraded QT from 3.0.x to 3.1.x in the past but have not remerged kdelibs"
+ ewarn "since then, please do so now."
+
+} \ No newline at end of file
diff --git a/x11-libs/qt/qt-3.1.1.ebuild b/x11-libs/qt/qt-3.1.1.ebuild
index 7af9ca7f2bfa..334addcdf9ed 100644
--- a/x11-libs/qt/qt-3.1.1.ebuild
+++ b/x11-libs/qt/qt-3.1.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt/qt-3.1.1.ebuild,v 1.1 2002/12/17 17:49:30 hannes Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt/qt-3.1.1.ebuild,v 1.2 2002/12/18 19:07:35 danarmak Exp $
IUSE="cups nas postgres opengl mysql odbc gif"
@@ -85,7 +85,7 @@ src_compile() {
export YACC='byacc -d'
- ./configure -sm -thread -stl -system-zlib -system-libjpeg \
+ ./configure -sm -thread -stl -system-zlib -system-libjpeg -verbose \
-qt-imgfmt-{jpeg,mng,png} -tablet -system-libmng \
-system-libpng -ldl -lpthread -xft -platform linux-g++ -xplatform \
linux-g++ -prefix ${QTBASE} -fast ${myconf} || die
@@ -153,3 +153,11 @@ src_install() {
done
}
+pkg_postinst() {
+
+ ewarn "If you upgraded from QT 3.0.x to 3.1.x, you should remerge any copies of kdelibs"
+ ewarn "you have installed. Otherwise, other kde packages may not compile properly."
+ ewarn "If you upgraded QT from 3.0.x to 3.1.x in the past but have not remerged kdelibs"
+ ewarn "since then, please do so now."
+
+}