summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDan Armak <danarmak@gentoo.org>2002-05-07 17:03:50 +0000
committerDan Armak <danarmak@gentoo.org>2002-05-07 17:03:50 +0000
commit5da6a6ef25d22eae605d1a4dabc8522c71cd218a (patch)
tree18e61ab234bca6d15a93599463f02be3439c0d40 /x11-libs/qt
parentNew upstream version. (diff)
downloadgentoo-2-5da6a6ef25d22eae605d1a4dabc8522c71cd218a.tar.gz
gentoo-2-5da6a6ef25d22eae605d1a4dabc8522c71cd218a.tar.bz2
gentoo-2-5da6a6ef25d22eae605d1a4dabc8522c71cd218a.zip
fix bug #2470 (qt not building with nas)
Diffstat (limited to 'x11-libs/qt')
-rw-r--r--x11-libs/qt/ChangeLog10
-rw-r--r--x11-libs/qt/files/digest-qt-3.0.4-r11
-rw-r--r--x11-libs/qt/qt-3.0.4-r1.ebuild128
-rw-r--r--x11-libs/qt/qt-3.0.4.ebuild7
4 files changed, 140 insertions, 6 deletions
diff --git a/x11-libs/qt/ChangeLog b/x11-libs/qt/ChangeLog
index f8d7066404c2..c179059713b0 100644
--- a/x11-libs/qt/ChangeLog
+++ b/x11-libs/qt/ChangeLog
@@ -1,11 +1,15 @@
# ChangeLog for x11-libs/qt
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt/ChangeLog,v 1.12 2002/05/05 12:03:51 danarmak Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt/ChangeLog,v 1.13 2002/05/07 17:03:50 danarmak Exp $
-*qt-3.0.3 (5 May 2002)
+*qt-3.0.4-r1 (7 May 2002)
- 5 May 2002; Dan Armak <danarmak@gentoo.org> changelog:
+ 7 May 2002; Dan Armak <danarmak@gentoo.org> changelog:
+ Fix bug #2470 (qt not compiling with USE nas on)
+
+*qt-3.0.4 (5 May 2002)
+ 5 May 2002; Dan Armak <danarmak@gentoo.org> changelog:
qt-3.0.4 (bugfix release).
30 Apr 2002; Dan Armak <danarmak@gentoo.org> changelog:
diff --git a/x11-libs/qt/files/digest-qt-3.0.4-r1 b/x11-libs/qt/files/digest-qt-3.0.4-r1
new file mode 100644
index 000000000000..9a194bc08cac
--- /dev/null
+++ b/x11-libs/qt/files/digest-qt-3.0.4-r1
@@ -0,0 +1 @@
+MD5 d87aa032f83aa4dea40f9906e2aa7608 qt-x11-free-3.0.4.tar.gz 15198015
diff --git a/x11-libs/qt/qt-3.0.4-r1.ebuild b/x11-libs/qt/qt-3.0.4-r1.ebuild
new file mode 100644
index 000000000000..09e99bf523a0
--- /dev/null
+++ b/x11-libs/qt/qt-3.0.4-r1.ebuild
@@ -0,0 +1,128 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Dan Armak <danarmak@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt/qt-3.0.4-r1.ebuild,v 1.1 2002/05/07 17:03:50 danarmak Exp $
+
+S=${WORKDIR}/qt-x11-free-${PV}
+
+DESCRIPTION="QT version ${PV}"
+SLOT="3"
+
+SRC_URI="ftp://ftp.trolltech.com/pub/qt/source/qt-x11-free-${PV}.tar.gz"
+
+HOMEPAGE="http://www.trolltech.com/"
+
+DEPEND="virtual/x11
+ media-libs/libpng
+ >=media-libs/libmng-1.0.0
+ gif? ( media-libs/giflib
+ media-libs/libungif )
+ nas? ( >=media-libs/nas-1.4.1 )
+ odbc? ( >=dev-db/unixODBC-2.0 )
+ mysql? ( >=dev-db/mysql-3.2.10 )
+ opengl? ( virtual/opengl virtual/glu )
+ postgres? ( =dev-db/postgresql-7.1.3* )"
+
+
+QTBASE=/usr/qt/3
+export QTDIR=${S}
+
+src_unpack() {
+
+ export QTDIR=${S}
+
+ unpack ${A}
+
+ cd ${S}
+ cp configure configure.orig
+ sed -e 's:read acceptance:acceptance=yes:' \
+ -e 's:|-repeater|:|-nas-sound|-repeater|:' configure.orig > configure
+
+}
+
+src_compile() {
+
+ export QTDIR=${S}
+
+ export LDFLAGS="-ldl"
+
+ use nas && myconf="${myconf} -nas-sound"
+ use gif && myconf="${myconf} -qt-gif"
+ use mysql && myconf="${myconf} -plugin-sql-mysql -I/usr/include/mysql -L/usr/lib/mysql"
+ use postgres && myconf="${myconf} -plugin-sql-psql -I/usr/include/postgresql -I/usr/include/postgresql/libpq -L/usr/lib"
+ use odbc && myconf="${myconf} -plugin-sql-odbc"
+ [ -n "$DEBUG" ] && myconf="${myconf} -debug" || myconf="${myconf} -release -no-g++-exceptions"
+
+ # avoid wasting time building things we won't install
+ rm -rf tutorial examples
+
+ ./configure -sm -thread -stl -system-zlib -system-libjpeg -qt-imgfmt-{jpeg,mng,png} ${myconf} \
+ -system-libmng -system-libpng -ldl -lpthread -xft || die
+
+ export QTDIR=${S}
+
+ emake src-qmake src-moc sub-src sub-tools || die
+
+}
+
+src_install() {
+
+
+ export QTDIR=${S}
+
+ cd ${S}
+
+ # binaries
+ into $QTBASE
+ dobin bin/*
+
+ # libraries
+ dolib lib/libqt-mt.so.${PV} lib/libqui.so.1.0.0 lib/libeditor.so.1.0.0
+ cd ${D}$QTBASE/lib
+ for x in libqui.so libeditor.so
+ do
+ ln -s $x.1.0.0 $x.1.0
+ ln -s $x.1.0 $x.1
+ ln -s $x.1 $x
+ done
+
+ # version symlinks - 3.0.3->3.0->3->.so
+ ln -s libqt-mt.so.${PV} libqt-mt.so.3.0
+ ln -s libqt-mt.so.3.0 libqt-mt.so.3
+ ln -s libqt-mt.so.3 libqt-mt.so
+
+ # libqt -> libqt-mt symlinks
+ ln -s libqt-mt.so.${PV} libqt.so.${PV}
+ ln -s libqt-mt.so.3.0 libqt.so.3.0
+ ln -s libqt-mt.so.3 libqt.so.3
+ ln -s libqt-mt.so libqt.so
+
+ # includes
+ cd ${S}
+ dodir ${QTBASE}/include/private
+ cp include/* ${D}/${QTBASE}/include/
+ cp include/private/* ${D}/${QTBASE}/include/private/
+
+ # misc
+ insinto /etc/env.d
+ doins ${FILESDIR}/{45qt3,50qtdir3}
+
+ # misc build reqs
+ dodir ${QTBASE}/mkspecs
+ cp -R ${S}/mkspecs/linux-g++ ${D}/${QTBASE}/mkspecs/
+
+ sed -e "s:${D}::g" \
+ -e "s:qt-x11-free-3.0.1::g" \
+ -e "s:${WORKDIR}:${QTBASE}:" \
+ -e "s:/usr/local/qt:${QTBASE}:" \
+ ${S}/.qmake.cache > ${D}${QTBASE}/.qmake.cache
+
+ # plugins
+ cd ${S}
+ plugins=`find plugins -name "lib*.so" -print`
+ for x in $plugins; do
+ insinto ${QTBASE}/`dirname $x`
+ doins $x
+ done
+
+}
diff --git a/x11-libs/qt/qt-3.0.4.ebuild b/x11-libs/qt/qt-3.0.4.ebuild
index 31197f1fcfcd..e5870ee3a689 100644
--- a/x11-libs/qt/qt-3.0.4.ebuild
+++ b/x11-libs/qt/qt-3.0.4.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Author Dan Armak <danarmak@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt/qt-3.0.4.ebuild,v 1.1 2002/05/05 12:03:51 danarmak Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt/qt-3.0.4.ebuild,v 1.2 2002/05/07 17:03:50 danarmak Exp $
S=${WORKDIR}/qt-x11-free-${PV}
@@ -35,7 +35,8 @@ src_unpack() {
cd ${S}
cp configure configure.orig
- sed -e "s:read acceptance:acceptance=yes:" configure.orig > configure
+ sed -e 's:read acceptance:acceptance=yes:' \
+ -e 's:|-repeater|:|-nas-sound|-repeater|:' configure.orig > configure
}
@@ -45,7 +46,7 @@ src_compile() {
export LDFLAGS="-ldl"
- use nas && myconf="${myconf} -system-nas-sound"
+ use nas && myconf="${myconf} -nas-sound"
use gif && myconf="${myconf} -qt-gif"
use mysql && myconf="${myconf} -plugin-sql-mysql -I/usr/include/mysql -L/usr/lib/mysql"
use postgres && myconf="${myconf} -plugin-sql-psql -I/usr/include/postgresql -I/usr/include/postgresql/libpq -L/usr/lib"