summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBen de Groot <yngwin@gentoo.org>2009-08-17 20:12:15 +0000
committerBen de Groot <yngwin@gentoo.org>2009-08-17 20:12:15 +0000
commit51d74ff2ed9f04952045996c69d48a6da1bf264c (patch)
tree8869ca107ec72ad021f1c9815580afe223dc5eee /x11-libs/qt-webkit
parentclean up (diff)
downloadgentoo-2-51d74ff2ed9f04952045996c69d48a6da1bf264c.tar.gz
gentoo-2-51d74ff2ed9f04952045996c69d48a6da1bf264c.tar.bz2
gentoo-2-51d74ff2ed9f04952045996c69d48a6da1bf264c.zip
Remove old. Add patch for bug 281821, revbump all relevant versions.
(Portage version: 2.2_rc38/cvs/Linux x86_64)
Diffstat (limited to 'x11-libs/qt-webkit')
-rw-r--r--x11-libs/qt-webkit/ChangeLog11
-rw-r--r--x11-libs/qt-webkit/files/webkit-CVE-2009-1725.patch22
-rw-r--r--x11-libs/qt-webkit/qt-webkit-4.4.2-r2.ebuild (renamed from x11-libs/qt-webkit/qt-webkit-4.4.2.ebuild)9
-rw-r--r--x11-libs/qt-webkit/qt-webkit-4.5.1-r1.ebuild39
-rw-r--r--x11-libs/qt-webkit/qt-webkit-4.5.2-r1.ebuild39
5 files changed, 117 insertions, 3 deletions
diff --git a/x11-libs/qt-webkit/ChangeLog b/x11-libs/qt-webkit/ChangeLog
index aede3c798218..8fa6b198bee0 100644
--- a/x11-libs/qt-webkit/ChangeLog
+++ b/x11-libs/qt-webkit/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for x11-libs/qt-webkit
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-webkit/ChangeLog,v 1.44 2009/06/27 19:23:40 yngwin Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-webkit/ChangeLog,v 1.45 2009/08/17 20:12:14 yngwin Exp $
+
+*qt-webkit-4.5.2-r1 (17 Aug 2009)
+*qt-webkit-4.5.1-r1 (17 Aug 2009)
+*qt-webkit-4.4.2-r2 (17 Aug 2009)
+
+ 17 Aug 2009; Ben de Groot <yngwin@gentoo.org> -qt-webkit-4.4.2.ebuild,
+ +qt-webkit-4.4.2-r2.ebuild, +qt-webkit-4.5.1-r1.ebuild,
+ +qt-webkit-4.5.2-r1.ebuild, +files/webkit-CVE-2009-1725.patch:
+ Remove old. Add patch for bug 281821, revbump all relevant versions.
*qt-webkit-4.5.2 (27 Jun 2009)
diff --git a/x11-libs/qt-webkit/files/webkit-CVE-2009-1725.patch b/x11-libs/qt-webkit/files/webkit-CVE-2009-1725.patch
new file mode 100644
index 000000000000..80e45ad9770c
--- /dev/null
+++ b/x11-libs/qt-webkit/files/webkit-CVE-2009-1725.patch
@@ -0,0 +1,22 @@
+Index: master/src/3rdparty/webkit/WebCore/html/HTMLTokenizer.cpp
+===================================================================
+--- a/master/src/3rdparty/webkit/WebCore/html/HTMLTokenizer.cpp
++++ b/master/src/3rdparty/webkit/WebCore/html/HTMLTokenizer.cpp
+@@ -865,5 +865,7 @@
+ } else {
+ // FIXME: We should eventually colorize entities by sending them as a special token.
+- checkBuffer(11);
++ // 12 bytes required: up to 10 bytes in m_cBuffer plus the
++ // leading '&' and trailing ';'
++ checkBuffer(12);
+ *dest++ = '&';
+ for (unsigned i = 0; i < cBufferPos; i++)
+@@ -876,5 +878,7 @@
+ }
+ } else {
+- checkBuffer(10);
++ // 11 bytes required: up to 10 bytes in m_cBuffer plus the
++ // leading '&'
++ checkBuffer(11);
+ // ignore the sequence, add it to the buffer as plaintext
+ *dest++ = '&';
diff --git a/x11-libs/qt-webkit/qt-webkit-4.4.2.ebuild b/x11-libs/qt-webkit/qt-webkit-4.4.2-r2.ebuild
index b076c3d7a724..b30dac81b58a 100644
--- a/x11-libs/qt-webkit/qt-webkit-4.4.2.ebuild
+++ b/x11-libs/qt-webkit/qt-webkit-4.4.2-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-webkit/qt-webkit-4.4.2.ebuild,v 1.9 2009/04/11 16:24:10 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-webkit/qt-webkit-4.4.2-r2.ebuild,v 1.1 2009/08/17 20:12:14 yngwin Exp $
EAPI="1"
inherit qt4-build flag-o-matic toolchain-funcs
@@ -10,7 +10,7 @@ HOMEPAGE="http://www.trolltech.com/"
LICENSE="|| ( GPL-3 GPL-2 )"
SLOT="4"
-KEYWORDS="alpha amd64 hppa ia64 ~mips ppc ppc64 -sparc x86"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~mips ~ppc ~ppc64 -sparc ~x86"
IUSE=""
DEPEND="~x11-libs/qt-gui-${PV}
@@ -31,6 +31,11 @@ src_unpack() {
[[ $(tc-arch) == "ppc64" ]] && append-flags -mminimal-toc #241900
qt4-build_src_unpack
+
+ # Apply bugfix patches from qt-copy (KDE)
+ epatch "${FILESDIR}"/0249-webkit-stale-frame-pointer.diff
+ # Security patch from upstream, bug 281821
+ epatch "${FILESDIR}"/webkit-CVE-2009-1725.patch
}
src_compile() {
diff --git a/x11-libs/qt-webkit/qt-webkit-4.5.1-r1.ebuild b/x11-libs/qt-webkit/qt-webkit-4.5.1-r1.ebuild
new file mode 100644
index 000000000000..f4cbe4f9fc0c
--- /dev/null
+++ b/x11-libs/qt-webkit/qt-webkit-4.5.1-r1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-webkit/qt-webkit-4.5.1-r1.ebuild,v 1.1 2009/08/17 20:12:14 yngwin Exp $
+
+EAPI="2"
+inherit qt4-build flag-o-matic
+
+DESCRIPTION="The Webkit module for the Qt toolkit"
+SLOT="4"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 -sparc ~x86 ~x86-fbsd"
+IUSE="kde"
+
+DEPEND="~x11-libs/qt-core-${PV}[debug=,ssl]
+ ~x11-libs/qt-gui-${PV}[debug=]
+ !kde? ( || ( ~x11-libs/qt-phonon-${PV}:${SLOT}[debug=] media-sound/phonon ) )
+ kde? ( media-sound/phonon )"
+RDEPEND="${DEPEND}"
+
+QT4_TARGET_DIRECTORIES="src/3rdparty/webkit/WebCore tools/designer/src/plugins/qwebview"
+QT4_EXTRACT_DIRECTORIES="
+include/
+src/
+tools/"
+QCONFIG_ADD="webkit"
+QCONFIG_DEFINE="QT_WEBKIT"
+
+src_prepare() {
+ [[ $(tc-arch) == "ppc64" ]] && append-flags -mminimal-toc #241900
+ qt4-build_src_prepare
+ # Security patch from upstream, bug 281821
+ epatch "${FILESDIR}"/webkit-CVE-2009-1725.patch
+}
+
+src_configure() {
+ # This fixes relocation overflows on alpha
+ use alpha && append-ldflags "-Wl,--no-relax"
+ myconf="${myconf} -webkit"
+ qt4-build_src_configure
+}
diff --git a/x11-libs/qt-webkit/qt-webkit-4.5.2-r1.ebuild b/x11-libs/qt-webkit/qt-webkit-4.5.2-r1.ebuild
new file mode 100644
index 000000000000..b4a6d872d86e
--- /dev/null
+++ b/x11-libs/qt-webkit/qt-webkit-4.5.2-r1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-webkit/qt-webkit-4.5.2-r1.ebuild,v 1.1 2009/08/17 20:12:14 yngwin Exp $
+
+EAPI="2"
+inherit qt4-build flag-o-matic
+
+DESCRIPTION="The Webkit module for the Qt toolkit"
+SLOT="4"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 -sparc ~x86 ~x86-fbsd"
+IUSE="kde"
+
+DEPEND="~x11-libs/qt-core-${PV}[debug=,ssl]
+ ~x11-libs/qt-gui-${PV}[debug=]
+ !kde? ( || ( ~x11-libs/qt-phonon-${PV}:${SLOT}[debug=] media-sound/phonon ) )
+ kde? ( media-sound/phonon )"
+RDEPEND="${DEPEND}"
+
+QT4_TARGET_DIRECTORIES="src/3rdparty/webkit/WebCore tools/designer/src/plugins/qwebview"
+QT4_EXTRACT_DIRECTORIES="
+include/
+src/
+tools/"
+QCONFIG_ADD="webkit"
+QCONFIG_DEFINE="QT_WEBKIT"
+
+src_prepare() {
+ [[ $(tc-arch) == "ppc64" ]] && append-flags -mminimal-toc #241900
+ qt4-build_src_prepare
+ # Security patch from upstream, bug 281821
+ epatch "${FILESDIR}"/webkit-CVE-2009-1725.patch
+}
+
+src_configure() {
+ # This fixes relocation overflows on alpha
+ use alpha && append-ldflags "-Wl,--no-relax"
+ myconf="${myconf} -webkit"
+ qt4-build_src_configure
+}