summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2009-04-27 19:51:15 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2009-04-27 19:51:15 +0000
commit133e9d4d8a53206fe7b52cd0bc1f9412bed7154f (patch)
tree9aba3bb030e16bca8c99ee9b7b65311684d0e269 /x11-libs/qt-webkit/qt-webkit-4.5.1.ebuild
parentBump. Thanks to Daniel Pielmeier for reminding me. Import some plnn-handling ... (diff)
downloadgentoo-2-133e9d4d8a53206fe7b52cd0bc1f9412bed7154f.tar.gz
gentoo-2-133e9d4d8a53206fe7b52cd0bc1f9412bed7154f.tar.bz2
gentoo-2-133e9d4d8a53206fe7b52cd0bc1f9412bed7154f.zip
Qt 4.5.1 release version bump
(Portage version: 2.2_rc31/cvs/Linux x86_64)
Diffstat (limited to 'x11-libs/qt-webkit/qt-webkit-4.5.1.ebuild')
-rw-r--r--x11-libs/qt-webkit/qt-webkit-4.5.1.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/x11-libs/qt-webkit/qt-webkit-4.5.1.ebuild b/x11-libs/qt-webkit/qt-webkit-4.5.1.ebuild
new file mode 100644
index 000000000000..42a7e619d6dd
--- /dev/null
+++ b/x11-libs/qt-webkit/qt-webkit-4.5.1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-webkit/qt-webkit-4.5.1.ebuild,v 1.1 2009/04/27 19:51:15 hwoarang Exp $
+
+EAPI="2"
+inherit qt4-build
+
+DESCRIPTION="The Webkit module for the Qt toolkit"
+SLOT="4"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 -sparc ~x86 ~x86-fbsd"
+IUSE=""
+
+DEPEND="~x11-libs/qt-core-${PV}[debug=,ssl]
+ ~x11-libs/qt-gui-${PV}[debug=]
+ || ( ~x11-libs/qt-phonon-${PV}:${SLOT}[debug=] media-sound/phonon )"
+RDEPEND="${DEPEND}"
+
+QT4_TARGET_DIRECTORIES="src/3rdparty/webkit/WebCore tools/designer/src/plugins/qwebview"
+QT4_EXTRACT_DIRECTORIES="
+include/
+src/
+tools/"
+QCONFIG_ADD="webkit"
+QCONFIG_DEFINE="QT_WEBKIT"
+
+src_prepare() {
+ [[ $(tc-arch) == "ppc64" ]] && append-flags -mminimal-toc #241900
+ qt4-build_src_prepare
+}
+
+src_configure() {
+ myconf="${myconf} -webkit"
+ qt4-build_src_configure
+}