summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2009-03-04 16:44:44 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2009-03-04 16:44:44 +0000
commit796640e10604016172d3719cc5b81dbd61f05f36 (patch)
treee56bfe5ac75519e453157c35954679c40a4fc4e1 /x11-libs/qt-test
parentMarking curl-7.19.4 ppc64 for bug 260361 (diff)
downloadgentoo-2-796640e10604016172d3719cc5b81dbd61f05f36.tar.gz
gentoo-2-796640e10604016172d3719cc5b81dbd61f05f36.tar.bz2
gentoo-2-796640e10604016172d3719cc5b81dbd61f05f36.zip
Adding iconv use flag ( bug #260145 )
(Portage version: 2.2_rc23/cvs/Linux i686)
Diffstat (limited to 'x11-libs/qt-test')
-rw-r--r--x11-libs/qt-test/ChangeLog6
-rw-r--r--x11-libs/qt-test/qt-test-4.5.0_rc1.ebuild8
2 files changed, 9 insertions, 5 deletions
diff --git a/x11-libs/qt-test/ChangeLog b/x11-libs/qt-test/ChangeLog
index 247a6d7ea20b..61b2d9b16804 100644
--- a/x11-libs/qt-test/ChangeLog
+++ b/x11-libs/qt-test/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for x11-libs/qt-test
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-test/ChangeLog,v 1.23 2009/03/01 11:00:58 alexxy Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-test/ChangeLog,v 1.24 2009/03/04 16:44:44 hwoarang Exp $
+
+ 04 Mar 2009; Markos Chandras <hwoarang@gentoo.org>
+ qt-test-4.5.0_rc1.ebuild:
+ Adding iconv use flag ( bug #260145 )
01 Mar 2009; Alexey Shvetsov <alexxy@gentoo.org> qt-test-4.4.2.ebuild,
qt-test-4.5.0_rc1.ebuild:
diff --git a/x11-libs/qt-test/qt-test-4.5.0_rc1.ebuild b/x11-libs/qt-test/qt-test-4.5.0_rc1.ebuild
index bfee46afdf31..f13e5c1763d3 100644
--- a/x11-libs/qt-test/qt-test-4.5.0_rc1.ebuild
+++ b/x11-libs/qt-test/qt-test-4.5.0_rc1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-test/qt-test-4.5.0_rc1.ebuild,v 1.3 2009/03/01 11:00:58 alexxy Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-test/qt-test-4.5.0_rc1.ebuild,v 1.4 2009/03/04 16:44:44 hwoarang Exp $
EAPI="2"
inherit qt4-build
@@ -9,7 +9,7 @@ DESCRIPTION="The testing framework module for the Qt toolkit"
LICENSE="|| ( GPL-3 GPL-2 )"
SLOT="4"
KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
-IUSE=""
+IUSE="+iconv"
DEPEND="~x11-libs/qt-core-${PV}[debug=]"
RDEPEND="${DEPEND}"
@@ -21,9 +21,9 @@ include/QtCore/
src/corelib/"
src_configure() {
- myconf="${myconf} -no-xkb -no-fontconfig -no-xrender -no-xrandr
+ myconf="${myconf} $(qt_use iconv) -no-xkb -no-fontconfig -no-xrender -no-xrandr
-no-xfixes -no-xcursor -no-xinerama -no-xshape -no-sm -no-opengl
- -no-nas-sound -no-dbus -iconv -no-cups -no-nis -no-gif -no-libpng
+ -no-nas-sound -no-dbus -no-cups -no-nis -no-gif -no-libpng
-no-libmng -no-libjpeg -no-openssl -system-zlib -no-webkit -no-phonon
-no-qt3support -no-xmlpatterns -no-freetype -no-libtiff -no-accessibility
-no-fontconfig -no-glib -no-opengl -no-svg"