summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIngmar Vanhassel <ingmar@gentoo.org>2008-05-15 12:49:46 +0000
committerIngmar Vanhassel <ingmar@gentoo.org>2008-05-15 12:49:46 +0000
commit299f3a256c856a3f4171bfeb3448a09be5512d04 (patch)
treea982e473aca89e86af41c4b15f5097561736f19d /x11-libs/qt-test
parentStable on ppc64; bug #221063 (diff)
downloadgentoo-2-299f3a256c856a3f4171bfeb3448a09be5512d04.tar.gz
gentoo-2-299f3a256c856a3f4171bfeb3448a09be5512d04.tar.bz2
gentoo-2-299f3a256c856a3f4171bfeb3448a09be5512d04.zip
Version bump to Qt-4.4.0.
(Portage version: 2.1.5)
Diffstat (limited to 'x11-libs/qt-test')
-rw-r--r--x11-libs/qt-test/ChangeLog7
-rw-r--r--x11-libs/qt-test/qt-test-4.4.0.ebuild31
2 files changed, 37 insertions, 1 deletions
diff --git a/x11-libs/qt-test/ChangeLog b/x11-libs/qt-test/ChangeLog
index f8c4b211b4c7..3c32b6da1881 100644
--- a/x11-libs/qt-test/ChangeLog
+++ b/x11-libs/qt-test/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-libs/qt-test
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-test/ChangeLog,v 1.4 2008/04/10 13:44:11 ingmar Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-test/ChangeLog,v 1.5 2008/05/15 12:49:46 ingmar Exp $
+
+*qt-test-4.4.0 (15 May 2008)
+
+ 15 May 2008; Ingmar Vanhassel <ingmar@gentoo.org> +qt-test-4.4.0.ebuild:
+ Version bump to Qt-4.4.0.
10 Apr 2008; Ingmar Vanhassel <ingmar@gentoo.org>
-qt-test-4.4.0_beta1.ebuild, +qt-test-4.4.0_rc1.ebuild:
diff --git a/x11-libs/qt-test/qt-test-4.4.0.ebuild b/x11-libs/qt-test/qt-test-4.4.0.ebuild
new file mode 100644
index 000000000000..005791179b21
--- /dev/null
+++ b/x11-libs/qt-test/qt-test-4.4.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-test/qt-test-4.4.0.ebuild,v 1.1 2008/05/15 12:49:46 ingmar Exp $
+
+inherit qt4-build
+
+DESCRIPTION="The testing framework module for the Qt toolkit."
+HOMEPAGE="http://www.trolltech.com/"
+
+LICENSE="|| ( QPL-1.0 GPL-3 GPL-2 )"
+SLOT="4"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="~x11-libs/qt-core-${PV}"
+RDEPEND="${DEPEND}"
+
+QT4_TARGET_DIRECTORIES="src/testlib"
+QT4_EXTRACT_DIRECTORIES="${QT4_TARGET_DIRECTORIES}"
+
+src_compile() {
+ local myconf
+ myconf="${myconf} -no-xkb -no-tablet -no-fontconfig -no-xrender -no-xrandr
+ -no-xfixes -no-xcursor -no-xinerama -no-xshape -no-sm -no-opengl
+ -no-nas-sound -no-dbus -iconv -no-cups -no-nis -no-gif -no-libpng
+ -no-libmng -no-libjpeg -no-openssl -system-zlib -no-webkit -no-phonon
+ -no-qt3support -no-xmlpatterns -no-freetype -no-libtiff -no-accessibility
+ -no-fontconfig -no-glib -no-opengl -no-svg"
+
+ qt4-build_src_compile
+}