summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBen de Groot <yngwin@gentoo.org>2009-06-27 19:23:05 +0000
committerBen de Groot <yngwin@gentoo.org>2009-06-27 19:23:05 +0000
commit027f39bb11a60d9ec557546ab068a11e0b8adea4 (patch)
treed50c3e96c339145c6267cefcf5e14e60989331e0 /x11-libs/qt-test
parentQt 4.5.2 release version bump (diff)
downloadgentoo-2-027f39bb11a60d9ec557546ab068a11e0b8adea4.tar.gz
gentoo-2-027f39bb11a60d9ec557546ab068a11e0b8adea4.tar.bz2
gentoo-2-027f39bb11a60d9ec557546ab068a11e0b8adea4.zip
Qt 4.5.2 release version bump
(Portage version: 2.2_rc33/cvs/Linux x86_64)
Diffstat (limited to 'x11-libs/qt-test')
-rw-r--r--x11-libs/qt-test/ChangeLog8
-rw-r--r--x11-libs/qt-test/files/qt-4.5-nolibx11.diff18
-rw-r--r--x11-libs/qt-test/qt-test-4.5.2.ebuild34
3 files changed, 59 insertions, 1 deletions
diff --git a/x11-libs/qt-test/ChangeLog b/x11-libs/qt-test/ChangeLog
index db8954f6d071..7e9e4d6bc050 100644
--- a/x11-libs/qt-test/ChangeLog
+++ b/x11-libs/qt-test/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-libs/qt-test
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-test/ChangeLog,v 1.34 2009/06/08 22:36:16 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-test/ChangeLog,v 1.35 2009/06/27 19:23:05 yngwin Exp $
+
+*qt-test-4.5.2 (27 Jun 2009)
+
+ 27 Jun 2009; Ben de Groot <yngwin@gentoo.org> +files/qt-4.5-nolibx11.diff,
+ +qt-test-4.5.2.ebuild:
+ Version bump
08 Jun 2009; Jeroen Roovers <jer@gentoo.org> qt-test-4.5.1.ebuild:
Stable for HPPA (bug #266201).
diff --git a/x11-libs/qt-test/files/qt-4.5-nolibx11.diff b/x11-libs/qt-test/files/qt-4.5-nolibx11.diff
new file mode 100644
index 000000000000..f94be77b742d
--- /dev/null
+++ b/x11-libs/qt-test/files/qt-4.5-nolibx11.diff
@@ -0,0 +1,18 @@
+diff -Nur qt-x11-opensource-src-4.5.1-orig/configure qt-x11-opensource-src-4.5.1/configure
+--- qt-x11-opensource-src-4.5.1-orig/configure 2009-04-22 02:57:35.000000000 +0300
++++ qt-x11-opensource-src-4.5.1/configure 2009-06-03 00:59:44.108245373 +0300
+@@ -4733,14 +4733,6 @@
+ X11TESTS_FLAGS="$X11TESTS_FLAGS -fpermissive"
+ fi
+
+- # Check we actually have X11 :-)
+- if ! "$unixtests/compile.test" "$XQMAKESPEC" "$QMAKE_CONFIG" $OPT_VERBOSE "$relpath" "$outpath" config.tests/x11/xlib "XLib" $L_FLAGS $I_FLAGS $l_FLAGS $X11TESTS_FLAGS; then
+- echo "Basic XLib functionality test failed!"
+- echo " You might need to modify the include and library search paths by editing"
+- echo " QMAKE_INCDIR_X11 and QMAKE_LIBDIR_X11 in ${XQMAKESPEC}."
+- exit 1
+- fi
+-
+ # auto-detect OpenGL support (es1 = OpenGL ES 1.x Common, es1cl = ES 1.x common lite, es2 = OpenGL ES 2.x)
+ if [ "$CFG_OPENGL" = "auto" ] || [ "$CFG_OPENGL" = "yes" ]; then
+ if "$unixtests/compile.test" "$XQMAKESPEC" "$QMAKE_CONFIG" $OPT_VERBOSE "$relpath" "$outpath" config.tests/x11/opengl "OpenGL" $L_FLAGS $I_FLAGS $l_FLAGS $X11TESTS_FLAGS; then
diff --git a/x11-libs/qt-test/qt-test-4.5.2.ebuild b/x11-libs/qt-test/qt-test-4.5.2.ebuild
new file mode 100644
index 000000000000..da6fc08b1033
--- /dev/null
+++ b/x11-libs/qt-test/qt-test-4.5.2.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-test/qt-test-4.5.2.ebuild,v 1.1 2009/06/27 19:23:05 yngwin Exp $
+
+EAPI="2"
+inherit qt4-build
+
+DESCRIPTION="The testing framework module for the Qt toolkit"
+SLOT="4"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="iconv"
+
+DEPEND="~x11-libs/qt-core-${PV}[debug=]"
+RDEPEND="${DEPEND}"
+
+QT4_TARGET_DIRECTORIES="src/testlib"
+QT4_EXTRACT_DIRECTORIES="${QT4_TARGET_DIRECTORIES}
+include/QtTest/
+include/QtCore/
+src/corelib/"
+
+PATCHES=(
+ "${FILESDIR}/qt-4.5-nolibx11.diff"
+)
+
+src_configure() {
+ myconf="${myconf} $(qt_use iconv) -no-xkb -no-fontconfig -no-xrender -no-xrandr
+ -no-xfixes -no-xcursor -no-xinerama -no-xshape -no-sm -no-opengl
+ -no-nas-sound -no-dbus -no-cups -no-nis -no-gif -no-libpng
+ -no-libmng -no-libjpeg -no-openssl -system-zlib -no-webkit -no-phonon
+ -no-qt3support -no-xmlpatterns -no-freetype -no-libtiff -no-accessibility
+ -no-fontconfig -no-glib -no-opengl -no-svg"
+ qt4-build_src_configure
+}