summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBen de Groot <yngwin@gentoo.org>2008-09-19 00:16:49 +0000
committerBen de Groot <yngwin@gentoo.org>2008-09-19 00:16:49 +0000
commit6c4a7edcafc181234fc6953531e2f2ba020ca058 (patch)
tree3a66580f5daa24df90461239c28560b5f46c73eb /x11-libs/qt-svg
parentqt-4.4.2 version bump (diff)
downloadgentoo-2-6c4a7edcafc181234fc6953531e2f2ba020ca058.tar.gz
gentoo-2-6c4a7edcafc181234fc6953531e2f2ba020ca058.tar.bz2
gentoo-2-6c4a7edcafc181234fc6953531e2f2ba020ca058.zip
qt-4.4.2 version bump
(Portage version: 2.2_rc8/cvs/Linux 2.6.26.5 i686)
Diffstat (limited to 'x11-libs/qt-svg')
-rw-r--r--x11-libs/qt-svg/ChangeLog7
-rw-r--r--x11-libs/qt-svg/qt-svg-4.4.2.ebuild38
2 files changed, 44 insertions, 1 deletions
diff --git a/x11-libs/qt-svg/ChangeLog b/x11-libs/qt-svg/ChangeLog
index b425f7f42fc5..623eb32593a5 100644
--- a/x11-libs/qt-svg/ChangeLog
+++ b/x11-libs/qt-svg/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-libs/qt-svg
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-svg/ChangeLog,v 1.11 2008/08/11 13:10:37 yngwin Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-svg/ChangeLog,v 1.12 2008/09/19 00:16:49 yngwin Exp $
+
+*qt-svg-4.4.2 (19 Sep 2008)
+
+ 19 Sep 2008; Ben de Groot <yngwin@gentoo.org> +qt-svg-4.4.2.ebuild:
+ Version bump
*qt-svg-4.4.1 (11 Aug 2008)
diff --git a/x11-libs/qt-svg/qt-svg-4.4.2.ebuild b/x11-libs/qt-svg/qt-svg-4.4.2.ebuild
new file mode 100644
index 000000000000..68688b106c08
--- /dev/null
+++ b/x11-libs/qt-svg/qt-svg-4.4.2.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-svg/qt-svg-4.4.2.ebuild,v 1.1 2008/09/19 00:16:49 yngwin Exp $
+
+EAPI="1"
+inherit qt4-build
+
+DESCRIPTION="The SVG module for the Qt toolkit."
+HOMEPAGE="http://www.trolltech.com/"
+
+LICENSE="|| ( GPL-3 GPL-2 )"
+SLOT="4"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+DEPEND="~x11-libs/qt-gui-${PV}
+ !<=x11-libs/qt-4.4.0_alpha:${SLOT}"
+RDEPEND="${DEPEND}"
+
+QCONFIG_ADD="svg"
+QCONFIG_DEFINE="QT_SVG"
+QT4_TARGET_DIRECTORIES="
+src/svg
+src/plugins/imageformats/svg
+src/plugins/iconengines/svgiconengine"
+QT4_EXTRACT_DIRECTORIES="${QT4_TARGET_DIRECTORIES}"
+
+src_compile() {
+ local myconf
+ myconf="${myconf} -svg -no-xkb -no-tablet -no-fontconfig -no-xrender -no-xrandr
+ -no-xfixes -no-xcursor -no-xinerama -no-xshape -no-sm -no-opengl
+ -no-nas-sound -no-dbus -iconv -no-cups -no-nis -no-gif -no-libpng
+ -no-libmng -no-libjpeg -no-openssl -system-zlib -no-webkit -no-phonon
+ -no-qt3support -no-xmlpatterns -no-freetype -no-libtiff -no-accessibility
+ -no-fontconfig -no-glib -no-opengl"
+
+ qt4-build_src_compile
+}