summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlex Alexander <wired@gentoo.org>2011-09-08 09:22:11 +0000
committerAlex Alexander <wired@gentoo.org>2011-09-08 09:22:11 +0000
commit6b26eb26086670b82eff33d64335492be678553a (patch)
tree5eccddc8b404acb0f0a3b2e6e874dafa8bb24d71 /x11-libs/qt-svg
parentversion bump, 4.7.4 (diff)
downloadgentoo-2-6b26eb26086670b82eff33d64335492be678553a.tar.gz
gentoo-2-6b26eb26086670b82eff33d64335492be678553a.tar.bz2
gentoo-2-6b26eb26086670b82eff33d64335492be678553a.zip
version bump, 4.7.4
(Portage version: 2.2.0_alpha54/cvs/Linux x86_64)
Diffstat (limited to 'x11-libs/qt-svg')
-rw-r--r--x11-libs/qt-svg/ChangeLog7
-rw-r--r--x11-libs/qt-svg/qt-svg-4.7.4.ebuild50
2 files changed, 56 insertions, 1 deletions
diff --git a/x11-libs/qt-svg/ChangeLog b/x11-libs/qt-svg/ChangeLog
index e9ca15f56b41..9789dea7b7ad 100644
--- a/x11-libs/qt-svg/ChangeLog
+++ b/x11-libs/qt-svg/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-libs/qt-svg
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-svg/ChangeLog,v 1.92 2011/08/17 16:58:53 chithanh Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-svg/ChangeLog,v 1.93 2011/09/08 09:22:11 wired Exp $
+
+*qt-svg-4.7.4 (08 Sep 2011)
+
+ 08 Sep 2011; Alex Alexander <wired@gentoo.org> +qt-svg-4.7.4.ebuild:
+ version bump, 4.7.4
17 Aug 2011; Chí-Thanh Christopher Nguyễn <chithanh@gentoo.org>
qt-svg-4.6.3.ebuild:
diff --git a/x11-libs/qt-svg/qt-svg-4.7.4.ebuild b/x11-libs/qt-svg/qt-svg-4.7.4.ebuild
new file mode 100644
index 000000000000..823d1947291b
--- /dev/null
+++ b/x11-libs/qt-svg/qt-svg-4.7.4.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-svg/qt-svg-4.7.4.ebuild,v 1.1 2011/09/08 09:22:11 wired Exp $
+
+EAPI="3"
+inherit qt4-build
+
+DESCRIPTION="The SVG module for the Qt toolkit"
+SLOT="4"
+KEYWORDS="~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 -sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x64-solaris ~x86-solaris"
+IUSE="+accessibility iconv"
+
+DEPEND="~x11-libs/qt-gui-${PV}[accessibility=,aqua=,debug=]"
+RDEPEND="${DEPEND}"
+
+pkg_setup() {
+ QT4_TARGET_DIRECTORIES="
+ src/svg
+ src/plugins/imageformats/svg
+ src/plugins/iconengines/svgiconengine"
+ QT4_EXTRACT_DIRECTORIES="${QT4_TARGET_DIRECTORIES}
+ include/QtSvg/
+ include/Qt/
+ include/QtGui/
+ include/QtCore/
+ include/QtXml/
+ src/corelib/
+ src/gui/
+ src/plugins/
+ src/xml
+ src/3rdparty"
+
+ QCONFIG_ADD="svg"
+ QCONFIG_DEFINE="QT_SVG"
+
+ qt4-build_pkg_setup
+}
+
+src_configure() {
+ myconf="${myconf} -svg
+ $(qt_use iconv)
+ $(qt_use accessibility)
+ -no-xkb -no-xrender
+ -no-xrandr -no-xfixes -no-xcursor -no-xinerama -no-xshape -no-sm
+ -no-opengl -no-nas-sound -no-dbus -no-cups -no-nis -no-gif -no-libpng
+ -no-libmng -no-libjpeg -no-openssl -system-zlib -no-webkit -no-phonon
+ -no-qt3support -no-xmlpatterns -no-freetype -no-libtiff
+ -no-fontconfig -no-glib -no-gtkstyle"
+ qt4-build_src_configure
+}