summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJonathan Callen <abcd@gentoo.org>2009-12-25 15:44:11 +0000
committerJonathan Callen <abcd@gentoo.org>2009-12-25 15:44:11 +0000
commit6b4907fc967b961f67765ce39a90661d38c89458 (patch)
treec27f6b9efa22d62950bf30967b228999d33c694c /x11-libs/qt-sql
parentAdd prefix support, revbump due to otherwise unresolvable USE deps (diff)
downloadgentoo-2-6b4907fc967b961f67765ce39a90661d38c89458.tar.gz
gentoo-2-6b4907fc967b961f67765ce39a90661d38c89458.tar.bz2
gentoo-2-6b4907fc967b961f67765ce39a90661d38c89458.zip
Add prefix support, revbump due to otherwise unresolvable USE deps
(Portage version: -svn/cvs/Linux i686)
Diffstat (limited to 'x11-libs/qt-sql')
-rw-r--r--x11-libs/qt-sql/ChangeLog8
-rw-r--r--x11-libs/qt-sql/qt-sql-4.6.0-r1.ebuild (renamed from x11-libs/qt-sql/qt-sql-4.6.0.ebuild)10
2 files changed, 12 insertions, 6 deletions
diff --git a/x11-libs/qt-sql/ChangeLog b/x11-libs/qt-sql/ChangeLog
index ac0e632a1f64..4921a780c570 100644
--- a/x11-libs/qt-sql/ChangeLog
+++ b/x11-libs/qt-sql/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-libs/qt-sql
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-sql/ChangeLog,v 1.66 2009/12/03 17:23:59 wired Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-sql/ChangeLog,v 1.67 2009/12/25 15:44:11 abcd Exp $
+
+*qt-sql-4.6.0-r1 (25 Dec 2009)
+
+ 25 Dec 2009; Jonathan Callen <abcd@gentoo.org> -qt-sql-4.6.0.ebuild,
+ +qt-sql-4.6.0-r1.ebuild:
+ Add prefix support, revbump due to otherwise unresolvable USE deps
03 Dec 2009; Alex Alexander <wired@gentoo.org>
+files/qt-4.6-nolibx11.diff, qt-sql-4.6.0.ebuild:
diff --git a/x11-libs/qt-sql/qt-sql-4.6.0.ebuild b/x11-libs/qt-sql/qt-sql-4.6.0-r1.ebuild
index b8c157d28887..873e99f50360 100644
--- a/x11-libs/qt-sql/qt-sql-4.6.0.ebuild
+++ b/x11-libs/qt-sql/qt-sql-4.6.0-r1.ebuild
@@ -1,16 +1,16 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-sql/qt-sql-4.6.0.ebuild,v 1.2 2009/12/03 17:23:59 wired Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-sql/qt-sql-4.6.0-r1.ebuild,v 1.1 2009/12/25 15:44:11 abcd Exp $
EAPI="2"
inherit qt4-build
DESCRIPTION="The SQL module for the Qt toolkit"
SLOT="4"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x64-solaris ~x86-solaris"
IUSE="firebird iconv mysql odbc postgres qt3support +sqlite"
-DEPEND="~x11-libs/qt-core-${PV}[debug=,qt3support=]
+DEPEND="~x11-libs/qt-core-${PV}[aqua=,debug=,qt3support=]
firebird? ( dev-db/firebird )
mysql? ( virtual/mysql )
odbc? ( dev-db/unixODBC )
@@ -55,8 +55,8 @@ src_prepare() {
src_configure() {
# Don't support sqlite2 anymore
myconf="${myconf} -no-sql-sqlite2
- $(qt_use mysql sql-mysql plugin) $(use mysql && echo "-I/usr/include/mysql -L/usr/$(get_libdir)/mysql ")
- $(qt_use postgres sql-psql plugin) $(use postgres && echo "-I/usr/include/postgresql/pgsql ")
+ $(qt_use mysql sql-mysql plugin) $(use mysql && echo "-I${EPREFIX}/usr/include/mysql -L${EPREFIX}/usr/$(get_libdir)/mysql ")
+ $(qt_use postgres sql-psql plugin) $(use postgres && echo "-I${EPREFIX}/usr/include/postgresql/pgsql ")
$(qt_use sqlite sql-sqlite plugin) $(use sqlite && echo '-system-sqlite')
$(qt_use odbc sql-odbc plugin)
$(qt_use qt3support)"