summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBen de Groot <yngwin@gentoo.org>2008-08-11 13:08:10 +0000
committerBen de Groot <yngwin@gentoo.org>2008-08-11 13:08:10 +0000
commitf1c0959e5a8de888a2ae387de5ca92149f9ec903 (patch)
treebf3164f7905e1fa70ecffd638685d57d571611cf /x11-libs/qt-script
parentVersion bump to 4.4.1 (diff)
downloadgentoo-2-f1c0959e5a8de888a2ae387de5ca92149f9ec903.tar.gz
gentoo-2-f1c0959e5a8de888a2ae387de5ca92149f9ec903.tar.bz2
gentoo-2-f1c0959e5a8de888a2ae387de5ca92149f9ec903.zip
Version bump to 4.4.1
(Portage version: 2.2_rc7/cvs/Linux 2.6.26-hh1 i686)
Diffstat (limited to 'x11-libs/qt-script')
-rw-r--r--x11-libs/qt-script/ChangeLog7
-rw-r--r--x11-libs/qt-script/qt-script-4.4.1.ebuild39
2 files changed, 45 insertions, 1 deletions
diff --git a/x11-libs/qt-script/ChangeLog b/x11-libs/qt-script/ChangeLog
index 04c43e8d873c..c9d272393e6e 100644
--- a/x11-libs/qt-script/ChangeLog
+++ b/x11-libs/qt-script/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-libs/qt-script
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-script/ChangeLog,v 1.10 2008/06/13 23:23:58 ingmar Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-script/ChangeLog,v 1.11 2008/08/11 13:08:10 yngwin Exp $
+
+*qt-script-4.4.1 (11 Aug 2008)
+
+ 11 Aug 2008; Ben de Groot <yngwin@gentoo.org> +qt-script-4.4.1.ebuild:
+ Version bump
13 Jun 2008; Ingmar Vanhassel <ingmar@gentoo.org> qt-script-4.4.0.ebuild:
Make all split Qt4 ebuilds block the old monolithic ebuild.
diff --git a/x11-libs/qt-script/qt-script-4.4.1.ebuild b/x11-libs/qt-script/qt-script-4.4.1.ebuild
new file mode 100644
index 000000000000..868eaeb6a08d
--- /dev/null
+++ b/x11-libs/qt-script/qt-script-4.4.1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-script/qt-script-4.4.1.ebuild,v 1.1 2008/08/11 13:08:10 yngwin Exp $
+
+EAPI="1"
+inherit qt4-build
+
+DESCRIPTION="The ECMAScript module for the Qt toolkit"
+HOMEPAGE="http://www.trolltech.com/"
+
+LICENSE="|| ( GPL-3 GPL-2 )"
+SLOT="4"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+DEPEND="~x11-libs/qt-core-${PV}
+ !<=x11-libs/qt-4.4.0_alpha:${SLOT}"
+RDEPEND="${DEPEND}"
+
+QT4_TARGET_DIRECTORIES="src/script/"
+QT4_EXTRACT_DIRECTORIES="${QT4_TARGET_DIRECTORIES}
+include/Qt/
+include/QtCore/
+include/QtScript/
+src/corelib/global/
+src/corelib/kernel/
+src/corelib/plugin/"
+
+src_compile() {
+ local myconf
+ myconf="${myconf} -no-xkb -no-tablet -no-fontconfig -no-xrender -no-xrandr
+ -no-xfixes -no-xcursor -no-xinerama -no-xshape -no-sm -no-opengl
+ -no-nas-sound -no-dbus -iconv -no-cups -no-nis -no-gif -no-libpng
+ -no-libmng -no-libjpeg -no-openssl -system-zlib -no-webkit -no-phonon
+ -no-qt3support -no-xmlpatterns -no-freetype -no-libtiff -no-accessibility
+ -no-fontconfig -no-glib -no-opengl -no-svg"
+
+ qt4-build_src_compile
+}