summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTheo Chatzimichos <tampakrap@gentoo.org>2010-09-21 15:01:32 +0000
committerTheo Chatzimichos <tampakrap@gentoo.org>2010-09-21 15:01:32 +0000
commitda1286729794aba6c4a9a7afb82d834807d7016b (patch)
treeae5629bd19083245f6ab428d797ecfd38457b155 /x11-libs/qt-script
parentVersion bump (diff)
downloadgentoo-2-da1286729794aba6c4a9a7afb82d834807d7016b.tar.gz
gentoo-2-da1286729794aba6c4a9a7afb82d834807d7016b.tar.bz2
gentoo-2-da1286729794aba6c4a9a7afb82d834807d7016b.zip
Version bump
(Portage version: 2.2_rc83/cvs/Linux x86_64)
Diffstat (limited to 'x11-libs/qt-script')
-rw-r--r--x11-libs/qt-script/ChangeLog8
-rw-r--r--x11-libs/qt-script/metadata.xml2
-rw-r--r--x11-libs/qt-script/qt-script-4.7.0.ebuild46
3 files changed, 55 insertions, 1 deletions
diff --git a/x11-libs/qt-script/ChangeLog b/x11-libs/qt-script/ChangeLog
index cddaf09ec67f..bb4eb9a6a2f4 100644
--- a/x11-libs/qt-script/ChangeLog
+++ b/x11-libs/qt-script/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-libs/qt-script
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-script/ChangeLog,v 1.73 2010/09/13 21:22:19 klausman Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-script/ChangeLog,v 1.74 2010/09/21 15:01:32 tampakrap Exp $
+
+*qt-script-4.7.0 (21 Sep 2010)
+
+ 21 Sep 2010; Theo Chatzimichos <tampakrap@gentoo.org>
+ +qt-script-4.7.0.ebuild:
+ Version bump
13 Sep 2010; Tobias Klausmann <klausman@gentoo.org>
qt-script-4.6.2.ebuild:
diff --git a/x11-libs/qt-script/metadata.xml b/x11-libs/qt-script/metadata.xml
index e34a8eb7ed3e..b7e05cc84676 100644
--- a/x11-libs/qt-script/metadata.xml
+++ b/x11-libs/qt-script/metadata.xml
@@ -5,5 +5,7 @@
<use>
<flag name='exceptions'>Add support for exceptions - like catching them
inside the event loop (recommended by Nokia)</flag>
+ <flag name="private-headers">Install Qt declarative private headers
+ required by Qt-creator QmlDesigner and QmlInspector plugins"</flag>
</use>
</pkgmetadata>
diff --git a/x11-libs/qt-script/qt-script-4.7.0.ebuild b/x11-libs/qt-script/qt-script-4.7.0.ebuild
new file mode 100644
index 000000000000..158bb810c375
--- /dev/null
+++ b/x11-libs/qt-script/qt-script-4.7.0.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-script/qt-script-4.7.0.ebuild,v 1.1 2010/09/21 15:01:32 tampakrap Exp $
+
+EAPI="2"
+inherit qt4-build
+
+DESCRIPTION="The ECMAScript module for the Qt toolkit"
+SLOT="4"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~ia64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x64-solaris ~x86-solaris"
+IUSE="iconv private-headers"
+
+DEPEND="~x11-libs/qt-core-${PV}[debug=]"
+RDEPEND="${DEPEND}"
+
+pkg_setup() {
+ QT4_TARGET_DIRECTORIES="src/script/"
+ QT4_EXTRACT_DIRECTORIES="${QT4_TARGET_DIRECTORIES}
+ include/Qt/
+ include/QtCore/
+ include/QtScript/
+ src/3rdparty/javascriptcore/
+ src/corelib/"
+
+ qt4-build_pkg_setup
+}
+
+src_configure() {
+ myconf="${myconf} $(qt_use iconv) -no-xkb -no-fontconfig -no-xrender
+ -no-xrandr -no-xfixes -no-xcursor -no-xinerama -no-xshape -no-sm
+ -no-opengl -no-nas-sound -no-dbus -no-cups -no-nis -no-gif -no-libpng
+ -no-libmng -no-libjpeg -no-openssl -system-zlib -no-webkit -no-phonon
+ -no-qt3support -no-xmlpatterns -no-freetype -no-libtiff
+ -no-accessibility -no-fontconfig -no-glib -no-opengl -no-svg
+ -no-gtkstyle"
+ qt4-build_src_configure
+}
+
+src_install() {
+ qt4-build_src_install
+ #install private headers
+ if use private-headers; then
+ insinto ${QTHEADERDIR}/QtScript/private
+ find "${S}"/src/script -type f -name "*_p.h" -exec doins {} \;
+ fi
+}