summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2009-02-14 00:56:52 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2009-02-14 00:56:52 +0000
commit980b341b1cb8a4bbe8e176d0fad817435ecb3c3b (patch)
treedc9d3dbab13b9576db48bfe184ba54dd97501cfc /x11-libs/qt-script
parentVersion bump and removed old (diff)
downloadgentoo-2-980b341b1cb8a4bbe8e176d0fad817435ecb3c3b.tar.gz
gentoo-2-980b341b1cb8a4bbe8e176d0fad817435ecb3c3b.tar.bz2
gentoo-2-980b341b1cb8a4bbe8e176d0fad817435ecb3c3b.zip
Added qscripttools target, PDEPEND on qt-gui
(Portage version: 2.1.6.7/cvs/Linux i686)
Diffstat (limited to 'x11-libs/qt-script')
-rw-r--r--x11-libs/qt-script/ChangeLog8
-rw-r--r--x11-libs/qt-script/qt-script-4.5.0_rc1-r1.ebuild36
2 files changed, 43 insertions, 1 deletions
diff --git a/x11-libs/qt-script/ChangeLog b/x11-libs/qt-script/ChangeLog
index 666fe23921ef..44750ea43210 100644
--- a/x11-libs/qt-script/ChangeLog
+++ b/x11-libs/qt-script/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-libs/qt-script
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-script/ChangeLog,v 1.21 2009/02/11 23:19:01 yngwin Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-script/ChangeLog,v 1.22 2009/02/14 00:56:52 hwoarang Exp $
+
+*qt-script-4.5.0_rc1-r1 (14 Feb 2009)
+
+ 14 Feb 2009; Markos Chandras <hwoarang@gentoo.org>
+ +qt-script-4.5.0_rc1-r1.ebuild:
+ Added scripttools target, PDEPEND on qt-gui
*qt-script-4.5.0_rc1 (11 Feb 2009)
diff --git a/x11-libs/qt-script/qt-script-4.5.0_rc1-r1.ebuild b/x11-libs/qt-script/qt-script-4.5.0_rc1-r1.ebuild
new file mode 100644
index 000000000000..2b997f2e7e32
--- /dev/null
+++ b/x11-libs/qt-script/qt-script-4.5.0_rc1-r1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-script/qt-script-4.5.0_rc1-r1.ebuild,v 1.1 2009/02/14 00:56:52 hwoarang Exp $
+
+EAPI="2"
+inherit qt4-build
+
+DESCRIPTION="The ECMAScript module for the Qt toolkit"
+LICENSE="|| ( GPL-3 GPL-2 )"
+SLOT="4"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE=""
+
+DEPEND="~x11-libs/qt-core-${PV}[debug=]"
+RDEPEND="${DEPEND}"
+PDEPEND="~x11-libs/qt-gui-${PV}"
+
+QT4_TARGET_DIRECTORIES="src/script/ src/scripttools/"
+QT4_EXTRACT_DIRECTORIES="${QT4_TARGET_DIRECTORIES}
+include/Qt/
+include/QtCore/
+include/QtScriptTools/
+include/QtGui/
+include/QtScript/
+src/corelib/
+src/gui"
+
+src_configure() {
+ myconf="${myconf} -no-xkb -no-fontconfig -no-xrender -no-xrandr
+ -no-xfixes -no-xcursor -no-xinerama -no-xshape -no-sm -no-opengl
+ -no-nas-sound -no-dbus -iconv -no-cups -no-nis -no-gif -no-libpng
+ -no-libmng -no-libjpeg -no-openssl -system-zlib -no-webkit -no-phonon
+ -no-qt3support -no-xmlpatterns -no-freetype -no-libtiff -no-accessibility
+ -no-fontconfig -no-glib -no-opengl -no-svg -no-gtkstyle"
+ qt4-build_src_configure
+}