summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlex Alexander <wired@gentoo.org>2011-09-08 09:21:36 +0000
committerAlex Alexander <wired@gentoo.org>2011-09-08 09:21:36 +0000
commit0dc02d528a2b5f2b422fa0cc498c485bd5bff7d7 (patch)
tree92e8c9b067c5f0cc4074b2c4611e9e451a4c7335 /x11-libs/qt-script
parentversion bump, 4.7.4 (diff)
downloadgentoo-2-0dc02d528a2b5f2b422fa0cc498c485bd5bff7d7.tar.gz
gentoo-2-0dc02d528a2b5f2b422fa0cc498c485bd5bff7d7.tar.bz2
gentoo-2-0dc02d528a2b5f2b422fa0cc498c485bd5bff7d7.zip
version bump, 4.7.4
(Portage version: 2.2.0_alpha54/cvs/Linux x86_64)
Diffstat (limited to 'x11-libs/qt-script')
-rw-r--r--x11-libs/qt-script/ChangeLog7
-rw-r--r--x11-libs/qt-script/qt-script-4.7.4.ebuild46
2 files changed, 52 insertions, 1 deletions
diff --git a/x11-libs/qt-script/ChangeLog b/x11-libs/qt-script/ChangeLog
index 322d7de5e211..383104aab750 100644
--- a/x11-libs/qt-script/ChangeLog
+++ b/x11-libs/qt-script/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-libs/qt-script
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-script/ChangeLog,v 1.95 2011/08/17 16:57:43 chithanh Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-script/ChangeLog,v 1.96 2011/09/08 09:21:36 wired Exp $
+
+*qt-script-4.7.4 (08 Sep 2011)
+
+ 08 Sep 2011; Alex Alexander <wired@gentoo.org> +qt-script-4.7.4.ebuild:
+ version bump, 4.7.4
17 Aug 2011; Chí-Thanh Christopher Nguyễn <chithanh@gentoo.org>
qt-script-4.6.3.ebuild:
diff --git a/x11-libs/qt-script/qt-script-4.7.4.ebuild b/x11-libs/qt-script/qt-script-4.7.4.ebuild
new file mode 100644
index 000000000000..30ecf210bc37
--- /dev/null
+++ b/x11-libs/qt-script/qt-script-4.7.4.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-script/qt-script-4.7.4.ebuild,v 1.1 2011/09/08 09:21:36 wired Exp $
+
+EAPI="3"
+inherit qt4-build
+
+DESCRIPTION="The ECMAScript module for the Qt toolkit"
+SLOT="4"
+KEYWORDS="~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 -sparc ~x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~ia64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x64-solaris ~x86-solaris"
+IUSE="iconv +jit private-headers"
+
+DEPEND="~x11-libs/qt-core-${PV}[aqua=,debug=]"
+RDEPEND="${DEPEND}"
+
+pkg_setup() {
+ QT4_TARGET_DIRECTORIES="src/script/"
+ QT4_EXTRACT_DIRECTORIES="${QT4_TARGET_DIRECTORIES}
+ include/Qt/
+ include/QtCore/
+ include/QtScript/
+ src/3rdparty/javascriptcore/
+ src/corelib/"
+
+ qt4-build_pkg_setup
+}
+
+src_configure() {
+ myconf="${myconf} $(qt_use iconv) $(qt_use jit javascript-jit) -no-xkb
+ -no-fontconfig -no-xrender -no-xrandr -no-xfixes -no-xcursor -no-xinerama
+ -no-xshape -no-sm -no-opengl -no-nas-sound -no-dbus -no-cups -no-nis -no-gif
+ -no-libpng -no-libmng -no-libjpeg -no-openssl -system-zlib -no-webkit -no-phonon
+ -no-qt3support -no-xmlpatterns -no-freetype -no-libtiff
+ -no-accessibility -no-fontconfig -no-glib -no-opengl -no-svg
+ -no-gtkstyle"
+ qt4-build_src_configure
+}
+
+src_install() {
+ qt4-build_src_install
+ #install private headers
+ if use private-headers; then
+ insinto "${QTHEADERDIR#${EPREFIX}}"/QtScript/private
+ find "${S}"/src/script -type f -name "*_p.h" -exec doins {} \;
+ fi
+}