summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIngmar Vanhassel <ingmar@gentoo.org>2008-05-15 12:47:21 +0000
committerIngmar Vanhassel <ingmar@gentoo.org>2008-05-15 12:47:21 +0000
commitd5765505eed2bb316d57035a0374a0ed280a72cd (patch)
treee365e8e76918b9b93c22e8dee742b220ea5efb72 /x11-libs/qt-qt3support
parentStable on ppc64; bug #221063 (diff)
downloadgentoo-2-d5765505eed2bb316d57035a0374a0ed280a72cd.tar.gz
gentoo-2-d5765505eed2bb316d57035a0374a0ed280a72cd.tar.bz2
gentoo-2-d5765505eed2bb316d57035a0374a0ed280a72cd.zip
Version bump to Qt-4.4.0.
(Portage version: 2.1.5)
Diffstat (limited to 'x11-libs/qt-qt3support')
-rw-r--r--x11-libs/qt-qt3support/ChangeLog8
-rw-r--r--x11-libs/qt-qt3support/qt-qt3support-4.4.0.ebuild47
2 files changed, 54 insertions, 1 deletions
diff --git a/x11-libs/qt-qt3support/ChangeLog b/x11-libs/qt-qt3support/ChangeLog
index 80dbafa7e414..84c967f16c81 100644
--- a/x11-libs/qt-qt3support/ChangeLog
+++ b/x11-libs/qt-qt3support/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-libs/qt-qt3support
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-qt3support/ChangeLog,v 1.4 2008/04/10 13:42:15 ingmar Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-qt3support/ChangeLog,v 1.5 2008/05/15 12:47:21 ingmar Exp $
+
+*qt-qt3support-4.4.0 (15 May 2008)
+
+ 15 May 2008; Ingmar Vanhassel <ingmar@gentoo.org>
+ +qt-qt3support-4.4.0.ebuild:
+ Version bump to Qt-4.4.0.
10 Apr 2008; Ingmar Vanhassel <ingmar@gentoo.org>
-qt-qt3support-4.4.0_beta1.ebuild, +qt-qt3support-4.4.0_rc1.ebuild:
diff --git a/x11-libs/qt-qt3support/qt-qt3support-4.4.0.ebuild b/x11-libs/qt-qt3support/qt-qt3support-4.4.0.ebuild
new file mode 100644
index 000000000000..01d6e69c35a1
--- /dev/null
+++ b/x11-libs/qt-qt3support/qt-qt3support-4.4.0.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-qt3support/qt-qt3support-4.4.0.ebuild,v 1.1 2008/05/15 12:47:21 ingmar Exp $
+
+EAPI="1"
+inherit qt4-build
+
+DESCRIPTION="The Qt3 support module for the Qt toolkit."
+HOMEPAGE="http://www.trolltech.com/"
+
+LICENSE="|| ( QPL-1.0 GPL-3 GPL-2 )"
+SLOT="4"
+KEYWORDS="~amd64 ~x86"
+IUSE="+accessibility"
+
+DEPEND="~x11-libs/qt-gui-${PV}
+ ~x11-libs/qt-sql-${PV}"
+RDEPEND="${DEPEND}"
+
+QT4_TARGET_DIRECTORIES="
+src/qt3support
+src/tools/uic3
+tools/designer/src/plugins/widgets
+tools/qtconfig
+tools/porting"
+QT4_EXTRACT_DIRECTORIES="${QT4_TARGET_DIRECTORIES}
+src/tools/uic/
+"
+
+pkg_setup() {
+ QT4_BUILT_WITH_USE_CHECK="${QT4_BUILT_WITH_USE_CHECK}
+ ~x11-libs/qt-core-${PV} qt3support
+ ~x11-libs/qt-gui-${PV} qt3support
+ ~x11-libs/qt-sql-${PV} qt3support"
+ use accessibility && QT4_BUILT_WITH_USE_CHECK="${QT4_BUILT_WITH_USE_CHECK}
+ ~x11-libs/qt-gui-${PV} accessibility"
+
+ qt4-build_pkg_setup
+}
+
+src_compile() {
+ local myconf
+ myconf="${myconf} -qt3support -no-gstreamer -no-phonon
+ $(qt_use accessibility)"
+
+ qt4-build_src_compile
+}