summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavide Pesavento <pesa@gentoo.org>2012-03-29 22:13:37 +0000
committerDavide Pesavento <pesa@gentoo.org>2012-03-29 22:13:37 +0000
commitd0c73fdd3bfeef429149501e6b784989308c6457 (patch)
tree25a96463d8857eca9b292219cf656330c352211b /x11-libs/qt-openvg
parentVersion bump. (diff)
downloadgentoo-2-d0c73fdd3bfeef429149501e6b784989308c6457.tar.gz
gentoo-2-d0c73fdd3bfeef429149501e6b784989308c6457.tar.bz2
gentoo-2-d0c73fdd3bfeef429149501e6b784989308c6457.zip
Version bump.
(Portage version: 2.2.0_alpha96/cvs/Linux x86_64)
Diffstat (limited to 'x11-libs/qt-openvg')
-rw-r--r--x11-libs/qt-openvg/ChangeLog7
-rw-r--r--x11-libs/qt-openvg/qt-openvg-4.8.1.ebuild58
2 files changed, 64 insertions, 1 deletions
diff --git a/x11-libs/qt-openvg/ChangeLog b/x11-libs/qt-openvg/ChangeLog
index bb2fc905cca4..7ae8fb991e27 100644
--- a/x11-libs/qt-openvg/ChangeLog
+++ b/x11-libs/qt-openvg/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-libs/qt-openvg
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-openvg/ChangeLog,v 1.2 2012/02/05 13:03:34 wired Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-openvg/ChangeLog,v 1.3 2012/03/29 22:13:37 pesa Exp $
+
+*qt-openvg-4.8.1 (29 Mar 2012)
+
+ 29 Mar 2012; Davide Pesavento <pesa@gentoo.org> +qt-openvg-4.8.1.ebuild:
+ Version bump.
*qt-openvg-4.8.0-r2 (05 Feb 2012)
diff --git a/x11-libs/qt-openvg/qt-openvg-4.8.1.ebuild b/x11-libs/qt-openvg/qt-openvg-4.8.1.ebuild
new file mode 100644
index 000000000000..f17f5fd9d0b2
--- /dev/null
+++ b/x11-libs/qt-openvg/qt-openvg-4.8.1.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-openvg/qt-openvg-4.8.1.ebuild,v 1.1 2012/03/29 22:13:37 pesa Exp $
+
+EAPI=4
+
+inherit qt4-build
+
+DESCRIPTION="The OpenVG module for the Qt toolkit"
+SLOT="4"
+KEYWORDS="~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x64-solaris ~x86-solaris"
+IUSE="qt3support"
+
+DEPEND="
+ media-libs/mesa[egl,openvg]
+ ~x11-libs/qt-core-${PV}[aqua=,c++0x=,debug=,qpa=,qt3support=]
+ ~x11-libs/qt-gui-${PV}[aqua=,c++0x=,debug=,egl,qpa=,qt3support=]
+"
+RDEPEND="${DEPEND}"
+
+pkg_setup() {
+ QT4_TARGET_DIRECTORIES="
+ src/openvg
+ src/plugins/graphicssystems/openvg"
+
+ QT4_EXTRACT_DIRECTORIES="
+ include/QtCore
+ include/QtGui
+ include/QtOpenVG
+ src/corelib
+ src/gui
+ src/openvg
+ src/plugins
+ src/3rdparty"
+
+ QCONFIG_ADD="openvg"
+ QCONFIG_DEFINE="QT_OPENVG"
+
+ qt4-build_pkg_setup
+}
+
+src_configure() {
+ gltype="desktop"
+
+ myconf+="
+ -openvg -egl
+ $(qt_use qt3support)"
+
+ qt4-build_src_configure
+}
+
+src_install() {
+ qt4-build_src_install
+
+ # touch the available graphics systems
+ dodir /usr/share/qt4/graphicssystems
+ echo "experimental" > "${ED}"/usr/share/qt4/graphicssystems/openvg || die
+}