summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTheo Chatzimichos <tampakrap@gentoo.org>2011-05-10 20:06:45 +0000
committerTheo Chatzimichos <tampakrap@gentoo.org>2011-05-10 20:06:45 +0000
commita8c66fa68c9c8e889d135b989fdffb63d31f80de (patch)
tree7416524ced2bad8cce9b3e1cbd9247f787924751 /x11-libs/qt-opengl
parentVersion bump Qt 4.7.3 (diff)
downloadgentoo-2-a8c66fa68c9c8e889d135b989fdffb63d31f80de.tar.gz
gentoo-2-a8c66fa68c9c8e889d135b989fdffb63d31f80de.tar.bz2
gentoo-2-a8c66fa68c9c8e889d135b989fdffb63d31f80de.zip
Version bump Qt 4.7.3
(Portage version: 2.2.0_alpha30/cvs/Linux x86_64)
Diffstat (limited to 'x11-libs/qt-opengl')
-rw-r--r--x11-libs/qt-opengl/ChangeLog8
-rw-r--r--x11-libs/qt-opengl/qt-opengl-4.7.3.ebuild47
2 files changed, 54 insertions, 1 deletions
diff --git a/x11-libs/qt-opengl/ChangeLog b/x11-libs/qt-opengl/ChangeLog
index 43482786ec55..9bce863eecb2 100644
--- a/x11-libs/qt-opengl/ChangeLog
+++ b/x11-libs/qt-opengl/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-libs/qt-opengl
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-opengl/ChangeLog,v 1.87 2011/05/09 22:09:38 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-opengl/ChangeLog,v 1.88 2011/05/10 20:06:45 tampakrap Exp $
+
+*qt-opengl-4.7.3 (10 May 2011)
+
+ 10 May 2011; Theo Chatzimichos <tampakrap@gentoo.org>
+ +qt-opengl-4.7.3.ebuild:
+ Version bump Qt 4.7.3
09 May 2011; Markos Chandras <hwoarang@gentoo.org> qt-opengl-4.7.2.ebuild:
Stable on amd64 wrt bug #354033
diff --git a/x11-libs/qt-opengl/qt-opengl-4.7.3.ebuild b/x11-libs/qt-opengl/qt-opengl-4.7.3.ebuild
new file mode 100644
index 000000000000..25aedb0e3bd6
--- /dev/null
+++ b/x11-libs/qt-opengl/qt-opengl-4.7.3.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-opengl/qt-opengl-4.7.3.ebuild,v 1.1 2011/05/10 20:06:45 tampakrap Exp $
+
+EAPI="3"
+inherit qt4-build
+
+DESCRIPTION="The OpenGL module for the Qt toolkit"
+SLOT="4"
+KEYWORDS="~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 -sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x64-solaris ~x86-solaris"
+IUSE="egl qt3support"
+
+DEPEND="~x11-libs/qt-core-${PV}[aqua=,debug=,qt3support=]
+ ~x11-libs/qt-gui-${PV}[aqua=,debug=,egl=,qt3support=]
+ virtual/opengl"
+RDEPEND="${DEPEND}"
+
+pkg_setup() {
+ QT4_TARGET_DIRECTORIES="
+ src/opengl
+ src/plugins/graphicssystems/opengl"
+
+ QT4_EXTRACT_DIRECTORIES="
+ include/QtCore
+ include/QtGui
+ include/QtOpenGL
+ src/corelib
+ src/gui
+ src/opengl
+ src/plugins
+ src/3rdparty"
+
+ QCONFIG_ADD="opengl"
+ QCONFIG_DEFINE="QT_OPENGL $(use egl && echo QT_EGL)"
+ qt4-build_pkg_setup
+}
+
+src_configure() {
+ myconf="${myconf} -opengl
+ $(qt_use qt3support)
+ $(qt_use egl)"
+
+ qt4-build_src_configure
+
+ # Not building tools/designer/src/plugins/tools/view3d as it's
+ # commented out of the build in the source
+}