summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDror Levin <spatz@gentoo.org>2010-02-15 15:10:01 +0000
committerDror Levin <spatz@gentoo.org>2010-02-15 15:10:01 +0000
commit793a991e386e069073366a7305809e77835a17fd (patch)
tree6bf5fa19a5d73a64aba3d6ba64ba5379e8b0d19c /x11-libs/qt-multimedia
parentVersion bump. (diff)
downloadgentoo-2-793a991e386e069073366a7305809e77835a17fd.tar.gz
gentoo-2-793a991e386e069073366a7305809e77835a17fd.tar.bz2
gentoo-2-793a991e386e069073366a7305809e77835a17fd.zip
Version bump.
(Portage version: 2.2_rc62/cvs/Linux x86_64)
Diffstat (limited to 'x11-libs/qt-multimedia')
-rw-r--r--x11-libs/qt-multimedia/ChangeLog7
-rw-r--r--x11-libs/qt-multimedia/qt-multimedia-4.6.2.ebuild43
2 files changed, 49 insertions, 1 deletions
diff --git a/x11-libs/qt-multimedia/ChangeLog b/x11-libs/qt-multimedia/ChangeLog
index c822592afcb7..0b82f77e99e5 100644
--- a/x11-libs/qt-multimedia/ChangeLog
+++ b/x11-libs/qt-multimedia/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-libs/qt-multimedia
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-multimedia/ChangeLog,v 1.11 2010/02/09 21:14:30 spatz Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-multimedia/ChangeLog,v 1.12 2010/02/15 15:10:01 spatz Exp $
+
+*qt-multimedia-4.6.2 (15 Feb 2010)
+
+ 15 Feb 2010; Dror Levin <spatz@gentoo.org> +qt-multimedia-4.6.2.ebuild:
+ Version bump.
09 Feb 2010; Dror Levin <spatz@gentoo.org> qt-multimedia-4.6.1.ebuild:
Add ~ppc64 to newer version as well.
diff --git a/x11-libs/qt-multimedia/qt-multimedia-4.6.2.ebuild b/x11-libs/qt-multimedia/qt-multimedia-4.6.2.ebuild
new file mode 100644
index 000000000000..57cad875c313
--- /dev/null
+++ b/x11-libs/qt-multimedia/qt-multimedia-4.6.2.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-multimedia/qt-multimedia-4.6.2.ebuild,v 1.1 2010/02/15 15:10:01 spatz Exp $
+
+EAPI="2"
+inherit qt4-build
+
+DESCRIPTION="The Qt multimedia module"
+SLOT="4"
+KEYWORDS="~amd64 ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
+IUSE="iconv"
+
+# currently supported audio backends are: alsa, mac, win32
+DEPEND="!aqua? ( media-libs/alsa-lib )
+ ~x11-libs/qt-core-${PV}[aqua=,debug=]
+ ~x11-libs/qt-gui-${PV}[aqua=,debug=]"
+RDEPEND="${DEPEND}"
+
+QT4_TARGET_DIRECTORIES="src/multimedia"
+QT4_EXTRACT_DIRECTORIES="${QT4_TARGET_DIRECTORIES}
+include/Qt/
+include/QtCore/
+include/QtGui/
+include/QtMultimedia/
+src/src.pro
+src/corelib/
+src/gui/
+src/plugins
+src/3rdparty
+src/tools"
+
+src_configure() {
+ myconf="${myconf} $(qt_use iconv) -no-xkb -no-fontconfig -no-xrender -no-xrandr
+ -no-xfixes -no-xcursor -no-xinerama -no-xshape -no-sm -no-opengl
+ -no-nas-sound -no-dbus -no-cups -no-nis -no-gif -no-libpng
+ -no-libmng -no-libjpeg -no-openssl -system-zlib -no-webkit -no-phonon
+ -no-xmlpatterns -no-freetype -no-libtiff -no-accessibility -no-fontconfig
+ -no-sql-mysql -no-sql-psql -no-sql-ibase -no-sql-sqlite -no-sql-sqlite2
+ -no-sql-odbc -no-glib -no-opengl -no-svg -no-gtkstyle -no-phonon-backend -no-script
+ -no-scripttools -no-cups -no-xsync -no-xinput"
+
+ qt4-build_src_configure
+}