summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIngmar Vanhassel <ingmar@gentoo.org>2008-03-05 23:09:00 +0000
committerIngmar Vanhassel <ingmar@gentoo.org>2008-03-05 23:09:00 +0000
commitca0f6c15224c96086f352f5f806809e4bbfe0d29 (patch)
treea1e516add160e6f40fc5f58b847d41461e2acf21 /x11-libs/qt-gui
parentAdded Qt-4.4.0_beta, note that the RC1 is an accidentally mislabelled (diff)
downloadgentoo-2-ca0f6c15224c96086f352f5f806809e4bbfe0d29.tar.gz
gentoo-2-ca0f6c15224c96086f352f5f806809e4bbfe0d29.tar.bz2
gentoo-2-ca0f6c15224c96086f352f5f806809e4bbfe0d29.zip
Added Qt-4.4.0_beta, note that the RC1 is an accidentally mislabelled
`technical preview`, so this will appear as a downgrade if you installed that version. Thanks to David Leverton, Bo Andresen, Bernd Steinhauser & Arfrever Frehtes Taifersar Arahesis Fixes bugs: 206975, 212086, 172219, 212069, 206976 (Portage version: 2.1.4.4)
Diffstat (limited to 'x11-libs/qt-gui')
-rw-r--r--x11-libs/qt-gui/ChangeLog12
-rw-r--r--x11-libs/qt-gui/qt-gui-4.4.0_beta1.ebuild116
2 files changed, 126 insertions, 2 deletions
diff --git a/x11-libs/qt-gui/ChangeLog b/x11-libs/qt-gui/ChangeLog
index b67e589d95d4..0dbe41792ab7 100644
--- a/x11-libs/qt-gui/ChangeLog
+++ b/x11-libs/qt-gui/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for x11-libs/qt-gui
-# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-gui/ChangeLog,v 1.1 2007/12/21 19:10:35 caleb Exp $
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-gui/ChangeLog,v 1.2 2008/03/05 23:09:00 ingmar Exp $
+
+*qt-gui-4.4.0_beta1 (05 Mar 2008)
+
+ 05 Mar 2008; Ingmar Vanhassel <ingmar@gentoo.org>
+ +qt-gui-4.4.0_beta1.ebuild:
+ Added Qt-4.4.0_beta, note that the RC1 is an accidentally mislabelled
+ `technical preview`, so this will appear as a downgrade if you installed
+ that version.
*qt-gui-4.4.0_rc1 (21 Dec 2007)
diff --git a/x11-libs/qt-gui/qt-gui-4.4.0_beta1.ebuild b/x11-libs/qt-gui/qt-gui-4.4.0_beta1.ebuild
new file mode 100644
index 000000000000..c7c1ae63ec1f
--- /dev/null
+++ b/x11-libs/qt-gui/qt-gui-4.4.0_beta1.ebuild
@@ -0,0 +1,116 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-gui/qt-gui-4.4.0_beta1.ebuild,v 1.1 2008/03/05 23:09:00 ingmar Exp $
+
+EAPI="1"
+inherit eutils qt4-build
+
+DESCRIPTION="The GUI module(s) for the Qt toolkit."
+HOMEPAGE="http://www.trolltech.com/"
+
+LICENSE="|| ( QPL-1.0 GPL-3 GPL-2 )"
+SLOT="4"
+KEYWORDS="~amd64 ~x86"
+
+IUSE_INPUT_DEVICES="input_devices_wacom"
+IUSE="+accessibility cups dbus debug glib mng nas nis tiff +qt3support xinerama ${IUSE_INPUT_DEVICES}"
+
+RDEPEND="
+ media-libs/fontconfig
+ >=media-libs/freetype-2
+ media-libs/jpeg
+ media-libs/libpng
+ sys-libs/zlib
+ x11-libs/libXrandr
+ x11-libs/libXcursor
+ x11-libs/libXfont
+ x11-libs/libSM
+ ~x11-libs/qt-core-${PV}
+ ~x11-libs/qt-script-${PV}
+ cups? ( net-print/cups )
+ dbus? ( ~x11-libs/qt-dbus-${PV} )
+ input_devices_wacom? ( x11-libs/libXi x11-drivers/linuxwacom )
+ mng? ( >=media-libs/libmng-1.0.9 )
+ nas? ( >=media-libs/nas-1.5 )
+ tiff? ( media-libs/tiff )
+ xinerama? ( x11-libs/libXinerama )"
+DEPEND="${RDEPEND}
+ xinerama? ( x11-proto/xineramaproto )
+ x11-proto/xextproto
+ x11-proto/inputproto"
+
+QT4_TARGET_DIRECTORIES="
+src/gui
+tools/designer
+tools/linguist
+src/tools/lrelease
+src/tools/lupdate
+src/plugins/imageformats/gif
+src/plugins/imageformats/ico
+src/plugins/imageformats/jpeg"
+
+pkg_setup() {
+ use glib && QT4_BUILT_WITH_USE_CHECK="${QT4_BUILT_WITH_USE_CHECK}
+ ~x11-libs/qt-core-${PV} glib"
+ use qt3support && QT4_BUILT_WITH_USE_CHECK="${QT4_BUILT_WITH_USE_CHECK}
+ ~x11-libs/qt-core-${PV} qt3support"
+
+ qt4-build_pkg_setup
+}
+
+src_unpack() {
+ qt4-build_src_unpack
+
+ # Don't build plugins this go around, because they depend on qt3support lib
+ sed -i -e "s:CONFIG(shared:# &:g" "${S}"/tools/designer/src/src.pro
+}
+
+src_compile() {
+ export PATH="${S}/bin:${PATH}"
+ export LD_LIBRARY_PATH="${S}/lib:${LD_LIBRARY_PATH}"
+
+ local myconf
+ myconf="$(qt_use accessibility)
+ $(qt_use cups)
+ $(qt_use glib)
+ $(qt_use input_devices_wacom tablet)
+ $(qt_use mng libmng system)
+ $(qt_use nis)
+ $(qt_use tiff libtiff system)
+ $(qt_use qdbus)
+ $(qt_use qt3support)
+ $(qt_use xinerama)"
+
+ use nas && myconf="${myconf} -system-nas-sound"
+
+ myconf="${myconf} -qt-gif -system-libpng -system-libjpeg
+ -no-sql-mysql -no-sql-psql -no-sql-ibase -no-sql-sqlite -no-sql-sqlite2 -no-sql-odbc
+ -xrender -xrandr -xkb -xshape -sm"
+
+ # Explictly don't compile these packages.
+ # Emerge "qt-webkit", "qt-phonon", etc for their functionality.
+ myconf="${myconf} -no-webkit -no-phonon -no-qdbus -no-opengl"
+
+ use dbus && QT4_TARGET_DIRECTORIES="${QT4_TARGET_DIRECTORIES} tools/qdbus/qdbusviewer"
+ use mng && QT4_TARGET_DIRECTORIES="${QT4_TARGET_DIRECTORIES} src/plugins/imageformats/mng"
+ use tiff && QT4_TARGET_DIRECTORIES="${QT4_TARGET_DIRECTORIES} src/plugins/imageformats/tiff"
+
+ qt4-build_src_compile
+}
+
+src_install() {
+ QCONFIG_ADD="x11sm xshape xcursor xfixes xrandr xrender xkb fontconfig
+ $(use input_devices_wacom && echo tablet) $(usev accessibility)
+ $(usev xinerama) $(usev cups) $(usev nas) gif png system-png system-jpeg
+ $(use mng && echo system-mng) $(use tiff && echo system-tiff)"
+ QCONFIG_REMOVE="no-gif no-png"
+ QCONFIG_DEFINE="$(use accessibility && echo QT_ACCESSIBILITY)
+ $(use cups && echo QT_CUPS) QT_FONTCONFIG QT_IMAGEFORMAT_JPEG
+ $(use mng && echo QT_IMAGEFORMAT_MNG) $(use nas && echo QT_NAS)
+ $(use nis && echo QT_NIS) QT_IMAGEFORMAT_PNG QT_SESSIONMANAGER QT_SHAPE
+ $(use tiff && echo QT_IMAGEFORMAT_TIFF) QT_XCURSOR
+ $(use xinerama && echo QT_XINERAMA) QT_XFIXES QT_XKB QT_XRANDR QT_XRENDER"
+ qt4-build_src_install
+
+ domenu "${FILESDIR}"/{Designer,Linguist}.desktop
+}