summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBen de Groot <yngwin@gentoo.org>2009-02-11 23:16:14 +0000
committerBen de Groot <yngwin@gentoo.org>2009-02-11 23:16:14 +0000
commitf1db4c1314db0e6c5196b38be583cdf91b121180 (patch)
tree1d71c1d98068248fb2f2a3f906a8525c04b78ee5 /x11-libs/qt-dbus
parentQt 4.5.0_rc1 version bump (diff)
downloadgentoo-2-f1db4c1314db0e6c5196b38be583cdf91b121180.tar.gz
gentoo-2-f1db4c1314db0e6c5196b38be583cdf91b121180.tar.bz2
gentoo-2-f1db4c1314db0e6c5196b38be583cdf91b121180.zip
Qt 4.5.0_rc1 version bump
(Portage version: 2.2_rc23/cvs/Linux i686)
Diffstat (limited to 'x11-libs/qt-dbus')
-rw-r--r--x11-libs/qt-dbus/ChangeLog7
-rw-r--r--x11-libs/qt-dbus/qt-dbus-4.5.0_rc1.ebuild37
2 files changed, 43 insertions, 1 deletions
diff --git a/x11-libs/qt-dbus/ChangeLog b/x11-libs/qt-dbus/ChangeLog
index 079c115118f4..d4f199ae026d 100644
--- a/x11-libs/qt-dbus/ChangeLog
+++ b/x11-libs/qt-dbus/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-libs/qt-dbus
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-dbus/ChangeLog,v 1.20 2009/02/06 16:19:59 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-dbus/ChangeLog,v 1.21 2009/02/11 23:16:14 yngwin Exp $
+
+*qt-dbus-4.5.0_rc1 (11 Feb 2009)
+
+ 11 Feb 2009; Ben de Groot <yngwin@gentoo.org> +qt-dbus-4.5.0_rc1.ebuild:
+ Version bump
06 Feb 2009; Raúl Porcel <armin76@gentoo.org> qt-dbus-4.4.2.ebuild:
ia64/sparc stable wrt #248038
diff --git a/x11-libs/qt-dbus/qt-dbus-4.5.0_rc1.ebuild b/x11-libs/qt-dbus/qt-dbus-4.5.0_rc1.ebuild
new file mode 100644
index 000000000000..6555eca07bc9
--- /dev/null
+++ b/x11-libs/qt-dbus/qt-dbus-4.5.0_rc1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-dbus/qt-dbus-4.5.0_rc1.ebuild,v 1.1 2009/02/11 23:16:14 yngwin Exp $
+
+EAPI="2"
+inherit qt4-build
+
+DESCRIPTION="The DBus module for the Qt toolkit"
+LICENSE="|| ( GPL-3 GPL-2 )"
+SLOT="4"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE=""
+
+DEPEND="~x11-libs/qt-core-${PV}[debug=]
+ >=sys-apps/dbus-1.0.2"
+RDEPEND="${DEPEND}"
+
+QT4_TARGET_DIRECTORIES="
+src/dbus
+tools/qdbus/qdbus
+tools/qdbus/qdbusxml2cpp
+tools/qdbus/qdbuscpp2xml"
+QCONFIG_ADD="dbus dbus-linked"
+QCONFIG_DEFINE="QT_DBUS"
+
+#FIXME: Check if these are still needed with the header package
+QT4_EXTRACT_DIRECTORIES="${QT4_TARGET_DIRECTORIES}
+include/QtCore
+include/QtDBus
+include/QtXml
+src/corelib
+src/xml"
+
+src_configure() {
+ myconf="${myconf} -dbus-linked"
+ qt4-build_src_configure
+}