summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavide Pesavento <pesa@gentoo.org>2013-01-26 09:01:41 +0000
committerDavide Pesavento <pesa@gentoo.org>2013-01-26 09:01:41 +0000
commitaeef4f0a35062377bc014faed0a7d6790d73f075 (patch)
tree30823fbdec54876fbd67a3b12e5718f3d185b72e /x11-libs/qt-core
parentinitial add of openstack quantum (diff)
downloadgentoo-2-aeef4f0a35062377bc014faed0a7d6790d73f075.tar.gz
gentoo-2-aeef4f0a35062377bc014faed0a7d6790d73f075.tar.bz2
gentoo-2-aeef4f0a35062377bc014faed0a7d6790d73f075.zip
Apply upstream patch to solve bug 401025.
(Portage version: 2.2.0_alpha159/cvs/Linux x86_64, signed Manifest commit with key 17A85C72)
Diffstat (limited to 'x11-libs/qt-core')
-rw-r--r--x11-libs/qt-core/ChangeLog7
-rw-r--r--x11-libs/qt-core/files/set-pkg-config-locations-directly-to-install-dir.patch60
-rw-r--r--x11-libs/qt-core/qt-core-4.8.4-r1.ebuild3
3 files changed, 68 insertions, 2 deletions
diff --git a/x11-libs/qt-core/ChangeLog b/x11-libs/qt-core/ChangeLog
index 23103647e9c4..9bbc6793b400 100644
--- a/x11-libs/qt-core/ChangeLog
+++ b/x11-libs/qt-core/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-libs/qt-core
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-core/ChangeLog,v 1.203 2013/01/03 15:30:58 kensington Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-core/ChangeLog,v 1.204 2013/01/26 09:01:41 pesa Exp $
+
+ 26 Jan 2013; Davide Pesavento <pesa@gentoo.org>
+ +files/set-pkg-config-locations-directly-to-install-dir.patch,
+ qt-core-4.8.4-r1.ebuild:
+ Apply upstream patch to solve bug 401025.
*qt-core-4.8.4-r1 (03 Jan 2013)
diff --git a/x11-libs/qt-core/files/set-pkg-config-locations-directly-to-install-dir.patch b/x11-libs/qt-core/files/set-pkg-config-locations-directly-to-install-dir.patch
new file mode 100644
index 000000000000..46b9c28cfde4
--- /dev/null
+++ b/x11-libs/qt-core/files/set-pkg-config-locations-directly-to-install-dir.patch
@@ -0,0 +1,60 @@
+From 87fa0250081cffb6e413fec7957f5ac4add6cdd1 Mon Sep 17 00:00:00 2001
+From: Oswald Buddenhagen <oswald.buddenhagen@digia.com>
+Date: Tue, 8 Jan 2013 16:34:26 +0100
+Subject: [PATCH] set pkg-config *_location directly to install dir
+
+qmake tries to replace all occurrences of the install prefix with a
+literal ${prefix}. of course this would mess up build paths which happen
+to live under the prefix (this is untypical, but still), which would
+break the sed magic in the subsequent install step. as qmake itself has
+no use for the .pc files, it's ok to target them directly for the
+install dir. we do the same with the include and lib dirs already.
+
+qt5 is already doing the right thing.
+
+Task-number: QTBUG-28807
+Change-Id: I82c17284d1dbac4a96845db2ddec9680e251e7a5
+Reviewed-by: Davide Pesavento <davidepesa@gmail.com>
+Reviewed-by: Oswald Buddenhagen <oswald.buddenhagen@digia.com>
+
+diff --git a/src/qbase.pri b/src/qbase.pri
+index 991c888..feec9d6 100644
+--- a/src/qbase.pri
++++ b/src/qbase.pri
+@@ -166,23 +166,25 @@ DEFINES *= QT_USE_QSTRINGBUILDER
+
+ TARGET = $$qtLibraryTarget($$TARGET$$QT_LIBINFIX) #do this towards the end
+
+-qtPrepareTool(QMAKE_LUPDATE, lupdate)
+-qtPrepareTool(QMAKE_LRELEASE, lrelease)
+-
++QMAKE_MOC_PC = $$[QT_INSTALL_BINS]/moc
+ moc_dir.name = moc_location
+-moc_dir.variable = QMAKE_MOC
++moc_dir.variable = QMAKE_MOC_PC
+
++QMAKE_UIC_PC = $$[QT_INSTALL_BINS]/uic
+ uic_dir.name = uic_location
+-uic_dir.variable = QMAKE_UIC
++uic_dir.variable = QMAKE_UIC_PC
+
++QMAKE_RCC_PC = $$[QT_INSTALL_BINS]/rcc
+ rcc_dir.name = rcc_location
+-rcc_dir.variable = QMAKE_RCC
++rcc_dir.variable = QMAKE_RCC_PC
+
++QMAKE_LUPDATE_PC = $$[QT_INSTALL_BINS]/lupdate
+ lupdate_dir.name = lupdate_location
+-lupdate_dir.variable = QMAKE_LUPDATE
++lupdate_dir.variable = QMAKE_LUPDATE_PC
+
++QMAKE_LRELEASE_PC = $$[QT_INSTALL_BINS]/lrelease
+ lrelease_dir.name = lrelease_location
+-lrelease_dir.variable = QMAKE_LRELEASE
++lrelease_dir.variable = QMAKE_LRELEASE_PC
+
+ QMAKE_PKGCONFIG_VARIABLES += moc_dir uic_dir rcc_dir lupdate_dir lrelease_dir
+
+--
+1.8.1.1
+
diff --git a/x11-libs/qt-core/qt-core-4.8.4-r1.ebuild b/x11-libs/qt-core/qt-core-4.8.4-r1.ebuild
index c37b952bca33..257ca93911d0 100644
--- a/x11-libs/qt-core/qt-core-4.8.4-r1.ebuild
+++ b/x11-libs/qt-core/qt-core-4.8.4-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-core/qt-core-4.8.4-r1.ebuild,v 1.1 2013/01/03 15:30:58 kensington Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-core/qt-core-4.8.4-r1.ebuild,v 1.2 2013/01/26 09:01:41 pesa Exp $
EAPI=5
@@ -30,6 +30,7 @@ PDEPEND="
PATCHES=(
"${FILESDIR}/moc-workaround-for-boost-1.48.patch"
+ "${FILESDIR}/set-pkg-config-locations-directly-to-install-dir.patch"
)
pkg_setup() {