summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavide Pesavento <pesa@gentoo.org>2012-04-15 14:10:41 +0000
committerDavide Pesavento <pesa@gentoo.org>2012-04-15 14:10:41 +0000
commit5fc9817930c4bedcd2e63d0fae012694c400b520 (patch)
tree7dbff2c6358106b6802d3471287d50fb5ec35ac5 /x11-libs/qt-core
parentStable for amd64, wrt bug #412037 (diff)
downloadgentoo-2-5fc9817930c4bedcd2e63d0fae012694c400b520.tar.gz
gentoo-2-5fc9817930c4bedcd2e63d0fae012694c400b520.tar.bz2
gentoo-2-5fc9817930c4bedcd2e63d0fae012694c400b520.zip
Fix localization of date/time, bug 411929 by Franz Fellner. Patch has been merged upstream for Qt 4.8.2 (https://codereview.qt-project.org/20869).
(Portage version: 2.2.0_alpha100/cvs/Linux x86_64)
Diffstat (limited to 'x11-libs/qt-core')
-rw-r--r--x11-libs/qt-core/ChangeLog10
-rw-r--r--x11-libs/qt-core/files/qt-core-4.8.1-localized-time.patch11
-rw-r--r--x11-libs/qt-core/qt-core-4.8.1-r1.ebuild (renamed from x11-libs/qt-core/qt-core-4.8.1.ebuild)6
3 files changed, 25 insertions, 2 deletions
diff --git a/x11-libs/qt-core/ChangeLog b/x11-libs/qt-core/ChangeLog
index bbec5da317a9..b5c9786d1caf 100644
--- a/x11-libs/qt-core/ChangeLog
+++ b/x11-libs/qt-core/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for x11-libs/qt-core
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-core/ChangeLog,v 1.157 2012/04/12 17:56:22 pesa Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-core/ChangeLog,v 1.158 2012/04/15 14:10:41 pesa Exp $
+
+*qt-core-4.8.1-r1 (15 Apr 2012)
+
+ 15 Apr 2012; Davide Pesavento <pesa@gentoo.org>
+ +files/qt-core-4.8.1-localized-time.patch, +qt-core-4.8.1-r1.ebuild,
+ -qt-core-4.8.1.ebuild:
+ Fix localization of date/time, bug 411929 by Franz Fellner. Patch has been
+ merged upstream for Qt 4.8.2 (https://codereview.qt-project.org/20869).
12 Apr 2012; Davide Pesavento <pesa@gentoo.org>
-files/qt-core-4.8.0-qurl-regression-fix.patch, -qt-core-4.6.3.ebuild,
diff --git a/x11-libs/qt-core/files/qt-core-4.8.1-localized-time.patch b/x11-libs/qt-core/files/qt-core-4.8.1-localized-time.patch
new file mode 100644
index 000000000000..39931cf42c3e
--- /dev/null
+++ b/x11-libs/qt-core/files/qt-core-4.8.1-localized-time.patch
@@ -0,0 +1,11 @@
+--- src/corelib/tools/qlocale_unix.cpp.org 2012-04-14 11:02:06.425917171 +0200
++++ src/corelib/tools/qlocale_unix.cpp 2012-04-14 11:02:50.247920549 +0200
+@@ -68,6 +68,8 @@
+ lang = QByteArray("C");
+ if (numeric.isEmpty())
+ numeric = lang;
++ if (time.isEmpty())
++ time = lang;
+ if (monetary.isEmpty())
+ monetary = lang;
+ if (lc_messages_var.isEmpty())
diff --git a/x11-libs/qt-core/qt-core-4.8.1.ebuild b/x11-libs/qt-core/qt-core-4.8.1-r1.ebuild
index d1829ba52600..3e1a3ba67ff4 100644
--- a/x11-libs/qt-core/qt-core-4.8.1.ebuild
+++ b/x11-libs/qt-core/qt-core-4.8.1-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-core/qt-core-4.8.1.ebuild,v 1.1 2012/03/29 22:09:16 pesa Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-core/qt-core-4.8.1-r1.ebuild,v 1.1 2012/04/15 14:10:41 pesa Exp $
EAPI=4
@@ -27,6 +27,10 @@ PDEPEND="
qt3support? ( ~x11-libs/qt-gui-${PV}[aqua=,c++0x=,debug=,glib=,qpa=,qt3support] )
"
+PATCHES=(
+ "${FILESDIR}/${P}-localized-time.patch"
+)
+
pkg_setup() {
QT4_TARGET_DIRECTORIES="
src/tools/bootstrap