summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTheo Chatzimichos <tampakrap@gentoo.org>2009-12-01 14:48:01 +0000
committerTheo Chatzimichos <tampakrap@gentoo.org>2009-12-01 14:48:01 +0000
commit78fcb829a43a00c003f62ceb1d3bf82d41f057d1 (patch)
treef57be8875b3518fa26b9c5bf22e684434c3299fb /x11-libs/qt-assistant
parentVersion bump to 4.6.0 (diff)
downloadgentoo-2-78fcb829a43a00c003f62ceb1d3bf82d41f057d1.tar.gz
gentoo-2-78fcb829a43a00c003f62ceb1d3bf82d41f057d1.tar.bz2
gentoo-2-78fcb829a43a00c003f62ceb1d3bf82d41f057d1.zip
Version bump to 4.6.0
(Portage version: 2.2_rc54/cvs/Linux x86_64)
Diffstat (limited to 'x11-libs/qt-assistant')
-rw-r--r--x11-libs/qt-assistant/ChangeLog8
-rw-r--r--x11-libs/qt-assistant/qt-assistant-4.6.0.ebuild77
2 files changed, 84 insertions, 1 deletions
diff --git a/x11-libs/qt-assistant/ChangeLog b/x11-libs/qt-assistant/ChangeLog
index ecde99040c26..7cc9b85c1a3e 100644
--- a/x11-libs/qt-assistant/ChangeLog
+++ b/x11-libs/qt-assistant/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-libs/qt-assistant
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-assistant/ChangeLog,v 1.61 2009/11/18 20:50:13 wired Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-assistant/ChangeLog,v 1.62 2009/12/01 14:48:01 tampakrap Exp $
+
+*qt-assistant-4.6.0 (01 Dec 2009)
+
+ 01 Dec 2009; Theo Chatzimichos <tampakrap@gentoo.org>
+ +qt-assistant-4.6.0.ebuild:
+ Version Bump to 4.6.0
*qt-assistant-4.6.0_rc1 (18 Nov 2009)
diff --git a/x11-libs/qt-assistant/qt-assistant-4.6.0.ebuild b/x11-libs/qt-assistant/qt-assistant-4.6.0.ebuild
new file mode 100644
index 000000000000..af08dd1fa044
--- /dev/null
+++ b/x11-libs/qt-assistant/qt-assistant-4.6.0.ebuild
@@ -0,0 +1,77 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-assistant/qt-assistant-4.6.0.ebuild,v 1.1 2009/12/01 14:48:01 tampakrap Exp $
+
+EAPI="2"
+inherit qt4-build
+
+DESCRIPTION="The assistant help module for the Qt toolkit."
+SLOT="4"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 -sparc ~x86 ~x86-fbsd"
+IUSE=""
+
+DEPEND="
+ ~x11-libs/qt-gui-${PV}
+ ~x11-libs/qt-sql-${PV}[sqlite]
+ ~x11-libs/qt-webkit-${PV}
+"
+RDEPEND="${DEPEND}"
+
+PATCHES=(
+ "${FILESDIR}/${P}_rc1-tools.patch"
+)
+
+# Pixeltool isn't really assistant related, but it relies on
+# the assistant libraries. doc/qch/
+QT4_TARGET_DIRECTORIES="
+tools/assistant
+tools/pixeltool
+tools/qdoc3"
+QT4_EXTRACT_DIRECTORIES="${QT4_TARGET_DIRECTORIES}
+tools/
+demos/
+examples/
+src/
+include/
+doc/"
+src_configure() {
+ myconf="${myconf} -no-xkb -no-fontconfig -no-xrender -no-xrandr
+ -no-xfixes -no-xcursor -no-xinerama -no-xshape -no-sm -no-opengl
+ -no-nas-sound -no-dbus -iconv -no-cups -no-nis -no-gif -no-libpng
+ -no-libmng -no-libjpeg -no-openssl -system-zlib -no-phonon
+ -no-xmlpatterns -no-freetype -no-libtiff -no-accessibility
+ -no-fontconfig -no-glib -no-multimedia -no-qt3support -no-svg"
+ qt4-build_src_configure
+}
+
+src_compile() {
+ # help libQtHelp find freshly built libQtCLucene (bug #289811)
+ export LD_LIBRARY_PATH="${S}/lib"
+ qt4-build_src_compile
+ # ugly hack to build docs
+ cd "${S}"
+ qmake "LIBS+=-L${QTLIBDIR}" "CONFIG+=nostrip" projects.pro || die "qmake projects faied"
+ emake qch_docs || die "emake docs failed"
+}
+
+src_install() {
+ qt4-build_src_install
+ # install documentation
+ # note that emake install_qchdocs fails for undefined reason so we use a
+ # workaround
+ cd "${S}"
+ insinto "${QTDOCDIR}"
+ doins -r "${S}"/doc/qch || die "doins qch documentation failed"
+ dobin "${S}"/bin/qdoc3 || die "Installing qdoc3 failed"
+ #emake INSTALL_ROOT="${D}" install_qchdocs || die "emake install_qchdocs failed"
+ # install correct assistant icon, bug 241208
+ dodir /usr/share/pixmaps/ || die "dodir failed"
+ insinto /usr/share/pixmaps/ || die "insinto failed"
+ doins tools/assistant/tools/assistant/images/assistant.png \
+ || die "doins failed"
+ # Note: absolute image path required here!
+ make_desktop_entry /usr/bin/assistant Assistant \
+ /usr/share/pixmaps/assistant.png 'Qt;Development;GUIDesigner' \
+ || die "make_desktop_entry failed"
+
+}