summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDominik Kapusta <ayoy@gentoo.org>2009-10-31 11:53:14 +0000
committerDominik Kapusta <ayoy@gentoo.org>2009-10-31 11:53:14 +0000
commit6322aa555460aaf1635377cb270af441139b2bb9 (patch)
tree909795f79796bfdebecfe863c1061e93fb64b0c8 /x11-libs/qt-assistant
parentUpdate useflag requirements for mlt. Per bug #290987. (diff)
downloadgentoo-2-6322aa555460aaf1635377cb270af441139b2bb9.tar.gz
gentoo-2-6322aa555460aaf1635377cb270af441139b2bb9.tar.bz2
gentoo-2-6322aa555460aaf1635377cb270af441139b2bb9.zip
Fix libQtHelp linking issues (bug #289811)
(Portage version: 2.2_rc46/cvs/Linux x86_64)
Diffstat (limited to 'x11-libs/qt-assistant')
-rw-r--r--x11-libs/qt-assistant/ChangeLog6
-rw-r--r--x11-libs/qt-assistant/qt-assistant-4.6.0_beta1.ebuild5
2 files changed, 8 insertions, 3 deletions
diff --git a/x11-libs/qt-assistant/ChangeLog b/x11-libs/qt-assistant/ChangeLog
index ca8ffb872b7f..7487205722e1 100644
--- a/x11-libs/qt-assistant/ChangeLog
+++ b/x11-libs/qt-assistant/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for x11-libs/qt-assistant
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-assistant/ChangeLog,v 1.51 2009/10/29 11:57:21 fauli Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-assistant/ChangeLog,v 1.52 2009/10/31 11:53:14 ayoy Exp $
+
+ 31 Oct 2009; Dominik Kapusta <ayoy@gentoo.org>
+ qt-assistant-4.6.0_beta1.ebuild:
+ Fix libQtHelp linking issues (bug #289811)
29 Oct 2009; Christian Faulhammer <fauli@gentoo.org>
qt-assistant-4.5.3.ebuild:
diff --git a/x11-libs/qt-assistant/qt-assistant-4.6.0_beta1.ebuild b/x11-libs/qt-assistant/qt-assistant-4.6.0_beta1.ebuild
index 2e3ffebb9f48..62d5c0ded777 100644
--- a/x11-libs/qt-assistant/qt-assistant-4.6.0_beta1.ebuild
+++ b/x11-libs/qt-assistant/qt-assistant-4.6.0_beta1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-assistant/qt-assistant-4.6.0_beta1.ebuild,v 1.2 2009/10/16 19:52:21 wired Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-assistant/qt-assistant-4.6.0_beta1.ebuild,v 1.3 2009/10/31 11:53:14 ayoy Exp $
EAPI="2"
inherit qt4-build
@@ -45,10 +45,11 @@ src_configure() {
}
src_compile() {
+ # help libQtHelp find freshly built libQtCLucene (bug #289811)
+ export LD_LIBRARY_PATH="${S}/lib"
qt4-build_src_compile
# ugly hack to build docs
cd "${S}"
- export LD_LIBRARY_PATH="${S}/lib"
qmake "LIBS+=-L${QTLIBDIR}" "CONFIG+=nostrip" projects.pro || die "qmake projects faied"
emake qch_docs || die "emake docs failed"
}