summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2009-06-09 19:00:03 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2009-06-09 19:00:03 +0000
commitc398d5e1291954e12253fab8b6d60ddd0a042f21 (patch)
tree3d474e11aa565b56c96c53be247018cba957476f /x11-libs/qscintilla
parentStable for HPPA (bug #273304). (diff)
downloadgentoo-2-c398d5e1291954e12253fab8b6d60ddd0a042f21.tar.gz
gentoo-2-c398d5e1291954e12253fab8b6d60ddd0a042f21.tar.bz2
gentoo-2-c398d5e1291954e12253fab8b6d60ddd0a042f21.zip
Version bump
(Portage version: 2.2_rc33/cvs/Linux x86_64, RepoMan options: --force)
Diffstat (limited to 'x11-libs/qscintilla')
-rw-r--r--x11-libs/qscintilla/ChangeLog8
-rw-r--r--x11-libs/qscintilla/files/qscintilla-2.4-designer.patch29
-rw-r--r--x11-libs/qscintilla/qscintilla-2.4.ebuild92
3 files changed, 128 insertions, 1 deletions
diff --git a/x11-libs/qscintilla/ChangeLog b/x11-libs/qscintilla/ChangeLog
index a65aaae771fd..e2508c9f534b 100644
--- a/x11-libs/qscintilla/ChangeLog
+++ b/x11-libs/qscintilla/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-libs/qscintilla
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/qscintilla/ChangeLog,v 1.25 2009/06/01 22:28:49 yngwin Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qscintilla/ChangeLog,v 1.26 2009/06/09 19:00:02 hwoarang Exp $
+
+*qscintilla-2.4 (09 Jun 2009)
+
+ 09 Jun 2009; Markos Chandras <hwoarang@gentoo.org> +qscintilla-2.4.ebuild,
+ +files/qscintilla-2.4-designer.patch:
+ Version bump
01 Jun 2009; Ben de Groot <yngwin@gentoo.org> qscintilla-2.3.2.ebuild:
Move to EAPI=2, and add use dep
diff --git a/x11-libs/qscintilla/files/qscintilla-2.4-designer.patch b/x11-libs/qscintilla/files/qscintilla-2.4-designer.patch
new file mode 100644
index 000000000000..b4e7d2210c0a
--- /dev/null
+++ b/x11-libs/qscintilla/files/qscintilla-2.4-designer.patch
@@ -0,0 +1,29 @@
+diff -Naur QScintilla-gpl-2.4.orig/designer-Qt3/designer.pro QScintilla-gpl-2.4/designer-Qt3/designer.pro
+--- QScintilla-gpl-2.4.orig/designer-Qt3/designer.pro 2009-06-07 21:55:35.000000000 +0200
++++ QScintilla-gpl-2.4/designer-Qt3/designer.pro 2009-06-07 22:01:14.000000000 +0200
+@@ -3,10 +3,13 @@
+
+ TEMPLATE = lib
+ TARGET = qscintillaplugin
+-DESTDIR = $(QTDIR)/plugins/designer
+
+ CONFIG += qt warn_on release plugin
+
+ SOURCES += qscintillaplugin.cpp
+
+-LIBS += -lqscintilla2
++target.path = $(QTDIR)/plugins/designer
++INSTALLS += target
++
++INCLUDEPATH = ../Qt3
++LIBS += -L../Qt3 -lqscintilla2
+diff -Naur QScintilla-gpl-2.4.orig/designer-Qt4/designer.pro QScintilla-gpl-2.4/designer-Qt4/designer.pro
+--- QScintilla-gpl-2.4.orig/designer-Qt4/designer.pro 2009-06-07 21:55:35.000000000 +0200
++++ QScintilla-gpl-2.4/designer-Qt4/designer.pro 2009-06-07 21:57:46.000000000 +0200
+@@ -12,4 +12,5 @@
+ target.path = $$[QT_INSTALL_PLUGINS]/designer
+ INSTALLS += target
+
+-LIBS += -lqscintilla2
++INCLUDEPATH = ../Qt4
++LIBS += -L../Qt4 -lqscintilla2
diff --git a/x11-libs/qscintilla/qscintilla-2.4.ebuild b/x11-libs/qscintilla/qscintilla-2.4.ebuild
new file mode 100644
index 000000000000..caa12e974f51
--- /dev/null
+++ b/x11-libs/qscintilla/qscintilla-2.4.ebuild
@@ -0,0 +1,92 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qscintilla/qscintilla-2.4.ebuild,v 1.1 2009/06/09 19:00:02 hwoarang Exp $
+
+EAPI="2"
+
+inherit eutils multilib qt3 qt4
+
+MY_P="QScintilla-gpl-${PV/_pre/-snapshot-}"
+
+DESCRIPTION="A Qt port of Neil Hodgson's Scintilla C++ editor class"
+HOMEPAGE="http://www.riverbankcomputing.co.uk/software/qscintilla/intro"
+SRC_URI="http://www.riverbankcomputing.co.uk/static/Downloads/QScintilla2/${MY_P}.tar.gz"
+
+LICENSE="|| ( GPL-2 GPL-3 )"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="doc python +qt4"
+
+RDEPEND="qt4? ( x11-libs/qt-gui:4 )
+ !qt4? ( x11-libs/qt:3 )"
+DEPEND="${RDEPEND}"
+# dev-python/PyQt needs qscintilla to build and qscintilla's python bindings
+# need dev-python/PyQt, bug 199543
+PDEPEND="python? ( ~dev-python/qscintilla-python-${PV}[qt4=] )"
+
+S="${WORKDIR}"/${MY_P}
+
+PATCHES=( "${FILESDIR}/${PN}-2.4-designer.patch" )
+
+src_configure() {
+ if use qt4; then
+ myqtver=4
+ myqtdir=/usr/share/qt4
+ else
+ myqtver=3
+ myqtdir=${QTDIR}
+ fi
+
+ cd "${S}"/Qt${myqtver}
+ eqmake${myqtver} qscintilla.pro
+
+ cd "${S}"/designer-Qt${myqtver}
+ eqmake${myqtver} designer.pro
+}
+
+src_compile() {
+ cd "${S}"/Qt${myqtver}
+ emake all staticlib || die "emake failed"
+
+ cd "${S}"/designer-Qt${myqtver}
+ emake || die "failed to build designer plugin"
+}
+
+src_install() {
+ cd "${S}"/Qt${myqtver}
+ # header files
+ insinto /usr/include/Qsci
+ doins Qsci/*.h || die
+ # libraries
+ dolib.so libqscintilla2.so* || die
+ dolib.a libqscintilla2.a || die
+ # translations
+ insinto /usr/share/${PN}/translations
+ doins qscintilla_*.qm || die
+ for trans in $(ls -1 qscintilla_*.qm); do
+ dosym /usr/share/${PN}/translations/${trans} \
+ ${myqtdir}/translations/${trans} || die
+ done
+
+ # designer plugin
+ cd "${S}"/designer-Qt${myqtver}
+ emake INSTALL_ROOT="${D}" install || die "designer plugin installation failed"
+
+ # documentation
+ cd "${S}"
+ dodoc ChangeLog NEWS
+ if use doc; then
+ dohtml doc/html-Qt${myqtver}/* || die
+ insinto /usr/share/doc/${PF}/Scintilla
+ doins doc/Scintilla/* || die
+ fi
+}
+
+pkg_postinst() {
+ if use qt4; then
+ ewarn "Please remerge dev-python/PyQt4 if you have problems with eric or other"
+ else
+ ewarn "Please remerge dev-python/PyQt if you have problems with"
+ fi
+ ewarn "qscintilla related packages before submitting bug reports."
+}