summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2012-03-04 17:30:04 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2012-03-04 17:30:04 +0000
commit65864f3f08be2ae15dac8ba16f3c48fda119e175 (patch)
tree4574a0d01f474d98b7bb00bd4b7fea70e84aa0bf /x11-libs/qscintilla
parentversion bump (diff)
downloadgentoo-2-65864f3f08be2ae15dac8ba16f3c48fda119e175.tar.gz
gentoo-2-65864f3f08be2ae15dac8ba16f3c48fda119e175.tar.bz2
gentoo-2-65864f3f08be2ae15dac8ba16f3c48fda119e175.zip
version bump
(Portage version: 2.2.0_alpha89/cvs/Linux x86_64)
Diffstat (limited to 'x11-libs/qscintilla')
-rw-r--r--x11-libs/qscintilla/ChangeLog9
-rw-r--r--x11-libs/qscintilla/qscintilla-2.6.1.ebuild70
2 files changed, 77 insertions, 2 deletions
diff --git a/x11-libs/qscintilla/ChangeLog b/x11-libs/qscintilla/ChangeLog
index fc1c1a587e6d..c059c64534cd 100644
--- a/x11-libs/qscintilla/ChangeLog
+++ b/x11-libs/qscintilla/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-libs/qscintilla
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/qscintilla/ChangeLog,v 1.68 2011/11/12 10:57:21 hwoarang Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qscintilla/ChangeLog,v 1.69 2012/03/04 17:30:04 hwoarang Exp $
+
+*qscintilla-2.6.1 (04 Mar 2012)
+
+ 04 Mar 2012; Markos Chandras <hwoarang@gentoo.org> +qscintilla-2.6.1.ebuild:
+ version bump
*qscintilla-2.6 (12 Nov 2011)
diff --git a/x11-libs/qscintilla/qscintilla-2.6.1.ebuild b/x11-libs/qscintilla/qscintilla-2.6.1.ebuild
new file mode 100644
index 000000000000..a2177fdedd7c
--- /dev/null
+++ b/x11-libs/qscintilla/qscintilla-2.6.1.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qscintilla/qscintilla-2.6.1.ebuild,v 1.1 2012/03/04 17:30:04 hwoarang Exp $
+
+EAPI="3"
+
+inherit qt4-r2
+
+MY_P="QScintilla-gpl-${PV/_pre/-snapshot-}"
+
+DESCRIPTION="A Qt port of Neil Hodgson's Scintilla C++ editor class"
+HOMEPAGE="http://www.riverbankcomputing.co.uk/software/qscintilla/intro"
+SRC_URI="http://www.riverbankcomputing.co.uk/static/Downloads/QScintilla2/${MY_P}.tar.gz"
+
+LICENSE="|| ( GPL-2 GPL-3 )"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="doc python"
+
+DEPEND="x11-libs/qt-gui:4"
+RDEPEND="${DEPEND}"
+PDEPEND="python? ( ~dev-python/qscintilla-python-${PV} )"
+
+S=${WORKDIR}/${MY_P}
+
+PATCHES=("${FILESDIR}/${PN}-2.4-designer.patch")
+
+src_configure() {
+ pushd Qt4 > /dev/null
+ einfo "Configuration of qscintilla"
+ eqmake4 qscintilla.pro
+ popd > /dev/null
+
+ pushd designer-Qt4 > /dev/null
+ einfo "Configuration of designer plugin"
+ eqmake4 designer.pro
+ popd > /dev/null
+}
+
+src_compile() {
+ pushd Qt4 > /dev/null
+ einfo "Building of qscintilla"
+ emake || die "Building of qscintilla failed"
+ popd > /dev/null
+
+ pushd designer-Qt4 > /dev/null
+ einfo "Building of designer plugin"
+ emake || die "Building of designer plugin failed"
+ popd > /dev/null
+}
+
+src_install() {
+ pushd Qt4 > /dev/null
+ einfo "Installation of qscintilla"
+ emake INSTALL_ROOT="${D}" install || die "Installation of qscintilla failed"
+ popd > /dev/null
+
+ pushd designer-Qt4 > /dev/null
+ einfo "Installation of designer plugin"
+ emake INSTALL_ROOT="${D}" install || die "Installation of designer plugin failed"
+ popd > /dev/null
+
+ dodoc NEWS || die "dodoc failed"
+ if use doc; then
+ einfo "Installation of documentation"
+ dohtml doc/html-Qt4/* || die "dohtml failed"
+ insinto /usr/share/doc/${PF}/Scintilla
+ doins doc/Scintilla/* || die "doins failed"
+ fi
+}