summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2011-04-26 19:27:35 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2011-04-26 19:27:35 +0000
commit55f127337eac9f8fe9d406f204deaec21e9eb23f (patch)
treececad5a9599c96f7ebb172d7795531ada985d2cd /x11-libs/qscintilla
parentDelete older ebuild. (diff)
downloadgentoo-2-55f127337eac9f8fe9d406f204deaec21e9eb23f.tar.gz
gentoo-2-55f127337eac9f8fe9d406f204deaec21e9eb23f.tar.bz2
gentoo-2-55f127337eac9f8fe9d406f204deaec21e9eb23f.zip
Version bump.
(Portage version: 2.2.0_alpha30_p2/cvs/Linux x86_64)
Diffstat (limited to 'x11-libs/qscintilla')
-rw-r--r--x11-libs/qscintilla/ChangeLog8
-rw-r--r--x11-libs/qscintilla/qscintilla-2.5.1.ebuild70
2 files changed, 77 insertions, 1 deletions
diff --git a/x11-libs/qscintilla/ChangeLog b/x11-libs/qscintilla/ChangeLog
index 4b278550458e..43104111049b 100644
--- a/x11-libs/qscintilla/ChangeLog
+++ b/x11-libs/qscintilla/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-libs/qscintilla
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/qscintilla/ChangeLog,v 1.63 2011/03/16 21:14:32 xarthisius Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qscintilla/ChangeLog,v 1.64 2011/04/26 19:27:35 arfrever Exp $
+
+*qscintilla-2.5.1 (26 Apr 2011)
+
+ 26 Apr 2011; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ +qscintilla-2.5.1.ebuild:
+ Version bump.
16 Mar 2011; Kacper Kowalik <xarthisius@gentoo.org> qscintilla-2.4.5.ebuild:
ppc64 stable wrt #349607
diff --git a/x11-libs/qscintilla/qscintilla-2.5.1.ebuild b/x11-libs/qscintilla/qscintilla-2.5.1.ebuild
new file mode 100644
index 000000000000..6d1c11ff38bf
--- /dev/null
+++ b/x11-libs/qscintilla/qscintilla-2.5.1.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qscintilla/qscintilla-2.5.1.ebuild,v 1.1 2011/04/26 19:27:35 arfrever Exp $
+
+EAPI="3"
+
+inherit qt4-r2
+
+MY_P="QScintilla-gpl-${PV/_pre/-snapshot-}"
+
+DESCRIPTION="A Qt port of Neil Hodgson's Scintilla C++ editor class"
+HOMEPAGE="http://www.riverbankcomputing.co.uk/software/qscintilla/intro"
+SRC_URI="http://www.riverbankcomputing.co.uk/static/Downloads/QScintilla2/${MY_P}.tar.gz"
+
+LICENSE="|| ( GPL-2 GPL-3 )"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="doc python"
+
+DEPEND="x11-libs/qt-gui:4"
+RDEPEND="${DEPEND}"
+PDEPEND="python? ( ~dev-python/qscintilla-python-${PV} )"
+
+S=${WORKDIR}/${MY_P}
+
+PATCHES=("${FILESDIR}/${PN}-2.4-designer.patch")
+
+src_configure() {
+ pushd Qt4 > /dev/null
+ einfo "Configuration of qscintilla"
+ eqmake4 qscintilla.pro
+ popd > /dev/null
+
+ pushd designer-Qt4 > /dev/null
+ einfo "Configuration of designer plugin"
+ eqmake4 designer.pro
+ popd > /dev/null
+}
+
+src_compile() {
+ pushd Qt4 > /dev/null
+ einfo "Building of qscintilla"
+ emake || die "Building of qscintilla failed"
+ popd > /dev/null
+
+ pushd designer-Qt4 > /dev/null
+ einfo "Building of designer plugin"
+ emake || die "Building of designer plugin failed"
+ popd > /dev/null
+}
+
+src_install() {
+ pushd Qt4 > /dev/null
+ einfo "Installation of qscintilla"
+ emake INSTALL_ROOT="${D}" install || die "Installation of qscintilla failed"
+ popd > /dev/null
+
+ pushd designer-Qt4 > /dev/null
+ einfo "Installation of designer plugin"
+ emake INSTALL_ROOT="${D}" install || die "Installation of designer plugin failed"
+ popd > /dev/null
+
+ dodoc NEWS || die "dodoc failed"
+ if use doc; then
+ einfo "Installation of documentation"
+ dohtml doc/html-Qt4/* || die "dohtml failed"
+ insinto /usr/share/doc/${PF}/Scintilla
+ doins doc/Scintilla/* || die "doins failed"
+ fi
+}