summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBen de Groot <yngwin@gentoo.org>2009-06-01 22:28:49 +0000
committerBen de Groot <yngwin@gentoo.org>2009-06-01 22:28:49 +0000
commit2c08f982927f8ba686253f5c0eabe79c46eb6f6d (patch)
treed3903d737f5bd2d75a26f84a69c61b92e67f505d /x11-libs/qscintilla
parentUpdate package.mask for testing hal (diff)
downloadgentoo-2-2c08f982927f8ba686253f5c0eabe79c46eb6f6d.tar.gz
gentoo-2-2c08f982927f8ba686253f5c0eabe79c46eb6f6d.tar.bz2
gentoo-2-2c08f982927f8ba686253f5c0eabe79c46eb6f6d.zip
Move to EAPI=2, and add use dep
(Portage version: 2.2_rc33/cvs/Linux x86_64)
Diffstat (limited to 'x11-libs/qscintilla')
-rw-r--r--x11-libs/qscintilla/ChangeLog5
-rw-r--r--x11-libs/qscintilla/qscintilla-2.3.2.ebuild10
2 files changed, 8 insertions, 7 deletions
diff --git a/x11-libs/qscintilla/ChangeLog b/x11-libs/qscintilla/ChangeLog
index cc823f6ddf10..a65aaae771fd 100644
--- a/x11-libs/qscintilla/ChangeLog
+++ b/x11-libs/qscintilla/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for x11-libs/qscintilla
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/qscintilla/ChangeLog,v 1.24 2009/05/29 23:22:53 yngwin Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qscintilla/ChangeLog,v 1.25 2009/06/01 22:28:49 yngwin Exp $
+
+ 01 Jun 2009; Ben de Groot <yngwin@gentoo.org> qscintilla-2.3.2.ebuild:
+ Move to EAPI=2, and add use dep
29 May 2009; Ben de Groot <yngwin@gentoo.org> qscintilla-2.3.2.ebuild:
Remove monolithic qt4 dep, as only split is in tree
diff --git a/x11-libs/qscintilla/qscintilla-2.3.2.ebuild b/x11-libs/qscintilla/qscintilla-2.3.2.ebuild
index 33d746cfa621..6cafc95bfc22 100644
--- a/x11-libs/qscintilla/qscintilla-2.3.2.ebuild
+++ b/x11-libs/qscintilla/qscintilla-2.3.2.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/qscintilla/qscintilla-2.3.2.ebuild,v 1.8 2009/05/29 23:22:53 yngwin Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qscintilla/qscintilla-2.3.2.ebuild,v 1.9 2009/06/01 22:28:49 yngwin Exp $
-EAPI=1
+EAPI=2
inherit eutils toolchain-funcs multilib
MY_P="${PN/qs/QS}-gpl-${PV}"
@@ -22,11 +22,9 @@ RDEPEND="qt4? ( x11-libs/qt-gui:4 )
DEPEND="${RDEPEND}"
# dev-python/PyQt needs qscintilla to build and qscintilla's python bindings
# need dev-python/PyQt, bug 199543
-PDEPEND="python? ( dev-python/qscintilla-python )"
-
-src_unpack() {
- unpack ${A}
+PDEPEND="python? ( dev-python/qscintilla-python[qt4=] )"
+src_configure() {
local myqmake myqtdir
if use qt4; then
myqmake=/usr/bin/qmake