summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2009-05-04 15:17:31 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2009-05-04 15:17:31 +0000
commit4cc2c11406b834d0e31397c903c374854b9ef030 (patch)
tree822e3d412f90de0868bbff8d2f60f2b6c0ae0be7 /x11-libs/pixman
parentMove use_ functions out of global scope. (diff)
downloadgentoo-2-4cc2c11406b834d0e31397c903c374854b9ef030.tar.gz
gentoo-2-4cc2c11406b834d0e31397c903c374854b9ef030.tar.bz2
gentoo-2-4cc2c11406b834d0e31397c903c374854b9ef030.zip
Move use_ functions out of global scope.
(Portage version: 2.1.6.13/cvs/Linux x86_64)
Diffstat (limited to 'x11-libs/pixman')
-rw-r--r--x11-libs/pixman/ChangeLog6
-rw-r--r--x11-libs/pixman/pixman-0.11.6.ebuild8
-rw-r--r--x11-libs/pixman/pixman-0.11.8.ebuild8
-rw-r--r--x11-libs/pixman/pixman-0.12.0.ebuild8
-rw-r--r--x11-libs/pixman/pixman-0.14.0.ebuild8
5 files changed, 22 insertions, 16 deletions
diff --git a/x11-libs/pixman/ChangeLog b/x11-libs/pixman/ChangeLog
index 7bd46a1cd791..09ebdefb0ddf 100644
--- a/x11-libs/pixman/ChangeLog
+++ b/x11-libs/pixman/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for x11-libs/pixman
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/pixman/ChangeLog,v 1.40 2009/04/16 02:42:20 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/pixman/ChangeLog,v 1.41 2009/05/04 15:17:31 ssuominen Exp $
+
+ 04 May 2009; Samuli Suominen <ssuominen@gentoo.org> pixman-0.11.6.ebuild,
+ pixman-0.11.8.ebuild, pixman-0.12.0.ebuild, pixman-0.14.0.ebuild:
+ Move use_ functions out of global scope.
16 Apr 2009; Jeroen Roovers <jer@gentoo.org> pixman-0.14.0-r1.ebuild:
Stable for HPPA (bug #251832).
diff --git a/x11-libs/pixman/pixman-0.11.6.ebuild b/x11-libs/pixman/pixman-0.11.6.ebuild
index 30f1d81aca06..642c30c6c5cf 100644
--- a/x11-libs/pixman/pixman-0.11.6.ebuild
+++ b/x11-libs/pixman/pixman-0.11.6.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/pixman/pixman-0.11.6.ebuild,v 1.3 2009/02/24 18:18:51 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/pixman/pixman-0.11.6.ebuild,v 1.4 2009/05/04 15:17:31 ssuominen Exp $
# Must be before x-modular eclass is inherited
#SNAPSHOT="yes"
@@ -11,5 +11,7 @@ DESCRIPTION="Low-level pixel manipulation routines"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
IUSE="altivec mmx sse2"
-CONFIGURE_OPTIONS="$(use_enable altivec vmx) $(use_enable mmx) \
-$(use_enable sse2) --disable-gtk"
+pkg_setup() {
+ CONFIGURE_OPTIONS="$(use_enable altivec vmx) $(use_enable mmx)
+ $(use_enable sse2) --disable-gtk"
+}
diff --git a/x11-libs/pixman/pixman-0.11.8.ebuild b/x11-libs/pixman/pixman-0.11.8.ebuild
index 93d35c1f91bb..8c63e8c56520 100644
--- a/x11-libs/pixman/pixman-0.11.8.ebuild
+++ b/x11-libs/pixman/pixman-0.11.8.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/pixman/pixman-0.11.8.ebuild,v 1.6 2009/02/24 18:18:51 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/pixman/pixman-0.11.8.ebuild,v 1.7 2009/05/04 15:17:31 ssuominen Exp $
# Must be before x-modular eclass is inherited
#SNAPSHOT="yes"
@@ -11,10 +11,10 @@ DESCRIPTION="Low-level pixel manipulation routines"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
IUSE="altivec mmx sse sse2"
-CONFIGURE_OPTIONS="$(use_enable altivec vmx) $(use_enable mmx) \
-$(use_enable sse2) --disable-gtk"
-
pkg_setup() {
+ CONFIGURE_OPTIONS="$(use_enable altivec vmx) $(use_enable mmx)
+ $(use_enable sse2) --disable-gtk"
+
if use sse2 && ! use sse; then
eerror "You enabled SSE2 but have SSE disabled. This is an invalid"
eerror "configuration. Either do USE='sse' or USE='-sse2'"
diff --git a/x11-libs/pixman/pixman-0.12.0.ebuild b/x11-libs/pixman/pixman-0.12.0.ebuild
index 76475bf3f318..8a80c56cd5a3 100644
--- a/x11-libs/pixman/pixman-0.12.0.ebuild
+++ b/x11-libs/pixman/pixman-0.12.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/pixman/pixman-0.12.0.ebuild,v 1.9 2009/03/27 17:01:44 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/pixman/pixman-0.12.0.ebuild,v 1.10 2009/05/04 15:17:31 ssuominen Exp $
# Must be before x-modular eclass is inherited
#SNAPSHOT="yes"
@@ -11,10 +11,10 @@ DESCRIPTION="Low-level pixel manipulation routines"
KEYWORDS="alpha amd64 arm ~hppa ia64 ~mips ppc ppc64 s390 sh sparc x86 ~x86-fbsd"
IUSE="altivec mmx sse sse2"
-CONFIGURE_OPTIONS="$(use_enable altivec vmx) $(use_enable mmx) \
-$(use_enable sse2) --disable-gtk"
-
pkg_setup() {
+ CONFIGURE_OPTIONS="$(use_enable altivec vmx) $(use_enable mmx)
+ $(use_enable sse2) --disable-gtk"
+
if use sse2 && ! use sse; then
eerror "You enabled SSE2 but have SSE disabled. This is an invalid"
eerror "configuration. Either do USE='sse' or USE='-sse2'"
diff --git a/x11-libs/pixman/pixman-0.14.0.ebuild b/x11-libs/pixman/pixman-0.14.0.ebuild
index 596b3fed9e1a..0e939fe7529c 100644
--- a/x11-libs/pixman/pixman-0.14.0.ebuild
+++ b/x11-libs/pixman/pixman-0.14.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/pixman/pixman-0.14.0.ebuild,v 1.2 2009/03/03 16:33:36 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/pixman/pixman-0.14.0.ebuild,v 1.3 2009/05/04 15:17:31 ssuominen Exp $
# Must be before x-modular eclass is inherited
#SNAPSHOT="yes"
@@ -11,10 +11,10 @@ DESCRIPTION="Low-level pixel manipulation routines"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
IUSE="altivec mmx sse sse2"
-CONFIGURE_OPTIONS="$(use_enable altivec vmx) $(use_enable mmx) \
-$(use_enable sse2) --disable-gtk"
-
pkg_setup() {
+ CONFIGURE_OPTIONS="$(use_enable altivec vmx) $(use_enable mmx)
+ $(use_enable sse2) --disable-gtk"
+
if use sse2 && ! use sse; then
eerror "You enabled SSE2 but have SSE disabled. This is an invalid"
eerror "configuration. Either do USE='sse' or USE='-sse2'"