summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRémi Cardona <remi@gentoo.org>2009-09-29 10:49:01 +0000
committerRémi Cardona <remi@gentoo.org>2009-09-29 10:49:01 +0000
commit08745d6194cf93be00fe4da6cf9e9c943ad4db4d (patch)
treec2ffeb3a3650c6fc53125c5e81a6b8105ba9f8f0 /x11-libs/pixman/pixman-0.16.2.ebuild
parentAutomated update of use.local.desc (diff)
downloadgentoo-2-08745d6194cf93be00fe4da6cf9e9c943ad4db4d.tar.gz
gentoo-2-08745d6194cf93be00fe4da6cf9e9c943ad4db4d.tar.bz2
gentoo-2-08745d6194cf93be00fe4da6cf9e9c943ad4db4d.zip
x11-libs/pixman: bump to 0.16.2, sync with x11 overlay
(Portage version: 2.2_rc42/cvs/Linux i686)
Diffstat (limited to 'x11-libs/pixman/pixman-0.16.2.ebuild')
-rw-r--r--x11-libs/pixman/pixman-0.16.2.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/x11-libs/pixman/pixman-0.16.2.ebuild b/x11-libs/pixman/pixman-0.16.2.ebuild
new file mode 100644
index 000000000000..e204bcd17fed
--- /dev/null
+++ b/x11-libs/pixman/pixman-0.16.2.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/pixman/pixman-0.16.2.ebuild,v 1.1 2009/09/29 10:49:01 remi Exp $
+
+# Must be before x-modular eclass is inherited
+#SNAPSHOT="yes"
+
+inherit x-modular toolchain-funcs versionator
+
+EGIT_REPO_URI="git://anongit.freedesktop.org/git/pixman"
+DESCRIPTION="Low-level pixel manipulation routines"
+
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="altivec mmx sse2"
+
+pkg_setup() {
+ CONFIGURE_OPTIONS="
+ $(use_enable altivec vmx)
+ --disable-gtk"
+
+ local enable_mmx="$(use mmx && echo 1 || echo 0)"
+ local enable_sse2="$(use sse2 && echo 1 || echo 0)"
+
+ # this block fixes bug #260287
+ if use x86; then
+ if use sse2 && ! $(version_is_at_least "4.2" "$(gcc-version)"); then
+ ewarn "SSE2 instructions require GCC 4.2 or higher."
+ ewarn "pixman will be built *without* SSE2 support"
+ enable_sse2="0"
+ fi
+ fi
+
+ # this block fixes bug #236558
+ case "$enable_mmx,$enable_sse2" in
+ '1,1')
+ CONFIGURE_OPTIONS="${CONFIGURE_OPTIONS} --enable-mmx --enable-sse2" ;;
+ '1,0')
+ CONFIGURE_OPTIONS="${CONFIGURE_OPTIONS} --enable-mmx --disable-sse2" ;;
+ '0,1')
+ ewarn "You enabled SSE2 but have MMX disabled. This is an invalid."
+ ewarn "pixman will be built *without* MMX/SSE2 support."
+ CONFIGURE_OPTIONS="${CONFIGURE_OPTIONS} --disable-mmx --disable-sse2" ;;
+ '0,0')
+ CONFIGURE_OPTIONS="${CONFIGURE_OPTIONS} --disable-mmx --disable-sse2" ;;
+ esac
+}