summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2012-01-11 20:37:04 +0000
committerMatt Turner <mattst88@gentoo.org>2012-01-11 20:37:04 +0000
commitf89ec0e661d0949cebceb08839dcb5f06b225389 (patch)
tree6fa465d9377454544259348be382815b4a9b2341 /x11-libs/libxcb
parentVersion bump. (diff)
downloadgentoo-2-f89ec0e661d0949cebceb08839dcb5f06b225389.tar.gz
gentoo-2-f89ec0e661d0949cebceb08839dcb5f06b225389.tar.bz2
gentoo-2-f89ec0e661d0949cebceb08839dcb5f06b225389.zip
Version bump.
(Portage version: 2.1.10.11/cvs/Linux x86_64)
Diffstat (limited to 'x11-libs/libxcb')
-rw-r--r--x11-libs/libxcb/ChangeLog9
-rw-r--r--x11-libs/libxcb/libxcb-1.8.ebuild35
2 files changed, 42 insertions, 2 deletions
diff --git a/x11-libs/libxcb/ChangeLog b/x11-libs/libxcb/ChangeLog
index 7fe38399142f..864ef3ada721 100644
--- a/x11-libs/libxcb/ChangeLog
+++ b/x11-libs/libxcb/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-libs/libxcb
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/libxcb/ChangeLog,v 1.82 2011/06/08 15:48:51 scarabeus Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/libxcb/ChangeLog,v 1.83 2012/01/11 20:37:04 mattst88 Exp $
+
+*libxcb-1.8 (11 Jan 2012)
+
+ 11 Jan 2012; Matt Turner <mattst88@gentoo.org> +libxcb-1.8.ebuild:
+ Version bump.
08 Jun 2011; Tomáš Chvátal <scarabeus@gentoo.org> libxcb-1.7.ebuild:
Run eautoreconf as configure.ac is patched.
diff --git a/x11-libs/libxcb/libxcb-1.8.ebuild b/x11-libs/libxcb/libxcb-1.8.ebuild
new file mode 100644
index 000000000000..003ed163e224
--- /dev/null
+++ b/x11-libs/libxcb/libxcb-1.8.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/libxcb/libxcb-1.8.ebuild,v 1.1 2012/01/11 20:37:04 mattst88 Exp $
+
+EAPI=3
+
+inherit python xorg-2
+
+DESCRIPTION="X C-language Bindings library"
+HOMEPAGE="http://xcb.freedesktop.org/"
+EGIT_REPO_URI="git://anongit.freedesktop.org/git/xcb/libxcb"
+[[ ${PV} != 9999* ]] && \
+ SRC_URI="http://xcb.freedesktop.org/dist/${P}.tar.bz2"
+
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="doc selinux"
+
+RDEPEND="x11-libs/libXau
+ x11-libs/libXdmcp
+ dev-libs/libpthread-stubs
+ >=x11-proto/xcb-proto-1.6"
+DEPEND="${RDEPEND}
+ doc? ( app-doc/doxygen )
+ dev-libs/libxslt
+ =dev-lang/python-2*[xml]"
+
+pkg_setup() {
+ python_set_active_version 2
+ xorg-2_pkg_setup
+ XORG_CONFIGURE_OPTIONS=(
+ $(use_enable doc build-docs)
+ $(use_enable selinux)
+ --enable-xinput
+ )
+}