summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2013-02-25 23:09:58 +0000
committerMichał Górny <mgorny@gentoo.org>2013-02-25 23:09:58 +0000
commit0336bc2eb9a659065f68c5cf20442e9e5daa6106 (patch)
treef6493a2cfa206bfbb915cc2edb9d3a8926c54275 /x11-libs/libxcb
parentEnable multilib. (diff)
downloadgentoo-2-0336bc2eb9a659065f68c5cf20442e9e5daa6106.tar.gz
gentoo-2-0336bc2eb9a659065f68c5cf20442e9e5daa6106.tar.bz2
gentoo-2-0336bc2eb9a659065f68c5cf20442e9e5daa6106.zip
Enable multilib.
(Portage version: 2.2.0_alpha163/cvs/Linux x86_64, signed Manifest commit with key 9627F456F9DA7643!)
Diffstat (limited to 'x11-libs/libxcb')
-rw-r--r--x11-libs/libxcb/ChangeLog7
-rw-r--r--x11-libs/libxcb/libxcb-1.9-r1.ebuild40
2 files changed, 46 insertions, 1 deletions
diff --git a/x11-libs/libxcb/ChangeLog b/x11-libs/libxcb/ChangeLog
index b2f4d16d3525..63e12c753cd1 100644
--- a/x11-libs/libxcb/ChangeLog
+++ b/x11-libs/libxcb/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-libs/libxcb
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/libxcb/ChangeLog,v 1.109 2013/02/22 18:04:44 zmedico Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/libxcb/ChangeLog,v 1.110 2013/02/25 23:09:58 mgorny Exp $
+
+*libxcb-1.9-r1 (25 Feb 2013)
+
+ 25 Feb 2013; Michał Górny <mgorny@gentoo.org> +libxcb-1.9-r1.ebuild:
+ Enable multilib.
22 Feb 2013; Zac Medico <zmedico@gentoo.org> libxcb-1.9.ebuild:
Add ~arm-linux keyword.
diff --git a/x11-libs/libxcb/libxcb-1.9-r1.ebuild b/x11-libs/libxcb/libxcb-1.9-r1.ebuild
new file mode 100644
index 000000000000..a8fd18a91d35
--- /dev/null
+++ b/x11-libs/libxcb/libxcb-1.9-r1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/libxcb/libxcb-1.9-r1.ebuild,v 1.1 2013/02/25 23:09:58 mgorny Exp $
+
+EAPI=5
+
+XORG_DOC=doc
+XORG_MULTILIB=yes
+inherit xorg-2
+
+DESCRIPTION="X C-language Bindings library"
+HOMEPAGE="http://xcb.freedesktop.org/"
+EGIT_REPO_URI="git://anongit.freedesktop.org/git/xcb/libxcb"
+[[ ${PV} != 9999* ]] && \
+ SRC_URI="http://xcb.freedesktop.org/dist/${P}.tar.bz2"
+
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="selinux"
+
+RDEPEND="dev-libs/libpthread-stubs[${MULTILIB_USEDEP}]
+ x11-libs/libXau[${MULTILIB_USEDEP}]
+ x11-libs/libXdmcp[${MULTILIB_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-lang/python[xml]
+ dev-libs/libxslt
+ >=x11-proto/xcb-proto-1.7-r1[${MULTILIB_USEDEP}]"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.9-python-3-iteritems.patch
+ "${FILESDIR}"/${PN}-1.9-python-3-exception.patch
+)
+
+pkg_setup() {
+ xorg-2_pkg_setup
+ XORG_CONFIGURE_OPTIONS=(
+ $(use_enable doc build-docs)
+ $(use_enable selinux)
+ --enable-xinput
+ )
+}