summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomas Chvatal <scarabeus@gentoo.org>2011-03-08 12:28:13 +0000
committerTomas Chvatal <scarabeus@gentoo.org>2011-03-08 12:28:13 +0000
commit9f718807a35234e91a714f59092752c1118a0810 (patch)
tree3090bf34fa405fb9d82922ca74c34621b45157ac /x11-libs/libva
parentx86 stable per bug 356937 (diff)
downloadgentoo-2-9f718807a35234e91a714f59092752c1118a0810.tar.gz
gentoo-2-9f718807a35234e91a714f59092752c1118a0810.tar.bz2
gentoo-2-9f718807a35234e91a714f59092752c1118a0810.zip
Update to libva shipped by freedesktop. So we do the same as debian or archlinux. Fixes bug #336854.
(Portage version: 2.2.0_alpha26/cvs/Linux x86_64)
Diffstat (limited to 'x11-libs/libva')
-rw-r--r--x11-libs/libva/ChangeLog9
-rw-r--r--x11-libs/libva/files/libva-dont-install-tests.patch47
-rw-r--r--x11-libs/libva/libva-1.0.10.ebuild58
3 files changed, 113 insertions, 1 deletions
diff --git a/x11-libs/libva/ChangeLog b/x11-libs/libva/ChangeLog
index 730cf90c1199..64e0343b46ec 100644
--- a/x11-libs/libva/ChangeLog
+++ b/x11-libs/libva/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for x11-libs/libva
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/libva/ChangeLog,v 1.15 2011/02/27 13:46:55 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/libva/ChangeLog,v 1.16 2011/03/08 12:28:13 scarabeus Exp $
+
+*libva-1.0.10 (08 Mar 2011)
+
+ 08 Mar 2011; Tomáš Chvátal <scarabeus@gentoo.org> +libva-1.0.10.ebuild,
+ +files/libva-dont-install-tests.patch:
+ Update to libva shipped by freedesktop. So we do the same as debian or
+ archlinux. Fixes bug #336854.
*libva-0.32.0_p2 (27 Feb 2011)
diff --git a/x11-libs/libva/files/libva-dont-install-tests.patch b/x11-libs/libva/files/libva-dont-install-tests.patch
new file mode 100644
index 000000000000..43e4cbaa73ec
--- /dev/null
+++ b/x11-libs/libva/files/libva-dont-install-tests.patch
@@ -0,0 +1,47 @@
+Don't install some useeless tests programs
+
+
+--- test/basic/Makefile.am~ 2010-02-12 09:42:10.000000000 -0500
++++ test/basic/Makefile.am 2010-03-10 13:36:50.449834525 -0500
+@@ -20,7 +20,7 @@
+ # TORT OR OTHERWISE, ARISING FROM, OUT OF OR IN CONNECTION WITH THE
+ # SOFTWARE OR THE USE OR OTHER DEALINGS IN THE SOFTWARE.
+
+-bin_PROGRAMS = test_01 test_02 test_03 test_04 test_05 test_06 \
++check_PROGRAMS = test_01 test_02 test_03 test_04 test_05 test_06 \
+ test_07 test_08 test_09 test_10 test_11
+
+ AM_CFLAGS = -I$(top_srcdir)/src -I$(top_srcdir)/src/x11 -DIN_LIBVA
+--- test/decode/Makefile.am~ 2010-02-12 09:42:10.000000000 -0500
++++ test/decode/Makefile.am 2010-03-10 13:37:09.636843464 -0500
+@@ -20,7 +20,7 @@
+ # TORT OR OTHERWISE, ARISING FROM, OUT OF OR IN CONNECTION WITH THE
+ # SOFTWARE OR THE USE OR OTHER DEALINGS IN THE SOFTWARE.
+
+-bin_PROGRAMS = mpeg2vldemo
++check_PROGRAMS = mpeg2vldemo
+
+ AM_CFLAGS = -I$(top_srcdir)/src -I$(top_srcdir)/src/x11 -DIN_LIBVA
+
+--- test/encode/Makefile.am~ 2010-02-12 09:42:10.000000000 -0500
++++ test/encode/Makefile.am 2010-03-10 13:37:26.701846294 -0500
+@@ -20,7 +20,7 @@
+ # TORT OR OTHERWISE, ARISING FROM, OUT OF OR IN CONNECTION WITH THE
+ # SOFTWARE OR THE USE OR OTHER DEALINGS IN THE SOFTWARE.
+
+-bin_PROGRAMS = h264encode
++check_PROGRAMS = h264encode
+
+ AM_CFLAGS = -I$(top_srcdir)/src -I$(top_srcdir)/src/x11 -DIN_LIBVA
+
+--- test/putsurface/Makefile.am~ 2010-03-10 13:18:55.270697040 -0500
++++ test/putsurface/Makefile.am 2010-03-10 13:38:08.106713556 -0500
+@@ -20,7 +20,7 @@
+ # TORT OR OTHERWISE, ARISING FROM, OUT OF OR IN CONNECTION WITH THE
+ # SOFTWARE OR THE USE OR OTHER DEALINGS IN THE SOFTWARE.
+
+-bin_PROGRAMS = putsurface
++check_PROGRAMS = putsurface
+
+ AM_CFLAGS = -I$(top_srcdir)/src -I$(top_srcdir)/src/x11 -DIN_LIBVA
+
diff --git a/x11-libs/libva/libva-1.0.10.ebuild b/x11-libs/libva/libva-1.0.10.ebuild
new file mode 100644
index 000000000000..151e722b2c33
--- /dev/null
+++ b/x11-libs/libva/libva-1.0.10.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/libva/libva-1.0.10.ebuild,v 1.1 2011/03/08 12:28:13 scarabeus Exp $
+
+EAPI=4
+inherit autotools-utils autotools
+
+DESCRIPTION="Video Acceleration (VA) API for Linux"
+HOMEPAGE="http://freedesktop.org/wiki/Software/vaapi/"
+SRC_URI="http://cgit.freedesktop.org/libva/snapshot/${P}.tar.bz2"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux"
+IUSE="opengl"
+
+VIDEO_CARDS="dummy nvidia intel" # fglrx
+for x in ${VIDEO_CARDS}; do
+ IUSE+=" video_cards_${x}"
+done
+
+RDEPEND=">=x11-libs/libdrm-2.4
+ x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXfixes
+ opengl? ( virtual/opengl )
+ video_cards_intel? ( >=x11-libs/libdrm-2.4.23 )"
+
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+PDEPEND="video_cards_nvidia? ( x11-libs/vdpau-video )"
+
+AUTOTOOLS_IN_SOURCE_BUILD=1
+
+PATCHES=(
+ "${FILESDIR}/${PN}-dont-install-tests.patch"
+)
+
+src_prepare() {
+ autotools-utils_src_prepare
+ eautoreconf
+}
+
+src_configure() {
+ local myeconfargs=(
+ "--disable-static"
+ $(use_enable video_cards_dummy dummy-driver)
+ $(use_enable video_cards_intel i965-driver)
+ $(use_enable opengl glx)
+ )
+
+ autotools-utils_src_configure
+}
+
+src_install() {
+ autotools-utils_src_install
+ remove_libtool_files all
+}