summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSerkan Kaba <serkan@gentoo.org>2009-05-31 16:24:46 +0000
committerSerkan Kaba <serkan@gentoo.org>2009-05-31 16:24:46 +0000
commitaa5e62e67e8ec53930ef5306626f0cc7a93b3cac (patch)
treebe6b97b4540b7629068d0fc73334470d25684a8a /x11-libs/libsexy
parentalpha/ia64/sparc stable wrt #270589 (diff)
downloadgentoo-2-aa5e62e67e8ec53930ef5306626f0cc7a93b3cac.tar.gz
gentoo-2-aa5e62e67e8ec53930ef5306626f0cc7a93b3cac.tar.bz2
gentoo-2-aa5e62e67e8ec53930ef5306626f0cc7a93b3cac.zip
Revbump to fix critical error. Closes bug #270179
(Portage version: 2.2_rc33/cvs/Linux x86_64)
Diffstat (limited to 'x11-libs/libsexy')
-rw-r--r--x11-libs/libsexy/ChangeLog8
-rw-r--r--x11-libs/libsexy/files/libsexy-0.1.11-fix-null-list.patch34
-rw-r--r--x11-libs/libsexy/libsexy-0.1.11-r1.ebuild33
3 files changed, 74 insertions, 1 deletions
diff --git a/x11-libs/libsexy/ChangeLog b/x11-libs/libsexy/ChangeLog
index 0ca56a8333be..3149c3285180 100644
--- a/x11-libs/libsexy/ChangeLog
+++ b/x11-libs/libsexy/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-libs/libsexy
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/libsexy/ChangeLog,v 1.37 2009/01/15 23:09:51 loki_val Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/libsexy/ChangeLog,v 1.38 2009/05/31 16:24:46 serkan Exp $
+
+*libsexy-0.1.11-r1 (31 May 2009)
+
+ 31 May 2009; Serkan Kaba <serkan@gentoo.org> +libsexy-0.1.11-r1.ebuild,
+ +files/libsexy-0.1.11-fix-null-list.patch:
+ Revbump to fix critical error. Closes bug #270179
15 Jan 2009; Peter Alfredsen <loki_val@gentoo.org> metadata.xml:
Compnerd retired.
diff --git a/x11-libs/libsexy/files/libsexy-0.1.11-fix-null-list.patch b/x11-libs/libsexy/files/libsexy-0.1.11-fix-null-list.patch
new file mode 100644
index 000000000000..5330e12e3a57
--- /dev/null
+++ b/x11-libs/libsexy/files/libsexy-0.1.11-fix-null-list.patch
@@ -0,0 +1,34 @@
+diff -Nur libsexy-0.1.11/libsexy/sexy-spell-entry.c libsexy-0.1.11_patched/libsexy/sexy-spell-entry.c
+--- libsexy-0.1.11/libsexy/sexy-spell-entry.c 2006-08-17 21:11:09.000000000 +0300
++++ libsexy-0.1.11_patched/libsexy/sexy-spell-entry.c 2009-05-17 15:15:25.000000000 +0300
+@@ -56,7 +56,7 @@
+ static void (*enchant_dict_add_to_session) (struct EnchantDict * dict, const char *const word, ssize_t len);
+ static int (*enchant_dict_check) (struct EnchantDict * dict, const char *const word, ssize_t len);
+ static void (*enchant_dict_describe) (struct EnchantDict * dict, EnchantDictDescribeFn fn, void * user_data);
+-static void (*enchant_dict_free_suggestions) (struct EnchantDict * dict, char **suggestions);
++static void (*enchant_dict_free_string_list) (struct EnchantDict * dict, char **suggestions);
+ static void (*enchant_dict_store_replacement) (struct EnchantDict * dict, const char *const mis, ssize_t mis_len, const char *const cor, ssize_t cor_len);
+ static char ** (*enchant_dict_suggest) (struct EnchantDict * dict, const char *const word, ssize_t len, size_t * out_n_suggs);
+ static gboolean have_enchant = FALSE;
+@@ -156,8 +156,8 @@
+ MODULE_SYMBOL("enchant_dict_add_to_session", enchant_dict_add_to_session)
+ MODULE_SYMBOL("enchant_dict_check", enchant_dict_check)
+ MODULE_SYMBOL("enchant_dict_describe", enchant_dict_describe)
+- MODULE_SYMBOL("enchant_dict_free_suggestions",
+- enchant_dict_free_suggestions)
++ MODULE_SYMBOL("enchant_dict_free_string_list",
++ enchant_dict_free_string_list)
+ MODULE_SYMBOL("enchant_dict_store_replacement",
+ enchant_dict_store_replacement)
+ MODULE_SYMBOL("enchant_dict_suggest", enchant_dict_suggest)
+@@ -435,9 +435,8 @@
+ gtk_widget_show(mi);
+ gtk_menu_shell_append(GTK_MENU_SHELL(menu), mi);
+ }
++ enchant_dict_free_string_list(dict, suggestions);
+ }
+-
+- enchant_dict_free_suggestions(dict, suggestions);
+ }
+
+ static GtkWidget *
diff --git a/x11-libs/libsexy/libsexy-0.1.11-r1.ebuild b/x11-libs/libsexy/libsexy-0.1.11-r1.ebuild
new file mode 100644
index 000000000000..1b45a32c2cf0
--- /dev/null
+++ b/x11-libs/libsexy/libsexy-0.1.11-r1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/libsexy/libsexy-0.1.11-r1.ebuild,v 1.1 2009/05/31 16:24:46 serkan Exp $
+
+EAPI="2"
+
+inherit gnome2
+
+DESCRIPTION="Sexy GTK+ Widgets"
+HOMEPAGE="http://www.chipx86.com/wiki/Libsexy"
+SRC_URI="http://releases.chipx86.com/${PN}/${PN}/${P}.tar.bz2"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="doc"
+
+RDEPEND=">=dev-libs/glib-2.6
+ >=x11-libs/gtk+-2.6
+ dev-libs/libxml2
+ >=x11-libs/pango-1.4.0
+ >=app-text/iso-codes-0.49"
+DEPEND="${RDEPEND}
+ >=dev-lang/perl-5
+ >=dev-util/pkgconfig-0.19
+ doc? ( >=dev-util/gtk-doc-1.4 )"
+
+DOCS="AUTHORS ChangeLog NEWS README"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-fix-null-list.patch
+ gnome2_src_prepare
+}