summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDoug Goldstein <cardoe@gentoo.org>2008-11-20 15:49:56 +0000
committerDoug Goldstein <cardoe@gentoo.org>2008-11-20 15:49:56 +0000
commit2522a76d1149a91bf6ab9221df0ef2086530df5b (patch)
treecb78e0225496435ecc6b1cc715c3594f129586b6 /x11-libs/libnotify
parentMarked ~hppa too (thanks to LuckyLuke). (diff)
downloadgentoo-2-2522a76d1149a91bf6ab9221df0ef2086530df5b.tar.gz
gentoo-2-2522a76d1149a91bf6ab9221df0ef2086530df5b.tar.bz2
gentoo-2-2522a76d1149a91bf6ab9221df0ef2086530df5b.zip
bug fix release from upstream. adds GtkStatusIcon support
(Portage version: 2.2_rc14/cvs/Linux 2.6.27-gentoo-r2 x86_64)
Diffstat (limited to 'x11-libs/libnotify')
-rw-r--r--x11-libs/libnotify/ChangeLog7
-rw-r--r--x11-libs/libnotify/libnotify-0.4.5.ebuild26
2 files changed, 32 insertions, 1 deletions
diff --git a/x11-libs/libnotify/ChangeLog b/x11-libs/libnotify/ChangeLog
index aa9dc27c7e1f..442ecbc2c526 100644
--- a/x11-libs/libnotify/ChangeLog
+++ b/x11-libs/libnotify/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-libs/libnotify
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/libnotify/ChangeLog,v 1.41 2008/06/23 13:37:59 drac Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/libnotify/ChangeLog,v 1.42 2008/11/20 15:49:56 cardoe Exp $
+
+*libnotify-0.4.5 (20 Nov 2008)
+
+ 20 Nov 2008; Doug Goldstein <cardoe@gentoo.org> +libnotify-0.4.5.ebuild:
+ bug fix release from upstream. adds GtkStatusIcon support
23 Jun 2008; Samuli Suominen <drac@gentoo.org> libnotify-0.4.4.ebuild:
Because repoman ci is broken commit to fix notification-daemon-xfce
diff --git a/x11-libs/libnotify/libnotify-0.4.5.ebuild b/x11-libs/libnotify/libnotify-0.4.5.ebuild
new file mode 100644
index 000000000000..2f74c0f69b36
--- /dev/null
+++ b/x11-libs/libnotify/libnotify-0.4.5.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/libnotify/libnotify-0.4.5.ebuild,v 1.1 2008/11/20 15:49:56 cardoe Exp $
+
+inherit eutils
+
+DESCRIPTION="Notifications library"
+HOMEPAGE="http://www.galago-project.org/"
+SRC_URI="http://www.galago-project.org/files/releases/source/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="doc"
+
+RDEPEND=">=x11-libs/gtk+-2.6
+ >=dev-libs/glib-2.6
+ >=dev-libs/dbus-glib-0.71
+ || ( x11-misc/notification-daemon x11-misc/notification-daemon-xfce )"
+DEPEND="${RDEPEND}
+ doc? ( >=dev-util/gtk-doc-1.4 )"
+
+src_install() {
+ emake install DESTDIR="${D}" || die "make install failed"
+ dodoc AUTHORS ChangeLog NEWS
+}