summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSaleem Abdulrasool <compnerd@gentoo.org>2007-02-28 23:06:29 +0000
committerSaleem Abdulrasool <compnerd@gentoo.org>2007-02-28 23:06:29 +0000
commitdd033b6b92bf4b289cddbb0e3d65ba0d55f4fb7e (patch)
treec7c98c47fbecfdf1006717e327521ba80f79cd7a /x11-libs/libnotify/libnotify-0.4.4.ebuild
parentStable on alpha wrt security bug #167583 (diff)
downloadgentoo-2-dd033b6b92bf4b289cddbb0e3d65ba0d55f4fb7e.tar.gz
gentoo-2-dd033b6b92bf4b289cddbb0e3d65ba0d55f4fb7e.tar.bz2
gentoo-2-dd033b6b92bf4b289cddbb0e3d65ba0d55f4fb7e.zip
version bump from upstream
(Portage version: 2.1.2-r12)
Diffstat (limited to 'x11-libs/libnotify/libnotify-0.4.4.ebuild')
-rw-r--r--x11-libs/libnotify/libnotify-0.4.4.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/x11-libs/libnotify/libnotify-0.4.4.ebuild b/x11-libs/libnotify/libnotify-0.4.4.ebuild
new file mode 100644
index 000000000000..0cb058fde914
--- /dev/null
+++ b/x11-libs/libnotify/libnotify-0.4.4.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/libnotify/libnotify-0.4.4.ebuild,v 1.1 2007/02/28 23:06:29 compnerd Exp $
+
+inherit eutils
+
+DESCRIPTION="Notifications library"
+HOMEPAGE="http://www.galago-project.org/"
+SRC_URI="http://www.galago-project.org/files/releases/source/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="doc"
+
+RDEPEND=">=x11-libs/gtk+-2.6
+ >=dev-libs/glib-2.6
+ || (
+ ( >=dev-libs/dbus-glib-0.71 )
+ ( <sys-apps/dbus-0.90 >=sys-apps/dbus-0.60 )
+ )
+ x11-misc/notification-daemon"
+DEPEND="${RDEPEND}
+ doc? ( >=dev-util/gtk-doc-1.4 )"
+
+src_install() {
+ emake install DESTDIR="${D}" || die "make install failed"
+ dodoc AUTHORS ChangeLog NEWS
+}