summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKrzysztof Pawlik <nelchael@gentoo.org>2006-01-21 10:38:03 +0000
committerKrzysztof Pawlik <nelchael@gentoo.org>2006-01-21 10:38:03 +0000
commitd92d9e26746b37fe7499e05d58622c8ffec39bdf (patch)
treeb9e9c743f2009d88e6ae7782dc8511d86dd015ab /x11-libs/libdockapp
parentAdded ppc keyword. bug 119436 (diff)
downloadgentoo-2-d92d9e26746b37fe7499e05d58622c8ffec39bdf.tar.gz
gentoo-2-d92d9e26746b37fe7499e05d58622c8ffec39bdf.tar.bz2
gentoo-2-d92d9e26746b37fe7499e05d58622c8ffec39bdf.zip
Version bump, see bug #119300.
(Portage version: 2.1_pre3-r1)
Diffstat (limited to 'x11-libs/libdockapp')
-rw-r--r--x11-libs/libdockapp/ChangeLog9
-rw-r--r--x11-libs/libdockapp/files/digest-libdockapp-0.6.11
-rw-r--r--x11-libs/libdockapp/files/install-paths.patch-0.6.115
-rw-r--r--x11-libs/libdockapp/files/legacy.patch-0.6.110
-rw-r--r--x11-libs/libdockapp/libdockapp-0.6.1.ebuild90
5 files changed, 124 insertions, 1 deletions
diff --git a/x11-libs/libdockapp/ChangeLog b/x11-libs/libdockapp/ChangeLog
index d47034ede67e..e69507d84a87 100644
--- a/x11-libs/libdockapp/ChangeLog
+++ b/x11-libs/libdockapp/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for x11-libs/libdockapp
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/libdockapp/ChangeLog,v 1.25 2006/01/15 14:25:55 nelchael Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/libdockapp/ChangeLog,v 1.26 2006/01/21 10:38:03 nelchael Exp $
+
+*libdockapp-0.6.1 (21 Jan 2006)
+
+ 21 Jan 2006; Krzysiek Pawlik <nelchael@gentoo.org>
+ +files/install-paths.patch-0.6.1, +files/legacy.patch-0.6.1,
+ +libdockapp-0.6.1.ebuild:
+ Version bump, see bug #119300.
15 Jan 2006; Krzysiek Pawlik <nelchael@gentoo.org>
-files/install-paths.patch-0.5.0-r1, -libdockapp-0.5.0-r1.ebuild,
diff --git a/x11-libs/libdockapp/files/digest-libdockapp-0.6.1 b/x11-libs/libdockapp/files/digest-libdockapp-0.6.1
new file mode 100644
index 000000000000..eb6f6e0d2cae
--- /dev/null
+++ b/x11-libs/libdockapp/files/digest-libdockapp-0.6.1
@@ -0,0 +1 @@
+MD5 ec1219c355516d63b6e2ee1e4cb10c30 libdockapp-0.6.1.tar.bz2 155920
diff --git a/x11-libs/libdockapp/files/install-paths.patch-0.6.1 b/x11-libs/libdockapp/files/install-paths.patch-0.6.1
new file mode 100644
index 000000000000..7206655bb7a3
--- /dev/null
+++ b/x11-libs/libdockapp/files/install-paths.patch-0.6.1
@@ -0,0 +1,15 @@
+--- fonts/Makefile.am 2005-06-08 14:36:38.389096256 +0200
++++ fonts/Makefile.am 2005-06-08 14:37:18.276032520 +0200
+@@ -5,10 +5,10 @@
+ # but I don't know how and they don't tell.
+ #
+
+-XFONTDIR = $(DESTDIR)/usr/X11R6/lib/X11/fonts
++XFONTDIR = $(DESTDIR)/usr/share/fonts/libdockapp-fonts
+
+ MYFONTDIR = /dockapp
+-MYDATA = luxel-ascii-06x09.pcf.gz seg7-ascii-05x07.pcf.gz fonts.dir fonts.alias
++MYDATA = luxel-ascii-06x09.pcf.gz seg7-ascii-05x07.pcf.gz
+
+ install-data-local:
+ $(INSTALL) -d $(XFONTDIR)$(MYFONTDIR)
diff --git a/x11-libs/libdockapp/files/legacy.patch-0.6.1 b/x11-libs/libdockapp/files/legacy.patch-0.6.1
new file mode 100644
index 000000000000..b608db02195e
--- /dev/null
+++ b/x11-libs/libdockapp/files/legacy.patch-0.6.1
@@ -0,0 +1,10 @@
+--- dockapp-0.6.0/src/damain-orig.c 2005-04-20 20:05:04.000000000 +0200
++++ dockapp-0.6.0/src/damain.c 2005-06-04 19:21:34.000000000 +0200
+@@ -237,6 +237,7 @@
+ DAInitialize(char *display, char *name, unsigned width, unsigned height,
+ int argc, char **argv)
+ {
++ _daContext= DAContextInit();
+ DAOpenDisplay(display, argc, argv);
+ DACreateIcon(name, width, height, argc, argv);
+ }
diff --git a/x11-libs/libdockapp/libdockapp-0.6.1.ebuild b/x11-libs/libdockapp/libdockapp-0.6.1.ebuild
new file mode 100644
index 000000000000..a43f4ef66db5
--- /dev/null
+++ b/x11-libs/libdockapp/libdockapp-0.6.1.ebuild
@@ -0,0 +1,90 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/libdockapp/libdockapp-0.6.1.ebuild,v 1.1 2006/01/21 10:38:03 nelchael Exp $
+
+inherit eutils autotools
+
+IUSE=""
+
+DESCRIPTION="Window Maker Dock Applet Library"
+SRC_URI="http://solfertje.student.utwente.nl/~dalroi/libdockapp/files/${P}.tar.bz2"
+HOMEPAGE="http://solfertje.student.utwente.nl/~dalroi/libdockapp/"
+
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
+
+RDEPEND="|| ( (
+ x11-libs/libX11
+ x11-libs/libXt
+ x11-libs/libXext
+ x11-libs/libXpm )
+ virtual/x11 )"
+DEPEND="${RDEPEND}
+ || ( (
+ x11-proto/xextproto
+ x11-proto/xproto )
+ virtual/x11 )"
+
+S=${WORKDIR}/${P/lib/}
+FONTDIR="/usr/share/fonts/${PN}-fonts"
+
+src_unpack()
+{
+ unpack ${A}
+ cd ${S}
+
+ # sanitize fonts installation path
+ epatch ${FILESDIR}/install-paths.patch-${PV}
+
+ # add legacy support for older dockapps
+ epatch ${FILESDIR}/legacy.patch-${PV}
+}
+
+src_compile()
+{
+ eautoreconf
+
+ econf || die "configure failed"
+ emake || die "parallel make failed"
+}
+
+src_install()
+{
+ make \
+ DESTDIR=${D} \
+ SHAREDIR="${D}/usr/share/doc/${PF}/examples/" \
+ install || die "make install failed"
+
+ dodoc README ChangeLog NEWS AUTHORS
+}
+
+pkg_postinst()
+{
+ einfo
+ einfo "You need to add following line into 'Section \"Files\"' in"
+ einfo "/etc/X11/xorg.conf (or /etc/X11/XF86Config if you are still using XFree86)"
+ einfo "and reboot X Window System, to use these fonts."
+ einfo
+ einfo "\t FontPath \"${FONTDIR}\""
+ einfo
+ einfo "You also need to add the following line to /etc/fonts/local.conf"
+ einfo
+ einfo "\t <dir>${FONTDIR}</dir>"
+ einfo
+}
+
+pkg_postrm()
+{
+ einfo
+ einfo "You need to remove following line from 'Section \"Files\"' in"
+ einfo "/etc/X11/xorg.conf (or /etc/X11/XF86Config if you are still using XFree86)"
+ einfo "to unmerge this package completely."
+ einfo
+ einfo "\t FontPath \"${FONTDIR}\""
+ einfo
+ einfo "You also need to remove the following line from /etc/fonts/local.conf"
+ einfo
+ einfo "\t <dir>${FONTDIR}</dir>"
+ einfo
+}