summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-01-22 01:28:17 +0000
committerMike Frysinger <vapier@gentoo.org>2004-01-22 01:28:17 +0000
commit341f2b5102749d0e77e9af2df96b301f2b7491c7 (patch)
tree364e67c539f9377ce85408b9de47037c44b7a0c8 /x11-libs/libast
parentFixed a missing white-space. (Manifest recommit) (diff)
downloadgentoo-2-341f2b5102749d0e77e9af2df96b301f2b7491c7.tar.gz
gentoo-2-341f2b5102749d0e77e9af2df96b301f2b7491c7.tar.bz2
gentoo-2-341f2b5102749d0e77e9af2df96b301f2b7491c7.zip
cleanup the use logic
Diffstat (limited to 'x11-libs/libast')
-rw-r--r--x11-libs/libast/libast-0.5-r1.ebuild15
1 files changed, 6 insertions, 9 deletions
diff --git a/x11-libs/libast/libast-0.5-r1.ebuild b/x11-libs/libast/libast-0.5-r1.ebuild
index cfe52ed64a76..b4833417bfdd 100644
--- a/x11-libs/libast/libast-0.5-r1.ebuild
+++ b/x11-libs/libast/libast-0.5-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/libast/libast-0.5-r1.ebuild,v 1.8 2004/01/02 21:29:20 aliz Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/libast/libast-0.5-r1.ebuild,v 1.9 2004/01/22 01:28:17 vapier Exp $
DESCRIPTION="LIBrary of Assorted Spiffy Things"
HOMEPAGE="http://www.eterm.org/download/"
@@ -17,17 +17,14 @@ DEPEND="virtual/x11
perl? ( dev-libs/libpcre )"
src_compile() {
- local myconf
- myconf="$myconf `use_with imlib`"
- if [ "${ARCH}" == "x86" ]; then
- myconf="`use_enable mmx`"
- fi
-
- econf $myconf || die
+ econf \
+ `use_with imlib` \
+ `use_enable mmx` \
+ || die
emake || die
}
src_install() {
make DESTDIR=${D} install || die
- dodoc README
+ dodoc README DESIGN ChangeLog
}