summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Ahlberg <aliz@gentoo.org>2004-01-02 21:28:31 +0000
committerDaniel Ahlberg <aliz@gentoo.org>2004-01-02 21:28:31 +0000
commit03ff451d5c05ed3c05bcf3c06a6666e164c634d1 (patch)
tree908a4bd91eb80a5c991d62833e082e572cbd7d04 /x11-libs/libast
parentmasked java-config 1.2.0 (diff)
downloadgentoo-2-03ff451d5c05ed3c05bcf3c06a6666e164c634d1.tar.gz
gentoo-2-03ff451d5c05ed3c05bcf3c06a6666e164c634d1.tar.bz2
gentoo-2-03ff451d5c05ed3c05bcf3c06a6666e164c634d1.zip
Add amd64 keyword
Diffstat (limited to 'x11-libs/libast')
-rw-r--r--x11-libs/libast/Manifest4
-rw-r--r--x11-libs/libast/libast-0.5-r1.ebuild13
2 files changed, 10 insertions, 7 deletions
diff --git a/x11-libs/libast/Manifest b/x11-libs/libast/Manifest
index 74830f76bdfa..0ab813f02eb1 100644
--- a/x11-libs/libast/Manifest
+++ b/x11-libs/libast/Manifest
@@ -1,4 +1,4 @@
-MD5 2a9e814b7851e9e22178430153da8110 files/digest-libast-0.5-r1 62
-MD5 047463785de7294e7a3898cd82941b78 libast-0.5-r1.ebuild 701
+MD5 30643384591becc156c587f7f3f73b96 libast-0.5-r1.ebuild 809
MD5 55bae7e153933d3240b08e50ac1fcd76 ChangeLog 1286
MD5 ec45fec065a8eccc43870fc678126de7 metadata.xml 820
+MD5 2a9e814b7851e9e22178430153da8110 files/digest-libast-0.5-r1 62
diff --git a/x11-libs/libast/libast-0.5-r1.ebuild b/x11-libs/libast/libast-0.5-r1.ebuild
index e29607af48eb..41ffea000604 100644
--- a/x11-libs/libast/libast-0.5-r1.ebuild
+++ b/x11-libs/libast/libast-0.5-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/libast/libast-0.5-r1.ebuild,v 1.6 2004/01/02 03:58:22 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/libast/libast-0.5-r1.ebuild,v 1.7 2004/01/02 21:28:23 aliz Exp $
DESCRIPTION="LIBrary of Assorted Spiffy Things"
HOMEPAGE="http://www.eterm.org/download/"
@@ -17,10 +17,13 @@ DEPEND="virtual/x11
perl? ( dev-libs/libpcre )"
src_compile() {
- econf \
- `use_enable mmx` \
- `use_with imlib` \
- || die
+ local myconf
+ myconf="$myconf `use_with imlib`"
+ if [ "${ARCH}" == "x86" ]; then
+ myconf="`use_enable mmx`"
+ fi
+
+ econf $myconf || die
emake || die
}