summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDonnie Berkholz <dberkholz@gentoo.org>2008-12-04 04:45:21 +0000
committerDonnie Berkholz <dberkholz@gentoo.org>2008-12-04 04:45:21 +0000
commitd222431cd528801edbdb365f7d137a20b4266ee3 (patch)
treef465c51761d6df27fc023ff5b59e6545b7b4e82a /x11-libs/libXi
parentRemoved insecure www-apps/websvn-2.0 (#243852). (diff)
downloadgentoo-2-d222431cd528801edbdb365f7d137a20b4266ee3.tar.gz
gentoo-2-d222431cd528801edbdb365f7d137a20b4266ee3.tar.bz2
gentoo-2-d222431cd528801edbdb365f7d137a20b4266ee3.zip
Bump. Adds input device properties support. IDP are modelled after window properties and work much in the same manner. Each X Input device can have multiple properties of arbitrary types at any point in time. These properties can be interpreted by the server and/or the driver and thus allow cheap, easily expandable ways of configuring devices.
(Portage version: 2.1.6_rc2/cvs/Linux 2.6.28-rc6 x86_64)
Diffstat (limited to 'x11-libs/libXi')
-rw-r--r--x11-libs/libXi/ChangeLog13
-rw-r--r--x11-libs/libXi/libXi-1.2.0.ebuild25
2 files changed, 36 insertions, 2 deletions
diff --git a/x11-libs/libXi/ChangeLog b/x11-libs/libXi/ChangeLog
index b6c894494404..3b3cd74763aa 100644
--- a/x11-libs/libXi/ChangeLog
+++ b/x11-libs/libXi/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for x11-libs/libXi
-# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/libXi/ChangeLog,v 1.57 2007/12/19 23:52:18 cla Exp $
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/libXi/ChangeLog,v 1.58 2008/12/04 04:45:21 dberkholz Exp $
+
+*libXi-1.2.0 (04 Dec 2008)
+
+ 04 Dec 2008; Donnie Berkholz <dberkholz@gentoo.org>; +libXi-1.2.0.ebuild:
+ Bump. Adds input device properties support. IDP are modelled after window
+ properties and work much in the same manner. Each X Input device can have
+ multiple properties of arbitrary types at any point in time. These
+ properties can be interpreted by the server and/or the driver and thus
+ allow cheap, easily expandable ways of configuring devices.
19 Dec 2007; Dawid Węgliński <cla@gentoo.org> libXi-1.1.3.ebuild:
Stable on x86 (bug #202087)
diff --git a/x11-libs/libXi/libXi-1.2.0.ebuild b/x11-libs/libXi/libXi-1.2.0.ebuild
new file mode 100644
index 000000000000..af50739c816b
--- /dev/null
+++ b/x11-libs/libXi/libXi-1.2.0.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/libXi/libXi-1.2.0.ebuild,v 1.1 2008/12/04 04:45:21 dberkholz Exp $
+
+# Must be before x-modular eclass is inherited
+#SNAPSHOT="yes"
+
+inherit x-modular
+
+DESCRIPTION="X.Org Xi library"
+
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+
+RDEPEND="x11-libs/libX11
+ x11-libs/libXext"
+DEPEND="${RDEPEND}
+ x11-proto/xproto
+ >=x11-proto/inputproto-1.4"
+
+pkg_postinst() {
+ x-modular_pkg_postinst
+
+ ewarn "Some special keys and keyboard layouts may stop working."
+ ewarn "To fix them, recompile xorg-server."
+}