summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRémi Cardona <remi@gentoo.org>2009-04-29 11:38:35 +0000
committerRémi Cardona <remi@gentoo.org>2009-04-29 11:38:35 +0000
commit1627730788d9be9fdf2ea2f3cef890d28e294471 (patch)
tree25fa61af37761e815abd6541d030b8017546c758 /x11-libs/libXfont/libXfont-1.4.0.ebuild
parentm68k stable (diff)
downloadgentoo-2-1627730788d9be9fdf2ea2f3cef890d28e294471.tar.gz
gentoo-2-1627730788d9be9fdf2ea2f3cef890d28e294471.tar.bz2
gentoo-2-1627730788d9be9fdf2ea2f3cef890d28e294471.zip
x11-libs/libXfont: import 1.4.0 from the x11 overlay
(Portage version: 2.2_rc31/cvs/Linux x86_64)
Diffstat (limited to 'x11-libs/libXfont/libXfont-1.4.0.ebuild')
-rw-r--r--x11-libs/libXfont/libXfont-1.4.0.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/x11-libs/libXfont/libXfont-1.4.0.ebuild b/x11-libs/libXfont/libXfont-1.4.0.ebuild
new file mode 100644
index 000000000000..e0a9a49ffe7e
--- /dev/null
+++ b/x11-libs/libXfont/libXfont-1.4.0.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/libXfont/libXfont-1.4.0.ebuild,v 1.1 2009/04/29 11:38:35 remi Exp $
+
+# Must be before x-modular eclass is inherited
+# SNAPSHOT="yes"
+
+inherit x-modular flag-o-matic
+
+DESCRIPTION="X.Org Xfont library"
+
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="ipv6"
+
+RDEPEND="x11-libs/xtrans
+ x11-libs/libfontenc
+ x11-proto/xproto
+ x11-proto/fontsproto
+ >=media-libs/freetype-2"
+DEPEND="${RDEPEND}
+ x11-proto/fontcacheproto"
+
+CONFIGURE_OPTIONS="$(use_enable ipv6)
+ --with-bzip2
+ --with-encodingsdir=/usr/share/fonts/encodings"
+
+pkg_setup() {
+ # No such function yet
+ # x-modular_pkg_setup
+
+ # (#125465) Broken with Bdirect support
+ filter-flags -Wl,-Bdirect
+ filter-ldflags -Bdirect
+ filter-ldflags -Wl,-Bdirect
+}