summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2009-05-04 15:09:18 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2009-05-04 15:09:18 +0000
commit051890d253238e56eaf714c8c1ca3969b3768a88 (patch)
tree3008dafa351ac94eb4cace664280424a1ef18521 /x11-libs/libX11/libX11-1.1.5.ebuild
parentMove use_ functions out of global scope. (diff)
downloadgentoo-2-051890d253238e56eaf714c8c1ca3969b3768a88.tar.gz
gentoo-2-051890d253238e56eaf714c8c1ca3969b3768a88.tar.bz2
gentoo-2-051890d253238e56eaf714c8c1ca3969b3768a88.zip
Move use_ functions out of global scope.
(Portage version: 2.1.6.13/cvs/Linux x86_64)
Diffstat (limited to 'x11-libs/libX11/libX11-1.1.5.ebuild')
-rw-r--r--x11-libs/libX11/libX11-1.1.5.ebuild12
1 files changed, 7 insertions, 5 deletions
diff --git a/x11-libs/libX11/libX11-1.1.5.ebuild b/x11-libs/libX11/libX11-1.1.5.ebuild
index 7e8e721de49b..3f127951e061 100644
--- a/x11-libs/libX11/libX11-1.1.5.ebuild
+++ b/x11-libs/libX11/libX11-1.1.5.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/libX11/libX11-1.1.5.ebuild,v 1.8 2009/04/16 01:56:01 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/libX11/libX11-1.1.5.ebuild,v 1.9 2009/05/04 15:09:18 ssuominen Exp $
# Must be before x-modular eclass is inherited
#SNAPSHOT="yes"
@@ -25,10 +25,12 @@ DEPEND="${RDEPEND}
x11-proto/xcmiscproto
>=x11-misc/util-macros-0.99.0_p20051007"
-CONFIGURE_OPTIONS="$(use_enable ipv6)
- $(use_with xcb)"
-# xorg really doesn't like xlocale disabled.
-# $(use_enable nls xlocale)
+pkg_setup() {
+ CONFIGURE_OPTIONS="$(use_enable ipv6)
+ $(use_with xcb)"
+ # xorg really doesn't like xlocale disabled.
+ # $(use_enable nls xlocale)
+}
x-modular_src_compile() {
x-modular_src_configure