summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2009-10-29 21:28:22 +0000
committerGilles Dartiguelongue <eva@gentoo.org>2009-10-29 21:28:22 +0000
commit8e65df96e3bb6e513626dd844749858c4ac1f621 (patch)
tree5217a2deceb8d206143708073389dc338b01dd1d /x11-libs/gtksourceview
parentAutomated update of use.local.desc (diff)
downloadgentoo-2-8e65df96e3bb6e513626dd844749858c4ac1f621.tar.gz
gentoo-2-8e65df96e3bb6e513626dd844749858c4ac1f621.tar.bz2
gentoo-2-8e65df96e3bb6e513626dd844749858c4ac1f621.zip
New version for GNOME 2.28.
(Portage version: 2.2_rc46/cvs/Linux x86_64)
Diffstat (limited to 'x11-libs/gtksourceview')
-rw-r--r--x11-libs/gtksourceview/ChangeLog12
-rw-r--r--x11-libs/gtksourceview/files/2.0/gentoo.lang2
-rw-r--r--x11-libs/gtksourceview/gtksourceview-2.8.1.ebuild35
3 files changed, 47 insertions, 2 deletions
diff --git a/x11-libs/gtksourceview/ChangeLog b/x11-libs/gtksourceview/ChangeLog
index ccc6c9955fee..8484491e43aa 100644
--- a/x11-libs/gtksourceview/ChangeLog
+++ b/x11-libs/gtksourceview/ChangeLog
@@ -1,6 +1,16 @@
# ChangeLog for x11-libs/gtksourceview
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/gtksourceview/ChangeLog,v 1.164 2009/10/28 22:53:13 eva Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/gtksourceview/ChangeLog,v 1.165 2009/10/29 21:28:21 eva Exp $
+
+ 29 Oct 2009; Gilles Dartiguelongue <eva@gentoo.org> files/2.0/gentoo.lang,
+ +gtksourceview-2.8.1.ebuild:
+ New version for GNOME 2.28.
+
+*gtksourceview-2.8.1 (29 Oct 2009)
+
+ 29 Oct 2009; Gilles Dartiguelongue <eva@gentoo.org> files/2.0/gentoo.lang,
+ +gtksourceview-2.8.1.ebuild:
+ New version for GNOME 2.28.
28 Oct 2009; Gilles Dartiguelongue <eva@gentoo.org> files/2.0/gentoo.lang,
-gtksourceview-2.6.1.ebuild, files/gentoo.lang:
diff --git a/x11-libs/gtksourceview/files/2.0/gentoo.lang b/x11-libs/gtksourceview/files/2.0/gentoo.lang
index ef0c4a7a5449..3aa3a332faa0 100644
--- a/x11-libs/gtksourceview/files/2.0/gentoo.lang
+++ b/x11-libs/gtksourceview/files/2.0/gentoo.lang
@@ -88,7 +88,7 @@
<!-- extra portage commands -->
<context id="portcmds" style-ref="command">
- <match>\b(e(begin|end|conf|install|make|warn|infon?|error|patch|log|javac|ant)|die|use(_(with|enable))?|inherit|has|(has|best)_version|unpack|(do|new)(ins|s?bin|doc|lib(|\.so|\.a)|man|info|exe|initd|confd|envd|pam|menu|icon)|do(python|sed|dir|hard|sym|html|jar|mo)|keepdir|prepall(|docs|info|man|strip)|prep(info|lib|lib\.(so|a)|man|strip)|(|doc|ins|exe)into|f(owners|perms)|(exe|ins|dir)opts)\b</match>
+ <match>\b(e(begin|end|conf|install|make|warn|infon?|error|patch)|die|use(_(with|enable))?|inherit|has|(has|best)_version|unpack|(do|new)(ins|s?bin|doc|lib(|\.so|\.a)|man|info|exe|initd|confd|envd|pam|menu|icon)|do(python|sed|dir|hard|sym|html|jar|mo)|keepdir|prepall(|docs|info|man|strip)|prep(info|lib|lib\.(so|a)|man|strip)|(|doc|ins|exe)into|f(owners|perms)|(exe|ins|dir)opts)\b</match>
</context>
<context id="built-in-command">
diff --git a/x11-libs/gtksourceview/gtksourceview-2.8.1.ebuild b/x11-libs/gtksourceview/gtksourceview-2.8.1.ebuild
new file mode 100644
index 000000000000..fcd89c6a9711
--- /dev/null
+++ b/x11-libs/gtksourceview/gtksourceview-2.8.1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/gtksourceview/gtksourceview-2.8.1.ebuild,v 1.1 2009/10/29 21:28:21 eva Exp $
+
+GCONF_DEBUG="no"
+
+inherit gnome2
+
+DESCRIPTION="A text widget implementing syntax highlighting and other features"
+HOMEPAGE="http://www.gnome.org/"
+
+LICENSE="GPL-2"
+SLOT="2.0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="doc"
+
+RDEPEND=">=x11-libs/gtk+-2.12
+ >=dev-libs/libxml2-2.5
+ >=dev-libs/glib-2.14"
+DEPEND="${RDEPEND}
+ sys-devel/gettext
+ >=dev-util/intltool-0.40
+ >=dev-util/pkgconfig-0.9
+ doc? ( >=dev-util/gtk-doc-1 )"
+
+DOCS="AUTHORS ChangeLog HACKING MAINTAINERS NEWS README"
+
+src_install() {
+ gnome2_src_install
+
+ find "${D}" -name "*.la" -delete || die "remove of la files failed"
+
+ insinto /usr/share/${PN}-2.0/language-specs
+ doins "${FILESDIR}"/2.0/gentoo.lang || die "doins failed"
+}