summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2008-04-09 21:43:10 +0000
committerGilles Dartiguelongue <eva@gentoo.org>2008-04-09 21:43:10 +0000
commit102156044c8190cb859f03fcb80886c3006983d6 (patch)
tree41bc1e9ddc34aacc78d3391e737a7e29460b5194 /x11-libs/gtksourceview
parentbump to 2.22.1, patches are gone. (diff)
downloadgentoo-2-102156044c8190cb859f03fcb80886c3006983d6.tar.gz
gentoo-2-102156044c8190cb859f03fcb80886c3006983d6.tar.bz2
gentoo-2-102156044c8190cb859f03fcb80886c3006983d6.zip
bump to 2.2.1. Bug fixes, translations updates and improved keybindings.
(Portage version: 2.1.5_rc2)
Diffstat (limited to 'x11-libs/gtksourceview')
-rw-r--r--x11-libs/gtksourceview/ChangeLog8
-rw-r--r--x11-libs/gtksourceview/gtksourceview-2.2.1.ebuild39
2 files changed, 46 insertions, 1 deletions
diff --git a/x11-libs/gtksourceview/ChangeLog b/x11-libs/gtksourceview/ChangeLog
index e4bbaf52c59c..fe3d228f938e 100644
--- a/x11-libs/gtksourceview/ChangeLog
+++ b/x11-libs/gtksourceview/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-libs/gtksourceview
# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/gtksourceview/ChangeLog,v 1.129 2008/03/21 16:57:57 leio Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/gtksourceview/ChangeLog,v 1.130 2008/04/09 21:43:10 eva Exp $
+
+*gtksourceview-2.2.1 (09 Apr 2008)
+
+ 09 Apr 2008; Gilles Dartiguelongue <eva@gentoo.org>
+ +gtksourceview-2.2.1.ebuild:
+ bump to 2.2.1. Bug fixes, translations updates and improved keybindings.
21 Mar 2008; Mart Raudsepp <leio@gentoo.org> gtksourceview-2.2.0.ebuild:
Fix up regex dependency handling - system pcre is never needed with the glib
diff --git a/x11-libs/gtksourceview/gtksourceview-2.2.1.ebuild b/x11-libs/gtksourceview/gtksourceview-2.2.1.ebuild
new file mode 100644
index 000000000000..693850e70960
--- /dev/null
+++ b/x11-libs/gtksourceview/gtksourceview-2.2.1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/gtksourceview/gtksourceview-2.2.1.ebuild,v 1.1 2008/04/09 21:43:10 eva Exp $
+
+inherit gnome2 eutils
+
+DESCRIPTION="A text widget implementing syntax highlighting and other features"
+HOMEPAGE="http://www.gnome.org/"
+
+LICENSE="GPL-2"
+SLOT="2.0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="doc"
+
+# glib-2.14 dep is to be sure GRegex exists, so that gtksourceview does not
+# build a copy of it. However gtk+-2.12 already can't work with lower version
+# than that
+RDEPEND=">=x11-libs/gtk+-2.12
+ >=dev-libs/libxml2-2.5
+ >=dev-libs/glib-2.14"
+DEPEND="${RDEPEND}
+ sys-devel/gettext
+ >=dev-util/intltool-0.35
+ >=dev-util/pkgconfig-0.9
+ doc? ( >=dev-util/gtk-doc-1 )"
+
+DOCS="AUTHORS ChangeLog HACKING MAINTAINERS NEWS README TODO"
+
+pkg_setup() {
+ # Removes the gnome-vfs dep
+ G2CONF="${G2CONF} --disable-build-tests"
+}
+
+src_install() {
+ gnome2_src_install
+
+ insinto /usr/share/${PN}-2.0/language-specs
+ doins "${FILESDIR}"/2.0/gentoo.lang
+}