summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2012-02-02 10:23:10 +0000
committerPacho Ramos <pacho@gentoo.org>2012-02-02 10:23:10 +0000
commitf29557d09a842bae670f31fc766078aec8608942 (patch)
tree87aad0eb2edeed455d5c65505f083008afc40994 /x11-libs/gtk+
parentVersion bump. (diff)
downloadgentoo-2-f29557d09a842bae670f31fc766078aec8608942.tar.gz
gentoo-2-f29557d09a842bae670f31fc766078aec8608942.tar.bz2
gentoo-2-f29557d09a842bae670f31fc766078aec8608942.zip
Don't crash when printing, upstream bug #543520, thanks to gringo for reporting.
(Portage version: 2.1.10.44/cvs/Linux x86_64)
Diffstat (limited to 'x11-libs/gtk+')
-rw-r--r--x11-libs/gtk+/ChangeLog9
-rw-r--r--x11-libs/gtk+/files/gtk+-2.24.9-printing-crash.patch135
-rw-r--r--x11-libs/gtk+/gtk+-2.24.9-r1.ebuild240
3 files changed, 383 insertions, 1 deletions
diff --git a/x11-libs/gtk+/ChangeLog b/x11-libs/gtk+/ChangeLog
index dc96030b4692..379bb6f31016 100644
--- a/x11-libs/gtk+/ChangeLog
+++ b/x11-libs/gtk+/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for x11-libs/gtk+
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/gtk+/ChangeLog,v 1.560 2012/01/29 10:51:28 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/gtk+/ChangeLog,v 1.561 2012/02/02 10:23:10 pacho Exp $
+
+*gtk+-2.24.9-r1 (02 Feb 2012)
+
+ 02 Feb 2012; Pacho Ramos <pacho@gentoo.org>
+ +files/gtk+-2.24.9-printing-crash.patch, +gtk+-2.24.9-r1.ebuild:
+ Don't crash when printing, upstream bug #543520, thanks to gringo for
+ reporting.
*gtk+-2.24.9 (29 Jan 2012)
diff --git a/x11-libs/gtk+/files/gtk+-2.24.9-printing-crash.patch b/x11-libs/gtk+/files/gtk+-2.24.9-printing-crash.patch
new file mode 100644
index 000000000000..b6558f71e61f
--- /dev/null
+++ b/x11-libs/gtk+/files/gtk+-2.24.9-printing-crash.patch
@@ -0,0 +1,135 @@
+From 66c99016d3d063aee0e00793da8f087c80172012 Mon Sep 17 00:00:00 2001
+From: Marek Kasik <mkasik@redhat.com>
+Date: Tue, 31 Jan 2012 11:01:43 +0000
+Subject: printing: Don't crash when printing
+
+This commit fixes crash which occurs in Firefox, Thunderbird and Inkscape
+during printing. This crash was caused because of wrong handling of Custom
+CUPS options. (#543520)
+---
+diff --git a/modules/printbackends/cups/gtkprintbackendcups.c b/modules/printbackends/cups/gtkprintbackendcups.c
+index 138bddd..59914ba 100644
+--- a/modules/printbackends/cups/gtkprintbackendcups.c
++++ b/modules/printbackends/cups/gtkprintbackendcups.c
+@@ -485,7 +485,7 @@ cups_print_cb (GtkPrintBackendCups *print_backend,
+
+ typedef struct {
+ GtkCupsRequest *request;
+- GtkPrinterOptionSet *options;
++ GtkPrinterCups *printer;
+ } CupsOptionsData;
+
+ static void
+@@ -495,9 +495,13 @@ add_cups_options (const gchar *key,
+ {
+ CupsOptionsData *data = (CupsOptionsData *) user_data;
+ GtkCupsRequest *request = data->request;
+- GtkPrinterOptionSet *options = data->options;
+- GtkPrinterOption *option = NULL;
++ GtkPrinterCups *printer = data->printer;
++ gboolean custom_value = FALSE;
+ gchar *new_value = NULL;
++ gint i;
++
++ if (!key || !value)
++ return;
+
+ if (!g_str_has_prefix (key, "cups-"))
+ return;
+@@ -505,17 +509,37 @@ add_cups_options (const gchar *key,
+ if (strcmp (value, "gtk-ignore-value") == 0)
+ return;
+
+- option = gtk_printer_option_set_lookup (options, key);
+-
+ key = key + strlen ("cups-");
+
+- /* Add "Custom." prefix to custom values */
+- if (value && option &&
+- !gtk_printer_option_has_choice (option, value))
+- new_value = g_strdup_printf ("Custom.%s", value);
++ if (printer && printer->ppd_file)
++ {
++ ppd_coption_t *coption;
++ gboolean found = FALSE;
++ gboolean custom_values_enabled = FALSE;
++
++ coption = ppdFindCustomOption (printer->ppd_file, key);
++ if (coption && coption->option)
++ {
++ for (i = 0; i < coption->option->num_choices; i++)
++ {
++ /* Are custom values enabled ? */
++ if (g_str_equal (coption->option->choices[i].choice, "Custom"))
++ custom_values_enabled = TRUE;
++
++ /* Is the value among available choices ? */
++ if (g_str_equal (coption->option->choices[i].choice, value))
++ found = TRUE;
++ }
+
+- if (new_value)
++ if (custom_values_enabled && !found)
++ custom_value = TRUE;
++ }
++ }
++
++ /* Add "Custom." prefix to custom values. */
++ if (custom_value)
+ {
++ new_value = g_strdup_printf ("Custom.%s", value);
+ gtk_cups_request_encode_option (request, key, new_value);
+ g_free (new_value);
+ }
+@@ -536,9 +560,6 @@ gtk_print_backend_cups_print_stream (GtkPrintBackend *print_backend,
+ CupsOptionsData *options_data;
+ GtkCupsRequest *request;
+ GtkPrintSettings *settings;
+- GtkPrinterOptionSet *options;
+- GtkPrintCapabilities capabilities;
+- GtkPageSetup *page_setup;
+ const gchar *title;
+ char printer_absolute_uri[HTTP_MAX_URI];
+
+@@ -547,8 +568,6 @@ gtk_print_backend_cups_print_stream (GtkPrintBackend *print_backend,
+
+ cups_printer = GTK_PRINTER_CUPS (gtk_print_job_get_printer (job));
+ settings = gtk_print_job_get_settings (job);
+- capabilities = cups_printer_get_capabilities (GTK_PRINTER (cups_printer));
+- page_setup = gtk_printer_get_default_page_size (GTK_PRINTER (cups_printer));
+
+ request = gtk_cups_request_new_with_username (NULL,
+ GTK_CUPS_POST,
+@@ -586,16 +605,10 @@ gtk_print_backend_cups_print_stream (GtkPrintBackend *print_backend,
+ IPP_TAG_NAME, "job-name",
+ NULL, title);
+
+- options = cups_printer_get_options (GTK_PRINTER (cups_printer), settings, page_setup, capabilities);
+-
+ options_data = g_new0 (CupsOptionsData, 1);
+ options_data->request = request;
+- options_data->options = options;
+-
++ options_data->printer = cups_printer;
+ gtk_print_settings_foreach (settings, add_cups_options, options_data);
+-
+- g_object_unref (page_setup);
+- g_object_unref (options);
+ g_free (options_data);
+
+ ps = g_new0 (CupsPrintStreamData, 1);
+@@ -4606,7 +4619,12 @@ cups_printer_get_default_page_size (GtkPrinter *printer)
+ return NULL;
+
+ option = ppdFindOption (ppd_file, "PageSize");
++ if (option == NULL)
++ return NULL;
++
+ size = ppdPageSize (ppd_file, option->defchoice);
++ if (size == NULL)
++ return NULL;
+
+ return create_page_setup (ppd_file, size);
+ }
+--
+cgit v0.9.0.2
diff --git a/x11-libs/gtk+/gtk+-2.24.9-r1.ebuild b/x11-libs/gtk+/gtk+-2.24.9-r1.ebuild
new file mode 100644
index 000000000000..d44e292e50f0
--- /dev/null
+++ b/x11-libs/gtk+/gtk+-2.24.9-r1.ebuild
@@ -0,0 +1,240 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/gtk+/gtk+-2.24.9-r1.ebuild,v 1.1 2012/02/02 10:23:10 pacho Exp $
+
+EAPI="4"
+PYTHON_DEPEND="2:2.4"
+
+inherit eutils flag-o-matic gnome.org libtool python virtualx autotools
+
+DESCRIPTION="Gimp ToolKit +"
+HOMEPAGE="http://www.gtk.org/"
+SRC_URI="${SRC_URI} mirror://gentoo/introspection.m4.bz2"
+
+LICENSE="LGPL-2"
+SLOT="2"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="aqua cups debug doc examples +introspection test vim-syntax xinerama"
+
+# NOTE: cairo[svg] dep is due to bug 291283 (not patched to avoid eautoreconf)
+COMMON_DEPEND="!aqua? (
+ x11-libs/libXrender
+ x11-libs/libX11
+ x11-libs/libXi
+ x11-libs/libXt
+ x11-libs/libXext
+ >=x11-libs/libXrandr-1.3
+ x11-libs/libXcursor
+ x11-libs/libXfixes
+ x11-libs/libXcomposite
+ x11-libs/libXdamage
+ >=x11-libs/cairo-1.6[X,svg]
+ x11-libs/gdk-pixbuf:2[X,introspection?]
+ )
+ aqua? (
+ >=x11-libs/cairo-1.6[aqua,svg]
+ x11-libs/gdk-pixbuf:2[introspection?]
+ )
+ xinerama? ( x11-libs/libXinerama )
+ >=dev-libs/glib-2.27.3:2
+ >=x11-libs/pango-1.20[introspection?]
+ >=dev-libs/atk-1.29.2[introspection?]
+ media-libs/fontconfig
+ x11-misc/shared-mime-info
+ cups? ( net-print/cups )
+ introspection? ( >=dev-libs/gobject-introspection-0.9.3 )
+ !<gnome-base/gail-1000"
+DEPEND="${COMMON_DEPEND}
+ >=dev-util/pkgconfig-0.9
+ !aqua? (
+ x11-proto/xextproto
+ x11-proto/xproto
+ x11-proto/inputproto
+ x11-proto/damageproto
+ )
+ xinerama? ( x11-proto/xineramaproto )
+ >=dev-util/gtk-doc-am-1.11
+ doc? (
+ >=dev-util/gtk-doc-1.11
+ ~app-text/docbook-xml-dtd-4.1.2 )
+ test? (
+ media-fonts/font-misc-misc
+ media-fonts/font-cursor-misc )"
+# gtk+-2.24.8 breaks Alt key handling in <=x11-libs/vte-0.28.2:0
+# Remove blocker after >=vte-0.28.2-r201:0 is stable
+RDEPEND="${COMMON_DEPEND}
+ !<x11-libs/vte-0.28.2-r201:0"
+PDEPEND="vim-syntax? ( app-vim/gtk-syntax )"
+
+strip_builddir() {
+ local rule=$1
+ shift
+ local directory=$1
+ shift
+ sed -e "s/^\(${rule} =.*\)${directory}\(.*\)$/\1\2/" -i $@ \
+ || die "Could not strip director ${directory} from build."
+}
+
+set_gtk2_confdir() {
+ # An arch specific config directory is used on multilib systems
+ GTK2_CONFDIR="/etc/gtk-2.0/${CHOST}"
+}
+
+src_prepare() {
+ # use an arch-specific config directory so that 32bit and 64bit versions
+ # dont clash on multilib systems
+ epatch "${FILESDIR}/${PN}-2.21.3-multilib.patch"
+
+ # Don't break inclusion of gtkclist.h, upstream bug 536767
+ epatch "${FILESDIR}/${PN}-2.14.3-limit-gtksignal-includes.patch"
+
+ # fix building with gir #372953, upstream bug #642085
+ epatch "${FILESDIR}"/${PN}-2.24.7-darwin-quartz-introspection.patch
+
+ # printing: Don't crash when printing, upstream bug #543520
+ epatch "${FILESDIR}"/${P}-printing-crash.patch
+
+ # Stop trying to build unmaintained docs, bug #349754
+ strip_builddir SUBDIRS tutorial docs/Makefile.am docs/Makefile.in
+ strip_builddir SUBDIRS faq docs/Makefile.am docs/Makefile.in
+
+ # -O3 and company cause random crashes in applications. Bug #133469
+ replace-flags -O3 -O2
+ strip-flags
+
+ use ppc64 && append-flags -mminimal-toc
+
+ if ! use test; then
+ # don't waste time building tests
+ strip_builddir SRC_SUBDIRS tests Makefile.am Makefile.in
+ else
+ # Non-working test in gentoo's env
+ sed 's:\(g_test_add_func ("/ui-tests/keys-events.*\):/*\1*/:g' \
+ -i gtk/tests/testing.c || die "sed 1 failed"
+
+ # Cannot work because glib is too clever to find real user's home
+ # gentoo bug #285687, upstream bug #639832
+ # XXX: /!\ Pay extra attention to second sed when bumping /!\
+ sed '/TEST_PROGS.*recentmanager/d' -i gtk/tests/Makefile.am \
+ || die "failed to disable recentmanager test (1)"
+ sed '/^TEST_PROGS =/,+3 s/recentmanager//' -i gtk/tests/Makefile.in \
+ || die "failed to disable recentmanager test (2)"
+ sed 's:\({ "GtkFileChooserButton".*},\):/*\1*/:g' -i gtk/tests/object.c \
+ || die "failed to disable recentmanager test (3)"
+
+ # Skip tests known to fail
+ # https://bugzilla.gnome.org/show_bug.cgi?id=646609
+ sed -e '/g_test_add_func.*test_text_access/s:^://:' \
+ -i "${S}/gtk/tests/testing.c" || die
+
+ # https://bugzilla.gnome.org/show_bug.cgi?id=617473
+ sed -i -e 's:pltcheck.sh:$(NULL):g' \
+ gtk/Makefile.am || die
+ fi
+
+ if ! use examples; then
+ # don't waste time building demos
+ strip_builddir SRC_SUBDIRS demos Makefile.am Makefile.in
+ fi
+
+ # http://bugs.gentoo.org/show_bug.cgi?id=371907
+ mkdir -p "${S}/m4" || die
+ mv "${WORKDIR}/introspection.m4" "${S}/m4macros" || die
+ AT_M4DIR=m4macros eautoreconf
+ # Use elibtoolize in place of eautoreconf when it will be dropped
+ #elibtoolize
+}
+
+src_configure() {
+ local myconf="$(use_enable doc gtk-doc)
+ $(use_enable xinerama)
+ $(use_enable cups cups auto)
+ $(use_enable introspection)
+ --disable-papi"
+ if use aqua; then
+ myconf="${myconf} --with-gdktarget=quartz"
+ else
+ myconf="${myconf} --with-gdktarget=x11 --with-xinput"
+ fi
+
+ # Passing --disable-debug is not recommended for production use
+ use debug && myconf="${myconf} --enable-debug=yes"
+
+ econf ${myconf}
+}
+
+src_test() {
+ unset DBUS_SESSION_BUS_ADDRESS
+ # Exporting HOME fixes tests using XDG directories spec since all defaults
+ # are based on $HOME. It is also backward compatible with functions not
+ # yet ported to this spec.
+ XDG_DATA_HOME="${T}" HOME="${T}" Xemake check || die "tests failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+
+ set_gtk2_confdir
+ dodir ${GTK2_CONFDIR}
+ keepdir ${GTK2_CONFDIR}
+
+ # see bug #133241
+ echo 'gtk-fallback-icon-theme = "gnome"' > "${T}/gtkrc"
+ insinto /etc/gtk-2.0
+ doins "${T}"/gtkrc
+
+ # Enable xft in environment as suggested by <utx@gentoo.org>
+ echo "GDK_USE_XFT=1" > "${T}"/50gtk2
+ doenvd "${T}"/50gtk2
+
+ dodoc AUTHORS ChangeLog* HACKING NEWS* README*
+
+ # add -framework Carbon to the .pc files
+ use aqua && for i in gtk+-2.0.pc gtk+-quartz-2.0.pc gtk+-unix-print-2.0.pc; do
+ sed -i -e "s:Libs\: :Libs\: -framework Carbon :" "${ED%/}"/usr/lib/pkgconfig/$i || die "sed failed"
+ done
+
+ python_convert_shebangs 2 "${ED}"usr/bin/gtk-builder-convert
+
+ find "${D}" -name '*.la' -exec rm -f {} +
+}
+
+pkg_postinst() {
+ set_gtk2_confdir
+
+ # gtk.immodules should be in their CHOST directories respectively.
+ gtk-query-immodules-2.0 > "${EROOT%/}${GTK2_CONFDIR}/gtk.immodules" \
+ || ewarn "Failed to run gtk-query-immodules-2.0"
+
+ if [ -e "${EROOT%/}/etc/gtk-2.0/gtk.immodules" ]; then
+ elog "File /etc/gtk-2.0/gtk.immodules has been moved to \$CHOST"
+ elog "aware location. Removing deprecated file."
+ rm -f ${EROOT%/}/etc/gtk-2.0/gtk.immodules
+ fi
+
+ # pixbufs are now handled by x11-libs/gdk-pixbuf
+ if [ -e "${EROOT%/}${GTK2_CONFDIR}/gdk-pixbuf.loaders" ]; then
+ elog "File ${EROOT%/}${GTK2_CONFDIR}/gdk-pixbuf.loaders is now handled by x11-libs/gdk-pixbuf"
+ elog "Removing deprecated file."
+ rm -f ${EROOT%/}${GTK2_CONFDIR}/gdk-pixbuf.loaders
+ fi
+
+ # two checks needed since we dropped multilib conditional
+ if [ -e "${EROOT%/}/etc/gtk-2.0/gdk-pixbuf.loaders" ]; then
+ elog "File ${EROOT%/}/etc/gtk-2.0/gdk-pixbuf.loaders is now handled by x11-libs/gdk-pixbuf"
+ elog "Removing deprecated file."
+ rm -f ${EROOT%/}/etc/gtk-2.0/gdk-pixbuf.loaders
+ fi
+
+ if [ -e "${EROOT%/}"/usr/lib/gtk-2.0/2.[^1]* ]; then
+ elog "You need to rebuild ebuilds that installed into" "${EROOT%/}"/usr/lib/gtk-2.0/2.[^1]*
+ elog "to do that you can use qfile from portage-utils:"
+ elog "emerge -va1 \$(qfile -qC ${EPREFIX}/usr/lib/gtk-2.0/2.[^1]*)"
+ fi
+
+ if ! has_version "app-text/evince"; then
+ elog "Please install app-text/evince for print preview functionality."
+ elog "Alternatively, check \"gtk-print-preview-command\" documentation and"
+ elog "add it to your gtkrc."
+ fi
+}