summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2010-03-22 20:25:01 +0000
committerPacho Ramos <pacho@gentoo.org>2010-03-22 20:25:01 +0000
commitdc66cbea86913a4bcc0e911abb2f6090c5368271 (patch)
tree6c5be60c6c5e26f6035d3d71b1bc1de15ef99660 /x11-libs/gtk+
parentVersion bump. (diff)
downloadgentoo-2-dc66cbea86913a4bcc0e911abb2f6090c5368271.tar.gz
gentoo-2-dc66cbea86913a4bcc0e911abb2f6090c5368271.tar.bz2
gentoo-2-dc66cbea86913a4bcc0e911abb2f6090c5368271.zip
Version bump and cleaning old testing version
(Portage version: 2.1.7.17/cvs/Linux x86_64)
Diffstat (limited to 'x11-libs/gtk+')
-rw-r--r--x11-libs/gtk+/ChangeLog8
-rw-r--r--x11-libs/gtk+/files/gtk+-2.18.9-notifications-gtkentry.patch36
-rw-r--r--x11-libs/gtk+/gtk+-2.18.9.ebuild (renamed from x11-libs/gtk+/gtk+-2.18.7-r1.ebuild)6
3 files changed, 46 insertions, 4 deletions
diff --git a/x11-libs/gtk+/ChangeLog b/x11-libs/gtk+/ChangeLog
index 89ab30cbf6a9..999d66f6927d 100644
--- a/x11-libs/gtk+/ChangeLog
+++ b/x11-libs/gtk+/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-libs/gtk+
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/gtk+/ChangeLog,v 1.447 2010/03/11 14:52:23 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/gtk+/ChangeLog,v 1.448 2010/03/22 20:25:00 pacho Exp $
+
+*gtk+-2.18.9 (22 Mar 2010)
+
+ 22 Mar 2010; Pacho Ramos <pacho@gentoo.org> -gtk+-2.18.7-r1.ebuild,
+ +gtk+-2.18.9.ebuild, +files/gtk+-2.18.9-notifications-gtkentry.patch:
+ Version bump with multiple bugfixes, cleaning old testing version
*gtk+-2.18.7-r1 (11 Mar 2010)
diff --git a/x11-libs/gtk+/files/gtk+-2.18.9-notifications-gtkentry.patch b/x11-libs/gtk+/files/gtk+-2.18.9-notifications-gtkentry.patch
new file mode 100644
index 000000000000..9ce97f330308
--- /dev/null
+++ b/x11-libs/gtk+/files/gtk+-2.18.9-notifications-gtkentry.patch
@@ -0,0 +1,36 @@
+From 0fff51eab6427ca4d0ab679c1d994a2a36898a7d Mon Sep 17 00:00:00 2001
+From: Matthias Clasen <mclasen@redhat.com>
+Date: Sat, 20 Mar 2010 03:20:38 +0000
+Subject: Avoid spurious notifications from GtkEntry
+
+Using gtk_entry_set_buffer() in dispose() causes problematic
+notifications, so just get rid of the buffer manually. See bug 613241.
+(cherry picked from commit 5f29a679f8a31b6548f34179d65a39de9ec63535)
+---
+diff --git a/gtk/gtkentry.c b/gtk/gtkentry.c
+index 4344449..0dafcf7 100644
+--- a/gtk/gtkentry.c
++++ b/gtk/gtkentry.c
+@@ -2425,12 +2425,19 @@ static void
+ gtk_entry_dispose (GObject *object)
+ {
+ GtkEntry *entry = GTK_ENTRY (object);
++ GtkEntryPrivate *priv = GTK_ENTRY_GET_PRIVATE (entry);
+
+ gtk_entry_set_icon_from_pixbuf (entry, GTK_ENTRY_ICON_PRIMARY, NULL);
+ gtk_entry_set_icon_tooltip_markup (entry, GTK_ENTRY_ICON_PRIMARY, NULL);
+ gtk_entry_set_icon_from_pixbuf (entry, GTK_ENTRY_ICON_SECONDARY, NULL);
+ gtk_entry_set_icon_tooltip_markup (entry, GTK_ENTRY_ICON_SECONDARY, NULL);
+- gtk_entry_set_buffer (entry, NULL);
++
++ if (priv->buffer)
++ {
++ buffer_disconnect_signals (entry);
++ g_object_unref (priv->buffer);
++ priv->buffer = NULL;
++ }
+
+ G_OBJECT_CLASS (gtk_entry_parent_class)->dispose (object);
+ }
+--
+cgit v0.8.3.1
diff --git a/x11-libs/gtk+/gtk+-2.18.7-r1.ebuild b/x11-libs/gtk+/gtk+-2.18.9.ebuild
index 8ff553e3b9da..c776ac0399a6 100644
--- a/x11-libs/gtk+/gtk+-2.18.7-r1.ebuild
+++ b/x11-libs/gtk+/gtk+-2.18.9.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/gtk+/gtk+-2.18.7-r1.ebuild,v 1.1 2010/03/11 14:52:23 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/gtk+/gtk+-2.18.9.ebuild,v 1.1 2010/03/22 20:25:00 pacho Exp $
EAPI="2"
@@ -86,8 +86,8 @@ src_prepare() {
# add correct framework linking options, for aqua
epatch "${FILESDIR}/${PN}-2.18.5-macosx-aqua.patch"
- # Fix chromium crash, bug 308985
- epatch "${FILESDIR}/${PN}-2.18.7-destroy-crash.patch"
+ # Fix gtkentry setting its buffer to null on destroy, upstream bug 613241
+ epatch "${FILESDIR}/${PN}-2.18.9-notifications-gtkentry.patch"
# -O3 and company cause random crashes in applications. Bug #133469
replace-flags -O3 -O2