summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHerbie Hopkins <herbs@gentoo.org>2005-04-18 16:06:18 +0000
committerHerbie Hopkins <herbs@gentoo.org>2005-04-18 16:06:18 +0000
commitca649432f0cdc65b21c25cfd49254586bf3568ce (patch)
tree3445c8b6a4fd6e6c49a813e41f3d63866d4b09c5 /x11-libs/gtk+
parentRemove old move of mono that was causing a circular move problem. (diff)
downloadgentoo-2-ca649432f0cdc65b21c25cfd49254586bf3568ce.tar.gz
gentoo-2-ca649432f0cdc65b21c25cfd49254586bf3568ce.tar.bz2
gentoo-2-ca649432f0cdc65b21c25cfd49254586bf3568ce.zip
Minor multilib cleanup.
(Portage version: 2.0.51.19)
Diffstat (limited to 'x11-libs/gtk+')
-rw-r--r--x11-libs/gtk+/ChangeLog5
-rw-r--r--x11-libs/gtk+/Manifest4
-rw-r--r--x11-libs/gtk+/gtk+-2.6.7.ebuild19
3 files changed, 15 insertions, 13 deletions
diff --git a/x11-libs/gtk+/ChangeLog b/x11-libs/gtk+/ChangeLog
index a6dcacdfdd38..9bc3d6143357 100644
--- a/x11-libs/gtk+/ChangeLog
+++ b/x11-libs/gtk+/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for x11-libs/gtk+
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/gtk+/ChangeLog,v 1.157 2005/04/16 11:50:03 foser Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/gtk+/ChangeLog,v 1.158 2005/04/18 16:06:18 herbs Exp $
+
+ 18 Apr 2005; Herbie Hopkins <herbs@gentoo.org> gtk+-2.6.7.ebuild:
+ Minor multilib cleanup.
*gtk+-2.6.7 (16 Apr 2005)
diff --git a/x11-libs/gtk+/Manifest b/x11-libs/gtk+/Manifest
index 2371ef394d3c..225973295ac8 100644
--- a/x11-libs/gtk+/Manifest
+++ b/x11-libs/gtk+/Manifest
@@ -6,8 +6,8 @@ MD5 cc82c88ecc09a6160980805e484421ac gtk+-2.4.14.ebuild 2916
MD5 d0160ef5c7f542df383228f3a040580e gtk+-2.4.9-r1.ebuild 3139
MD5 afb0e5aa8f6410c088c2e177a17efe5d gtk+-1.2.10-r10.ebuild 1719
MD5 55a0240fe45beae9e83402b8bd3f8cbf gtk+-2.6.1-r2.ebuild 3279
-MD5 670f6b56f57f6c4b54df3e6aa3178f0b gtk+-2.6.7.ebuild 2901
-MD5 f6518ee7f2fb8c7f18a8cbc8590cbfa9 ChangeLog 23134
+MD5 a5061c0afbf7c654c30a08fec05fbfbd gtk+-2.6.7.ebuild 2868
+MD5 d2a22d9381ec84dbb8638ab752ab4761 ChangeLog 23229
MD5 ef2a0dc4245e964cf21ba8b20a3ad067 gtk+-2.6.2.ebuild 3036
MD5 03ad2e6c4ab41244af1015a8bbb0b39f metadata.xml 158
MD5 b63cd20330898c8115bb7f119e4c60b6 gtk+-2.4.9-r2.ebuild 3178
diff --git a/x11-libs/gtk+/gtk+-2.6.7.ebuild b/x11-libs/gtk+/gtk+-2.6.7.ebuild
index 76bb88b13421..40bc1fdfbede 100644
--- a/x11-libs/gtk+/gtk+-2.6.7.ebuild
+++ b/x11-libs/gtk+/gtk+-2.6.7.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/gtk+/gtk+-2.6.7.ebuild,v 1.1 2005/04/16 11:50:03 foser Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/gtk+/gtk+-2.6.7.ebuild,v 1.2 2005/04/18 16:06:18 herbs Exp $
inherit flag-o-matic eutils
@@ -31,6 +31,11 @@ DEPEND="${RDEPEND}
doc? ( >=dev-util/gtk-doc-1 )
!x11-themes/gtk-engines-pixmap"
+# An arch specific config directory is used on multilib systems
+has_multilib_profile && GTK2_CONFDIR="/etc/gtk-2.0/${CHOST}"
+use x86 && [ "$(get_libdir)" == "lib32" ] && GTK2_CONFDIR="/etc/gtk-2.0/${CHOST}"
+GTK2_CONFDIR=${GTK2_CONFDIR:=/etc/gtk-2.0/}
+
src_unpack() {
unpack ${A}
@@ -45,10 +50,10 @@ src_unpack() {
cd ${S}
# use an arch-specific config directory so that 32bit and 64bit versions
# dont clash on multilib systems
- use amd64 && epatch ${DISTDIR}/gtk+-2.6.1-lib64.patch.bz2
+ has_multilib_profile && epatch ${DISTDIR}/gtk+-2.6.1-lib64.patch.bz2
# and this line is just here to make building emul-linux-x86-gtklibs a bit
# easier, so even this should be amd64 specific.
- use x86 && [ "${CONF_LIBDIR}" == "lib32" ] && epatch ${DISTDIR}/gtk+-2.6.1-lib64.patch.bz2
+ use x86 && [ "$(get_libdir)" == "lib32" ] && epatch ${DISTDIR}/gtk+-2.6.1-lib64.patch.bz2
# patch for ppc64 (#64359)
use ppc64 && epatch ${FILESDIR}/${PN}-2.4.9-ppc64.patch
@@ -83,9 +88,7 @@ src_compile() {
src_install() {
- dodir /etc/gtk-2.0
- use amd64 && dodir /etc/gtk-2.0/${CHOST}
- use x86 && [ "${CONF_LIBDIR}" == "lib32" ] && dodir /etc/gtk-2.0/${CHOST}
+ dodir ${GTK2_CONFDIR}
make DESTDIR=${D} install || die
@@ -99,10 +102,6 @@ src_install() {
pkg_postinst() {
- use amd64 && GTK2_CONFDIR="/etc/gtk-2.0/${CHOST}"
- use x86 && [ "${CONF_LIBDIR}" == "lib32" ] && GTK2_CONFDIR="/etc/gtk-2.0/${CHOST}"
- GTK2_CONFDIR=${GTK2_CONFDIR:=/etc/gtk-2.0/}
-
gtk-query-immodules-2.0 > /${GTK2_CONFDIR}/gtk.immodules
gdk-pixbuf-query-loaders > /${GTK2_CONFDIR}/gdk-pixbuf.loaders