summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRomain Perier <mrpouet@gentoo.org>2009-09-06 14:39:44 +0000
committerRomain Perier <mrpouet@gentoo.org>2009-09-06 14:39:44 +0000
commita4d0cc1eb3a8ac975644a353c431550057fa6ba5 (patch)
treed57acf7bdd50b80825108f6b22620f75e0fca5a9 /x11-libs/gtk+
parentamd64/x86 stable, bug #281579 (diff)
downloadgentoo-2-a4d0cc1eb3a8ac975644a353c431550057fa6ba5.tar.gz
gentoo-2-a4d0cc1eb3a8ac975644a353c431550057fa6ba5.tar.bz2
gentoo-2-a4d0cc1eb3a8ac975644a353c431550057fa6ba5.zip
Fix jpeg7 blured images in gdk-pixbuf due to jpeg7 scale specs changes, per bug #282744
(Portage version: 2.2_rc40/cvs/Linux x86_64)
Diffstat (limited to 'x11-libs/gtk+')
-rw-r--r--x11-libs/gtk+/ChangeLog10
-rw-r--r--x11-libs/gtk+/files/gtk+-2.16.5-jpeg-backward-compatibility.patch27
-rw-r--r--x11-libs/gtk+/gtk+-2.16.5-r1.ebuild158
3 files changed, 194 insertions, 1 deletions
diff --git a/x11-libs/gtk+/ChangeLog b/x11-libs/gtk+/ChangeLog
index 1226653d9e08..54f4aebe346c 100644
--- a/x11-libs/gtk+/ChangeLog
+++ b/x11-libs/gtk+/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for x11-libs/gtk+
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/gtk+/ChangeLog,v 1.422 2009/07/19 23:25:17 eva Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/gtk+/ChangeLog,v 1.423 2009/09/06 14:39:44 mrpouet Exp $
+
+*gtk+-2.16.5-r1 (06 Sep 2009)
+
+ 06 Sep 2009; Romain Perier <mrpouet@gentoo.org>
+ +gtk+-2.16.5-r1.ebuild,
+ +files/gtk+-2.16.5-jpeg-backward-compatibility.patch:
+ Fix jpeg7 blured images in gdk-pixbuf due to jpeg7 scale specs changes,
+ per bug #282744.
*gtk+-2.16.5 (19 Jul 2009)
diff --git a/x11-libs/gtk+/files/gtk+-2.16.5-jpeg-backward-compatibility.patch b/x11-libs/gtk+/files/gtk+-2.16.5-jpeg-backward-compatibility.patch
new file mode 100644
index 000000000000..e359d0ce0c3e
--- /dev/null
+++ b/x11-libs/gtk+/files/gtk+-2.16.5-jpeg-backward-compatibility.patch
@@ -0,0 +1,27 @@
+Author: Romain Perier <mrpouet@gentoo.org>
+Subject: Ensure gdk-pixbuf is backward compatible with jpeg6, even if it's works with jpeg7
+Date: 2009-09-01 10:27 UTC
+
+Fix blured images in gdk-pixbuf due to jpeg7 scale specs changes.
+
+---
+ gdk-pixbuf/io-jpeg.c | 5 ++++-
+ 1 files changed, 4 insertions(+), 1 deletions(-)
+
+diff --git a/gdk-pixbuf/io-jpeg.c b/gdk-pixbuf/io-jpeg.c
+index cf8c9ed..9af55ba 100644
+--- a/gdk-pixbuf/io-jpeg.c
++++ b/gdk-pixbuf/io-jpeg.c
+@@ -921,8 +921,11 @@ gdk_pixbuf__jpeg_image_load_increment (gpointer data,
+ return FALSE;
+ }
+ }
+-
++#if JPEG_LIB_VERSION >= 70
++ for (cinfo->scale_denom = 2; cinfo->scale_denom <= 16; cinfo->scale_denom *= 2) {
++#else
+ for (cinfo->scale_denom = 2; cinfo->scale_denom <= 8; cinfo->scale_denom *= 2) {
++#endif
+ jpeg_calc_output_dimensions (cinfo);
+ if (cinfo->output_width < width || cinfo->output_height < height) {
+ cinfo->scale_denom /= 2;
diff --git a/x11-libs/gtk+/gtk+-2.16.5-r1.ebuild b/x11-libs/gtk+/gtk+-2.16.5-r1.ebuild
new file mode 100644
index 000000000000..284673012a79
--- /dev/null
+++ b/x11-libs/gtk+/gtk+-2.16.5-r1.ebuild
@@ -0,0 +1,158 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/gtk+/gtk+-2.16.5-r1.ebuild,v 1.1 2009/09/06 14:39:44 mrpouet Exp $
+
+EAPI="2"
+
+inherit gnome.org flag-o-matic eutils libtool virtualx
+
+DESCRIPTION="Gimp ToolKit +"
+HOMEPAGE="http://www.gtk.org/"
+
+LICENSE="LGPL-2"
+SLOT="2"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="cups debug doc jpeg jpeg2k tiff test vim-syntax xinerama"
+
+# FIXME: configure says >=xrandr-1.2.99 but remi tells me it's broken
+RDEPEND="x11-libs/libXrender
+ x11-libs/libX11
+ x11-libs/libXi
+ x11-libs/libXt
+ x11-libs/libXext
+ >=x11-libs/libXrandr-1.2
+ x11-libs/libXcursor
+ x11-libs/libXfixes
+ x11-libs/libXcomposite
+ x11-libs/libXdamage
+ xinerama? ( x11-libs/libXinerama )
+ >=dev-libs/glib-2.19.7
+ >=x11-libs/pango-1.20
+ >=dev-libs/atk-1.13
+ >=x11-libs/cairo-1.6[X]
+ media-libs/fontconfig
+ x11-misc/shared-mime-info
+ >=media-libs/libpng-1.2.1
+ cups? ( net-print/cups )
+ jpeg? ( >=media-libs/jpeg-6b-r2 )
+ jpeg2k? ( media-libs/jasper )
+ tiff? ( >=media-libs/tiff-3.5.7 )
+ !<gnome-base/gail-1000"
+DEPEND="${RDEPEND}
+ >=dev-util/pkgconfig-0.9
+ x11-proto/xextproto
+ x11-proto/xproto
+ x11-proto/inputproto
+ x11-proto/damageproto
+ xinerama? ( x11-proto/xineramaproto )
+ >=dev-util/gtk-doc-am-1.11
+ doc? (
+ >=dev-util/gtk-doc-1.11
+ ~app-text/docbook-xml-dtd-4.1.2 )
+ test? (
+ media-fonts/font-misc-misc
+ media-fonts/font-cursor-misc )"
+PDEPEND="vim-syntax? ( app-vim/gtk-syntax )"
+
+set_gtk2_confdir() {
+ # An arch specific config directory is used on multilib systems
+ has_multilib_profile && GTK2_CONFDIR="/etc/gtk-2.0/${CHOST}"
+ GTK2_CONFDIR=${GTK2_CONFDIR:=/etc/gtk-2.0}
+}
+
+src_prepare() {
+ # use an arch-specific config directory so that 32bit and 64bit versions
+ # dont clash on multilib systems
+ has_multilib_profile && epatch "${FILESDIR}/${PN}-2.8.0-multilib.patch"
+
+ # Don't break inclusion of gtkclist.h, upstream bug 536767
+ epatch "${FILESDIR}/${PN}-2.14.3-limit-gtksignal-includes.patch"
+
+ # Fix blured images when using jpeg7 in gdk-pixbuf, upstream
+ # bug #588740, gentoo bug #282744.
+ epatch "${FILESDIR}/${P}-jpeg-backward-compatibility.patch"
+
+ # -O3 and company cause random crashes in applications. Bug #133469
+ replace-flags -O3 -O2
+ strip-flags
+
+ use ppc64 && append-flags -mminimal-toc
+
+ # Non-working test in gentoo's env
+ sed 's:\(g_test_add_func ("/ui-tests/keys-events.*\):/*\1*/:g' \
+ -i gtk/tests/testing.c || die "sed 1 failed"
+ sed '\%/recent-manager/add%,/recent_manager_purge/ d' \
+ -i gtk/tests/recentmanager.c || die "sed 2 failed"
+ elibtoolize
+}
+
+src_configure() {
+ # png always on to display icons (foser)
+ local myconf="$(use_enable doc gtk-doc) \
+ $(use_with jpeg libjpeg) \
+ $(use_with jpeg2k libjasper) \
+ $(use_with tiff libtiff) \
+ $(use_enable xinerama) \
+ $(use_enable cups cups auto) \
+ --disable-papi \
+ --with-libpng \
+ --with-gdktarget=x11 \
+ --with-xinput"
+
+ # Passing --disable-debug is not recommended for production use
+ use debug && myconf="${myconf} --enable-debug=yes"
+
+ econf ${myconf}
+}
+
+src_test() {
+ unset DBUS_SESSION_BUS_ADDRESS
+ Xemake check || die "tests failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "Installation failed"
+
+ set_gtk2_confdir
+ dodir ${GTK2_CONFDIR}
+ keepdir ${GTK2_CONFDIR}
+
+ # see bug #133241
+ echo 'gtk-fallback-icon-theme = "gnome"' > "${D}/${GTK2_CONFDIR}/gtkrc"
+
+ # Enable xft in environment as suggested by <utx@gentoo.org>
+ dodir /etc/env.d
+ echo "GDK_USE_XFT=1" > "${D}/etc/env.d/50gtk2"
+
+ dodoc AUTHORS ChangeLog* HACKING NEWS* README* || die "dodoc failed"
+
+ # This has to be removed, because it's multilib specific; generated in
+ # postinst
+ rm "${D}/etc/gtk-2.0/gtk.immodules"
+}
+
+pkg_postinst() {
+ set_gtk2_confdir
+
+ if [ -d "${ROOT}${GTK2_CONFDIR}" ]; then
+ gtk-query-immodules-2.0 > "${ROOT}${GTK2_CONFDIR}/gtk.immodules"
+ gdk-pixbuf-query-loaders > "${ROOT}${GTK2_CONFDIR}/gdk-pixbuf.loaders"
+ else
+ ewarn "The destination path ${ROOT}${GTK2_CONFDIR} doesn't exist;"
+ ewarn "to complete the installation of GTK+, please create the"
+ ewarn "directory and then manually run:"
+ ewarn " cd ${ROOT}${GTK2_CONFDIR}"
+ ewarn " gtk-query-immodules-2.0 > gtk.immodules"
+ ewarn " gdk-pixbuf-query-loaders > gdk-pixbuf.loaders"
+ fi
+
+ if [ -e /usr/lib/gtk-2.0/2.[^1]* ]; then
+ elog "You need to rebuild ebuilds that installed into" /usr/lib/gtk-2.0/2.[^1]*
+ elog "to do that you can use qfile from portage-utils:"
+ elog "emerge -va1 \$(qfile -qC /usr/lib/gtk-2.0/2.[^1]*)"
+ fi
+
+ elog "Please install app-text/evince for print preview functionality."
+ elog "Alternatively, check \"gtk-print-preview-command\" documentation and"
+ elog "add it to your gtkrc."
+}